Best 802.11ac wireless settings for Asus RT-AC66u

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page 1, 2  Next
Author Message
cinetic
DD-WRT Novice


Joined: 30 Nov 2013
Posts: 9

PostPosted: Sat Nov 30, 2013 21:25    Post subject: Best 802.11ac wireless settings for Asus RT-AC66u Reply with quote
Just installed dd-wrt (latest build from 10/09/13) on my RT-AC66U but I have no idea which combination of wireless settings will yield 1000+ Mbps AC connection rates to my MacBook Pro.

I have tried having both radios be the same name, all in auto, and that yielded a 54 mbps connection rate, which is what I am currently connected at.

What are the best settings for this router to create a fast AC environment?

Thanks!
Sponsor
cinetic
DD-WRT Novice


Joined: 30 Nov 2013
Posts: 9

PostPosted: Sun Dec 01, 2013 10:02    Post subject: Reply with quote
Anyone? What do people with this router and dd-wrt set their wireless settings to?
Malitiacurt
DD-WRT User


Joined: 16 Aug 2012
Posts: 190

PostPosted: Sun Dec 01, 2013 11:41    Post subject: Reply with quote
Sounds like you turned off WMM. Don't.

Also, you can't connect to both radios at the same time from 1 client device like a laptop. Connect only to the 5GHz one (name them differently).

Finally, max AC speed provides for 3x3 is 1300Mbps (Assuming you have a newer MBP that supports AC). You won't get the 1750 marketing gimmick rates.
cinetic
DD-WRT Novice


Joined: 30 Nov 2013
Posts: 9

PostPosted: Sun Dec 01, 2013 23:14    Post subject: Reply with quote
So still no luck. Maybe I am running too recent of a build? I have:

DD-WRT v24-sp2 (10/09/13) - build 22490

And I am still connected at 54 mbps on the 5ghz radio with a separate name, at 802.11a (not ac!). So strange. I have the wireless settings set to:

Mixed on both radios
Auto wireless channel and channel width

I tried doing a factory reset, didn't help either. WMM is enabled, and I haven't changed any advanced settings.
cinetic
DD-WRT Novice


Joined: 30 Nov 2013
Posts: 9

PostPosted: Sun Dec 01, 2013 23:48    Post subject: Reply with quote
So with encryption set to AES, I am now connecting on 802.11ac, but the rates are awful - 176 mbps, versus the 800+ I was seeing with the stock firmware.

Has anyone successfully connected to this router at higher wireless rates with the dd-wrt firmware?
cinetic
DD-WRT Novice


Joined: 30 Nov 2013
Posts: 9

PostPosted: Mon Dec 02, 2013 0:16    Post subject: Reply with quote
I also noticed that if you change the channel on the 5ghz radio, it doesn't actually change it. Bug?

Unfortunately, I've gone back to the ugly stock firmware now. It at least gives me the wireless speeds (connected at 867 mbps right now) that I want.
<Kong>
DD-WRT Guru


Joined: 15 Dec 2010
Posts: 2078
Location: Germany

PostPosted: Mon Dec 02, 2013 6:57    Post subject: Reply with quote
cinetic wrote:
So with encryption set to AES, I am now connecting on 802.11ac, but the rates are awful - 176 mbps, versus the 800+ I was seeing with the stock firmware.

Has anyone successfully connected to this router at higher wireless rates with the dd-wrt firmware?


With the latest build dd-wrt has better throughput, then oem firmware. But it is important,to do a config reset after flashing dd-wrt.

_________________
Development Units I use for Development:
R7000/R6300V2/R6300

Kong K3 AC DD-WRT Builds for Mipsel R6300/WNDR4500/D1800H/AC66U/EA6500V1
Kong K3 AC DD-WRT Builds for ARM 1450AC/R6250/R6300v2/R7000/AC56U/AC68U/DIR-868
Kong DD-WRT Guides
cinetic
DD-WRT Novice


Joined: 30 Nov 2013
Posts: 9

PostPosted: Mon Dec 02, 2013 10:42    Post subject: Reply with quote
I did a "restore from defaults" or do you mean "flash nvram"?

Also, shouldn't I be seeing 500 mbps connection rates, like I see on the stock firmware?
<Kong>
DD-WRT Guru


Joined: 15 Dec 2010
Posts: 2078
Location: Germany

PostPosted: Mon Dec 02, 2013 12:24    Post subject: Reply with quote
cinetic wrote:
I did a "restore from defaults" or do you mean "flash nvram"?

Also, shouldn't I be seeing 500 mbps connection rates, like I see on the stock firmware?


Yes if correctly setup you should see up to 1300Mbps depending on your client hardware. Make sure you use a build >= 22930, as previous builds did not always honor settings that were specified in webif.

_________________
Development Units I use for Development:
R7000/R6300V2/R6300

Kong K3 AC DD-WRT Builds for Mipsel R6300/WNDR4500/D1800H/AC66U/EA6500V1
Kong K3 AC DD-WRT Builds for ARM 1450AC/R6250/R6300v2/R7000/AC56U/AC68U/DIR-868
Kong DD-WRT Guides
cinetic
DD-WRT Novice


Joined: 30 Nov 2013
Posts: 9

PostPosted: Wed Dec 04, 2013 6:59    Post subject: Reply with quote
So I am still at a loss. I have reset many times, and upgraded to "DD-WRT v24-sp2 (11/24/13) kongac - build 22970."

Basically I can now connect on 802.11ac, but the data rates are 195 or 260, far from the 800 mbps I was seeing with the stock firmware.

Wireless client: Late 2013 MacBook Pro Retina 15 - Broadcom BCM 43xx
Reported signal/noise: -40 dBm/ -92 dBm
Wireless settings are:
2.4 ghz and 5 ghz are on separate SSIDs
5 ghz is set to use auto or 80 Mhz
Mixed mode

The 5ghz channel selection has *no* effect! I still show it using the channel 36, even though the UI shows the proper setting.

What settings do I need to make this work correctly?
cinetic
DD-WRT Novice


Joined: 30 Nov 2013
Posts: 9

PostPosted: Wed Dec 04, 2013 7:52    Post subject: Reply with quote
Okay, I found out that for the settings to take effect, you have to REBOOT the router! I did another erase nvram, and then set my 5ghz radio to the following:

Network Mode: Mixed
Wireless Channel: 132 (or anything in the 100s) - this is crucial for the higher data rates
Channel Width: 80 Mhz

Left all else as default, and then REBOOTED and viola! Now connected at 1053 mbps.

The dd-wrt devs should definitely look into why this device has to rebooted for the wireless changes to go into effect.
<Kong>
DD-WRT Guru


Joined: 15 Dec 2010
Posts: 2078
Location: Germany

PostPosted: Wed Dec 04, 2013 10:22    Post subject: Reply with quote
cinetic wrote:
Okay, I found out that for the settings to take effect, you have to REBOOT the router! I did another erase nvram, and then set my 5ghz radio to the following:

Network Mode: Mixed
Wireless Channel: 132 (or anything in the 100s) - this is crucial for the higher data rates
Channel Width: 80 Mhz

Left all else as default, and then REBOOTED and viola! Now connected at 1053 mbps.

The dd-wrt devs should definitely look into why this device has to rebooted for the wireless changes to go into effect.


No this is wrong, your problem before was, that you either did not reset as I noted in the changelog or because you set it to Auto.

Auto will never do 40 or 80Mhz width, auto is there because everytime you change extension and width, the channel selection changes and therefore jumps to auto, because your previous channel is not available for the combination of width and extension. Most people get it right without understanding the technical details, just by selecting and saving apply.

Higher channels are not recommended, higher channels require in most regions that the radio automatically reduces txpwr in order to avoid interfering with radar signals and therefore will give you a weak signal.

_________________
Development Units I use for Development:
R7000/R6300V2/R6300

Kong K3 AC DD-WRT Builds for Mipsel R6300/WNDR4500/D1800H/AC66U/EA6500V1
Kong K3 AC DD-WRT Builds for ARM 1450AC/R6250/R6300v2/R7000/AC56U/AC68U/DIR-868
Kong DD-WRT Guides
cinetic
DD-WRT Novice


Joined: 30 Nov 2013
Posts: 9

PostPosted: Wed Dec 04, 2013 19:38    Post subject: Reply with quote
My bad on the higher channels - I'll try the lower channels later tonight.

Literally before writing this post, I did a "clear nvram" and then set everything to auto, with the 2.4/5ghz networks on separate SSIDs. I even did a reboot, and it was connected at 190-230 mbps on channel 36.

I'll do some screenshots tonight with various settings, to show the effect on wireless data speeds.

Regardless, it is definitely a bug that one must manually reboot for the new wireless changes to take effect.

And I think for the average user, there should be some wireless setting guidelines because "auto" doesn't enable the higher wireless data rates.
MC_2k14
DD-WRT Novice


Joined: 22 Jan 2014
Posts: 1

PostPosted: Thu Jan 23, 2014 20:00    Post subject: Reply with quote
I'm having troubles with AC66U and newest Kong build.
We are having 3(6) SSIDS with same name on 2,4 and 5 Ghz (3 Interfaces on 2,4Ghz and 3 Interfaces on 5Ghz).

Is it not recommended to use same names for 2,4Ghz and 5Ghz? (with my Linksys E4200 everything was working fine) but the ASUS AC66U drives me crazy Razz.

Are there any recommended AC Settings?

The router is running fine but after some hours uptime devices are not able to connect to the wifi. (already connected devices are loosing the connection and i'm not able to add new devices) It looks like an authentication issue. Could not connect to the network is shown on my iphone and on a windows 8 PC i got the message that the connection took to long and so it was not able to connect to the network. (after a reboot everything is working fine)


It would be great if someone could support mit in this case.

thanks
ouija
DD-WRT Novice


Joined: 07 Jun 2009
Posts: 6

PostPosted: Thu Sep 25, 2014 22:58    Post subject: Reply with quote
I have the Asus RT-AC66U and too found that I was only getting 172Mbps connections when my wireless settings were on auto and both 2.4 and 5GHz bands were using same SSID;

Since then, I've changed the settings to have each band on a seperate SSID, and set the 2.4GHz band to to use 40MHz width lower extension, Channel 3, Mixed, which gives me 144Mps connection, and changed the 5GHz band to use lower lower extension, 80MHz width, Mixed, and found that it wouldn't connect any higher than 172Mbps UNLESS I put it to channel 132 or higher, then I was getting 300Mbps.... Still playing around, because this sucker should be going faster than that.


UPDATE: I found changing both the 2.4 and 5GHz bands to use upper / upper upper for the Extension Channel and the highest channel frequency for each (11/2.462GHz and 161/5.805GHz) along with 40MHz / 80MHz channel width got my speeds FINALLY maxed (jumped from 144Mbps on the 2.4 band to 300Mbps, and from 172Mbps on the 5GHz band to 702Mbps!)

WMM is enabled and AES WPA2 Personal Encryption is used as well. Each band has a unique SSID.

Not sure why the higher channels are achieving better speeds (according to Kong's reply) but this seems to do the trick with the RT-AC66u and I'm a lot happier with the performance using these settings)
Goto page 1, 2  Next Display posts from previous:    Page 1 of 2
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum