Does disabling SSID broadcast work?

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8, 9  Next
Author Message
JN
DD-WRT Guru


Joined: 29 Mar 2007
Posts: 731

PostPosted: Fri May 09, 2008 0:25    Post subject: Reply with quote
JN wrote:
I find Disable SSID broken on RC7 build 9433 on Buffalo WHR-G54S. This used to work, but is now broken. Hopefully the developers will fix what they broke.
Just to clarify, I was running in repeater mode. I did not test AP mode, repeater bridge, or anything else. Just noticed it broken in repeater mode.
Sponsor
TexasFlood
DD-WRT User


Joined: 17 Jun 2006
Posts: 335

PostPosted: Fri May 09, 2008 5:20    Post subject: Reply with quote
JN wrote:
JN wrote:
I find Disable SSID broken on RC7 build 9433 on Buffalo WHR-G54S. This used to work, but is now broken. Hopefully the developers will fix what they broke.
Just to clarify, I was running in repeater mode. I did not test AP mode, repeater bridge, or anything else. Just noticed it broken in repeater mode.
I noticed that after I'd done my first test in AP mode then configured my next text in repeater mode as well. That worked correctly for me as well.
soulstace
DD-WRT Guru


Joined: 04 Aug 2007
Posts: 6427

PostPosted: Fri May 09, 2008 5:39    Post subject: Reply with quote
TexasFlood wrote:
I noticed that after I'd done my first test in AP mode then configured my next text in repeater mode as well. That worked correctly for me as well.


So are you saying disabling broadcast on repeater virtual interface/SSID works for you?? Or do I misunderstand something?
TexasFlood
DD-WRT User


Joined: 17 Jun 2006
Posts: 335

PostPosted: Fri May 09, 2008 12:35    Post subject: Reply with quote
soulstace wrote:
TexasFlood wrote:
I noticed that after I'd done my first test in AP mode then configured my next text in repeater mode as well. That worked correctly for me as well.


So are you saying disabling broadcast on repeater virtual interface/SSID works for you?? Or do I misunderstand something?


Yes.

First I tested my WTR54GS (in AP mode) with dd-wrt.v24-9433_VINT_micro.bin.

Next I tested my WR850G v2 with dd-wrt.v24-9433_VINT_std.bin.
I realized that my first test did not test "an unbridged repeater with a bridged virtual interface" as reffered to in the original post.
For the second test I set up and tested both AP mode and the referred to bridge configuration. All tests showed the SSID broadcast was disabled when set that way.

I did notice something that didn't seem to work as I'd expected though. After testing the bridge, I reset the WR850G to factory defaults. Afterwards I found it still configured as a bridge though. I should probably test this again to confirm and perhaps report it as a bug.

If I have time this weekend I'll run some additional tests of both the SSID broadcast and the reset to factory defaults from bridged mode.
anthonymo
DD-WRT User


Joined: 09 Apr 2008
Posts: 266

PostPosted: Sat May 10, 2008 0:16    Post subject: Reply with quote
I did load VINT as a test and saw the same behavior, SSID broadcast no matter what the setting.
_________________
--------------------------------
WRT-54G V2 Running 16403M VINT Eko std-nokaid
WR850G V2 Running v24-Sp1 10011 mini
Ubnt Routerstation running 16785 Std
Cisco Valet (M10)16773M NEWD-2 K2.6 Eko std-nokaid-small
TexasFlood
DD-WRT User


Joined: 17 Jun 2006
Posts: 335

PostPosted: Sat May 10, 2008 1:34    Post subject: Reply with quote
anthonymo wrote:
I did load VINT as a test and saw the same behavior, SSID broadcast no matter what the setting.
Well I just flashed my WR850G v2 back to dd-wrt.v24-9433_VINT_std.bin and tested again. Still worked correctly for me. I don't see any point in checking it any more. Obviously other folks are getting different results and a ticket has been opened so I'll just wait for the outcome of that.
JN
DD-WRT Guru


Joined: 29 Mar 2007
Posts: 731

PostPosted: Sat May 10, 2008 15:40    Post subject: Reply with quote
JN wrote:
JN wrote:
I find Disable SSID broken on RC7 build 9433 on Buffalo WHR-G54S. This used to work, but is now broken. Hopefully the developers will fix what they broke.
Just to clarify, I was running in repeater mode. I did not test AP mode, repeater bridge, or anything else. Just noticed it broken in repeater mode.
And I used the official build, NOT the VINT driver. It consistently fails to hide SSID in repeater mode.
scragg
DD-WRT Novice


Joined: 10 May 2008
Posts: 2

PostPosted: Sat May 10, 2008 17:09    Post subject: Reply with quote
soulstace wrote:
What is the point of disabling it? Just enable WPA security with a strong passphrase, and be done with it.


Defense in depth.
JN
DD-WRT Guru


Joined: 29 Mar 2007
Posts: 731

PostPosted: Sun May 11, 2008 21:22    Post subject: Reply with quote
I find that disabling SSID broadcast works in AP mode for WHR-G54S with official RC7. When is it going to be fixed for repeater mode?

Thanks
JN
DD-WRT Guru


Joined: 29 Mar 2007
Posts: 731

PostPosted: Sat May 17, 2008 19:39    Post subject: Reply with quote
bump
soulstace
DD-WRT Guru


Joined: 04 Aug 2007
Posts: 6427

PostPosted: Sat May 17, 2008 19:42    Post subject: Reply with quote
scragg wrote:
Defense in depth.


I can see why you would want to hide it. But it shouldn't be used as a real security measure. non-broadcasted SSIDs can still can be found by any determined attacker.
Prosperot
DD-WRT Novice


Joined: 14 Jan 2007
Posts: 14

PostPosted: Sun May 18, 2008 12:40    Post subject: Reply with quote
It seems to be solved in the V24 final Very Happy
JN
DD-WRT Guru


Joined: 29 Mar 2007
Posts: 731

PostPosted: Sun May 18, 2008 20:43    Post subject: Reply with quote
Prosperot wrote:
It seems to be solved in the V24 final Very Happy
I find this still broken when I tried V24 final on a Buffalo WHR-G54S. I can't get a repeater to stop broadcasting the SSID of the virtual WLAN interface to be used by its clients.
JN
DD-WRT Guru


Joined: 29 Mar 2007
Posts: 731

PostPosted: Sat May 24, 2008 18:06    Post subject: Reply with quote
Any progress since 9513, First Final?
JN
DD-WRT Guru


Joined: 29 Mar 2007
Posts: 731

PostPosted: Sat Jun 07, 2008 0:40    Post subject: Reply with quote
bump
Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8, 9  Next Display posts from previous:    Page 3 of 9
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum