WRT54G2: Wireless rate drops to 2 Mbps or 1 Mbps

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page 1, 2, 3 ... 13, 14, 15  Next
Author Message
beng
DD-WRT Novice


Joined: 14 Mar 2009
Posts: 4

PostPosted: Sat Mar 14, 2009 19:37    Post subject: WRT54G2: Wireless rate drops to 2 Mbps or 1 Mbps Reply with quote
Using a WRT54G2 flashed to v24-10709 micro, I set up a standard wireless access point network (channel set to auto, G-only, WPA2 Personal security).

When I reboot the unit, the wireless rate is 54 Mbps. Unfortunately, whenever a wireless client does a large transfer (say, an iTunes download), the wireless rate drops from 54 Mbps to 2 Mbps or 1 Mbps.

I read through the Peacock thread and followed the instructions there to do a 30/30/30 reset, then an upgrade to v24-11296 micro.

Unfortunately, even after a hard reset and upgrade to v24-11296, I hit the same problem: as soon as a wireless client does a big transfer, the wireless rate drops down from 54 Mbps to 2 Mbps:





I tried setting the ACK timing to 0, disabling WPA2, and I ran iStumbler to find an empty channel and changed the channel from Auto to that channel -- nothing helped.

Wired clients have no problem with big downloads, so this is specifically a problem with the wireless.

My wireless client is about 10-15 feet from the router, so I'm pretty sure it's not a range issue. However, I am only getting an SNR of 40 on the wireless client -- is that good enough?

If this is an issue with the wireless chipset in the WRT54G2, I can deal with that, but it'd be nice to see if other folks are running into the same problem.
Sponsor
redhawk0
DD-WRT Guru


Joined: 04 Jan 2007
Posts: 10943
Location: Wherever the wind blows- North America

PostPosted: Sat Mar 14, 2009 19:48    Post subject: Reply with quote
A few things to try.

On the Wireless>>Advanced tab
Change your Tx power from the default of 70 down to something in the 35-50mW range.

Disable CTS protection, FrameBurst, and Afterburner

Set the Preamble to Auto instead of Long.



Next....change the IP filter settings on the Administration tab to

Max Ports = 4096
TCP/UDP timeouts = 120 each.

The ports shouldn't effect the quality of your Wireless but it can reduce the router crash problem that we also see so often.

redhawk

_________________
I currently test dd-wrt on Asus, Buffalo, Linksys, and Netgear. Too many to list.

Looking for more test units (newer models) for the project...got a brick?...PM me to make a hardware donation. (USA) A donation is not a debricking service....it is a way to "Give back" to the dd-wrt project.

I do NOT provide personal assistance through chat or phone....so please don't ask.
beng
DD-WRT Novice


Joined: 14 Mar 2009
Posts: 4

PostPosted: Sat Mar 14, 2009 20:14    Post subject: Reply with quote
redhawk0 wrote:
A few things to try.

On the Wireless>>Advanced tab
Change your Tx power from the default of 70 down to something in the 35-50mW range.

Disable CTS protection, FrameBurst, and Afterburner

Set the Preamble to Auto instead of Long.


Thanks so much for the quick response! I'll give these a try and report back.

Quote:

Next....change the IP filter settings on the Administration tab to

Max Ports = 4096
TCP/UDP timeouts = 120 each.


Yep, that was the first thing I did. Wink Having the NAT connection tracker fill up is the last thing I want.
beng
DD-WRT Novice


Joined: 14 Mar 2009
Posts: 4

PostPosted: Sun Mar 15, 2009 21:02    Post subject: Reply with quote
redhawk0 wrote:

On the Wireless>>Advanced tab
Change your Tx power from the default of 70 down to something in the 35-50mW range.

Disable CTS protection, FrameBurst, and Afterburner

Set the Preamble to Auto instead of Long.


Thanks for the tips! I've done all of these, and it seems to have done the trick.

I'll guess it's probably the transmit power -- maybe the transmitter in the WRT52G2 can't handle 70 mW?
redhawk0
DD-WRT Guru


Joined: 04 Jan 2007
Posts: 10943
Location: Wherever the wind blows- North America

PostPosted: Sun Mar 15, 2009 21:08    Post subject: Reply with quote
beng wrote:
redhawk0 wrote:

On the Wireless>>Advanced tab
Change your Tx power from the default of 70 down to something in the 35-50mW range.

Disable CTS protection, FrameBurst, and Afterburner

Set the Preamble to Auto instead of Long.


Thanks for the tips! I've done all of these, and it seems to have done the trick.

I'll guess it's probably the transmit power -- maybe the transmitter in the WRT52G2 can't handle 70 mW?


Others have seen this same problem with the Tx power when set to 70. I think it overdrives the output drivers due to the crappy antennas inside.

redhawk

_________________
I currently test dd-wrt on Asus, Buffalo, Linksys, and Netgear. Too many to list.

Looking for more test units (newer models) for the project...got a brick?...PM me to make a hardware donation. (USA) A donation is not a debricking service....it is a way to "Give back" to the dd-wrt project.

I do NOT provide personal assistance through chat or phone....so please don't ask.
beng
DD-WRT Novice


Joined: 14 Mar 2009
Posts: 4

PostPosted: Mon Mar 16, 2009 14:48    Post subject: Reply with quote
[quote="redhawk0"][quote="beng"]
redhawk0 wrote:

Others have seen this same problem with the Tx power when set to 70. I think it overdrives the output drivers due to the crappy antennas inside.


Hmm. I think I spoke too soon.

With the Tx power set to 45 mW, the problem came back again this morning as soon as my wireless client did an iTunes podcast download; the data rate dropped down to 2 Mbps and stuck there.

I've moved the Tx power down to 35 mW to see if that helps. But I'm seriously unimpressed with this hardware, and will be replacing it shortly.

(edit)

Same problem at 35 mW. Sad This hardware is going back.

I'm surprised -- is nobody else running into this problem?
Assman
DD-WRT User


Joined: 02 Nov 2008
Posts: 52
Location: Burnt Scrotum, New Mexico

PostPosted: Wed Apr 15, 2009 18:30    Post subject: Reply with quote
Yep, exactly the same problem here. Any updates on the solution Question In the meanwhile I'm going back to my wrt150n.
mac_x50
DD-WRT Novice


Joined: 28 Dec 2008
Posts: 18

PostPosted: Wed Apr 15, 2009 20:47    Post subject: Reply with quote
I tried many tips since october when I bought mine and nothing have solved my problems yet. Wink
Assman
DD-WRT User


Joined: 02 Nov 2008
Posts: 52
Location: Burnt Scrotum, New Mexico

PostPosted: Sun Apr 19, 2009 0:20    Post subject: Reply with quote
Very similar problem on my wrt150n 1.1, yesterday switched wifi rate from auto to 54mbps, so far so good.

But on both routers (150n and g2) there's a considerable lag, especially when streaming mms or such. This never happened on linksys fw. So I give up on dd-wrt Crying or Very sad , last night ordered WRT54G-TM (8/32) and will flush it with potato.
wowowboy69
DD-WRT Novice


Joined: 20 Apr 2009
Posts: 1

PostPosted: Mon Apr 20, 2009 1:01    Post subject: Reply with quote
had same problem here with wrt54g2. did the same same steps thatwas listed here except for the transmit power. i reduced it to 28mW. did the trick. the signal strength is still ok but atleast the rate doesnt drop. plays around at 36 to54 Mbps. i'll observe the router and will post if its a success or not.
aad4321
DD-WRT User


Joined: 31 Mar 2009
Posts: 94

PostPosted: Mon Apr 20, 2009 3:04    Post subject: Reply with quote
Yeah, both wireless pcs in my house are at about 36% to 40% signal quality at about 45 on the wireless output
Assman
DD-WRT User


Joined: 02 Nov 2008
Posts: 52
Location: Burnt Scrotum, New Mexico

PostPosted: Tue Apr 21, 2009 1:44    Post subject: Reply with quote
Holy Crap I broke the internet! Got my 8/32 router with Tomato RAF (by victek) running. I didn't know my internet was that fast Laughing


No offense dd-wrt Wink
brndt
DD-WRT Novice


Joined: 27 Oct 2007
Posts: 1

PostPosted: Tue Apr 21, 2009 3:09    Post subject: Reply with quote
redhawk0, nice tip, rate went from 24-36 to 54 Mbps. Hope it stays there.

Using;
DD-WRT v24 (05/24/08) micro - build 9526
on a WRT54G v8
ThaCrip
DD-WRT User


Joined: 05 May 2008
Posts: 265

PostPosted: Mon May 04, 2009 2:28    Post subject: Reply with quote
i also have this issue. any suggestions?

repeater bridge = Belkin (in my sig)

client mode = Linksys (in my sig) (this is the one that seems to drop to 1-2mbps range)

both of my routers are running DD-WRT v24 pre-sp2 11296 (and i hard-reset both of them before manual configure with the 'erase nvram' stuff)

also... it did seem like when i had the Belkin router fairly close to my linksys (in other room about 15feet away or so) it seemed like i got pretty good speeds (i.e. speedtest.net did around 4mbps) ... now it's around 1mbps (maybe 2mbps TOPS)

EDIT: even when it's back to close... the overall speed is noticeably better but it still aint perfect.

_________________
Linksys WRT54GS v6 Router /w DD-WRT v24-12548_NEWD_micro (not at my house any more (@ sisters house))

Belkin F5D7230-4 v1444 Router /w DD-WRT v24-12548_NEWD_micro-plus (mostly used in 'client bridge' mode to connect to my primary router from time to time to stream video from PC to XBox1 running XBMC)

Asus WL-520gu Router /w DD-WRT v24-15230_NEWD_mini_usb_ftp (my primary router/internet connection setup as AP connected to DSL modem with PPPoE on router)

Linksys WRT54GS v1.1 /w DD-WRT v24-13491_VINT_mega (currently not in use)
Assman
DD-WRT User


Joined: 02 Nov 2008
Posts: 52
Location: Burnt Scrotum, New Mexico

PostPosted: Mon May 04, 2009 4:38    Post subject: Reply with quote
Try newer builds, maybe that'll help
_________________
Goto page 1, 2, 3 ... 13, 14, 15  Next Display posts from previous:    Page 1 of 15
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum