DNSmasq and avahi (zeroconf)

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Author Message
mutz
DD-WRT Novice


Joined: 05 Oct 2008
Posts: 39

PostPosted: Thu Sep 03, 2009 10:48    Post subject: DNSmasq and avahi (zeroconf) Reply with quote
Hello

I've got a problem with avahi(zeroconf) on a NSLU with debian lenny and probably dnsmasq on dd-wrt build 12548M NEWD Eko
My setup is this
- Got a wrt54gl with dd-wrt on it and dnsmasq is running with the options
dnsmasq = enabled
local DNS = enabled
additional DNSMasq options:
address=/sipje/192.168.80.30
address=/kerberos/192.168.80.1
address=/dropje/192.168.80.10
address=/leslie/192.168.80.20
address=/slakje/192.168.80.40

The nslu2 has debian lenny installed. I did a netatalk setup to be able to use AFP on it's connected shares.

If i try to setup AVAHI and try to run the daemon on the NSLU i get following error message:
Restarting Avahi mDNS/DNS-SD Daemon: avahi-daemonavahi-daemon disabled because there is a unicast .local domain (warning).

It's probably got todo with dnsmasq...
any ideas to solve it?

Thanks in advance

_________________
-WRT54GL running 12548M NEWD Eko openvpn
-1 apple airport express connected with wire to wrt54GL
-1 apple airport express in WDS with WPA to the wired airport
-1 NSLU with debian lenny
Sponsor
mutz
DD-WRT Novice


Joined: 05 Oct 2008
Posts: 39

PostPosted: Mon Sep 07, 2009 12:53    Post subject: Reply with quote
Solved!

After searching for a long time i found out that the problems lies with my ISP.

if i do a
Code:
host -t SOA local.

on my debian (NSLU) box i got this reply

Code:
local has SOA record localhost. ops.telenet.be. 1 3600 900 3600000 3600


BAD ISP!!!

strange thing i had openDNS-servers used in my config.
looking further into this problem i found out that you have to fill in all 3 DNS-server in dd-wrt or else you will get the local. problem from your ISP. (if you don't fil in all 3 it still will use your ISP's DNS-server for lookups it can't find)

my setup in the basic setup -> network setup->"Network Address Server Settings (DHCP)"
DNS-server 1 = your router's LAN IP
DNS-server 2 = 208.67.220.220
DNS-server 3 = 208.67.222.222

Restart al your boxes and try
Code:
/etc/init.d/avahi-daemon restart


Works for me!

more info https://bugs.launchpad.net/ubuntu/karmic/+source/avahi/+bug/327362

_________________
-WRT54GL running 12548M NEWD Eko openvpn
-1 apple airport express connected with wire to wrt54GL
-1 apple airport express in WDS with WPA to the wired airport
-1 NSLU with debian lenny
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum