WPA fails after reboot

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Author Message
marvinpa
DD-WRT Novice


Joined: 04 Sep 2009
Posts: 6

PostPosted: Fri Sep 04, 2009 1:51    Post subject: WPA fails after reboot Reply with quote
Hi!

Using a whr-hp-g54 with DD-WRT v24-sp2 build 12533.
Needing multicast for IPTV I enabled multicast forwarding but wanted to disable it for WLAN. I set the WLAN to unbridged and enabled NAT and put it in another IP range. Also started another DHCP server for the WLAN.

Everything works correctly, until the wrt is powered down and is restarted. Now I can't connect to the WLAN. It keeps asking me for the WPA key. Setting it again wont help.

Any help would be appreciated.
Sponsor
marvinpa
DD-WRT Novice


Joined: 04 Sep 2009
Posts: 6

PostPosted: Sun Sep 06, 2009 0:13    Post subject: WPA fails after reboot Reply with quote
After 30-30-30 resets, and installing different versions of the firmware, it still happens. Currently installed build 12759 micro. All the settings are in memory and wlan starts to work after reboot when I go in the dd-wrt web interface and press "Apply Settings" in the wireless menu. Wireless will also connect normally, even after reboot, if set to unbridged.
pauldmis
DD-WRT User


Joined: 01 May 2008
Posts: 77

PostPosted: Sun Sep 06, 2009 5:10    Post subject: Reply with quote
Please post some screen prints of the config you have setup. Maybe that will help with analysis.
Murrkf
DD-WRT Guru


Joined: 22 Sep 2008
Posts: 12666

PostPosted: Mon Sep 07, 2009 13:57    Post subject: Reply with quote
Are you using firefox? You might have to clear your password cache. Test this by trying a new browser, such as Opera.
_________________
SIG:
I'm trying to teach you to fish, not give you a fish. If you just want a fish, wait for a fisherman who hands them out. I'm more of a fishing instructor.
LOM: "If you show that you have not bothered to read the forum announcements or to follow the advices in them then the level of help available for you will drop substantially, also known as Murrkf's law.."
marvinpa
DD-WRT Novice


Joined: 04 Sep 2009
Posts: 6

PostPosted: Tue Sep 08, 2009 2:18    Post subject: Reply with quote
Nope, all the settings appear to be set on any browser, just not used for some reason. If I telnet and look at "nvram show" wl0_wds0 seems to contain all of the correct wireless settings.

Should be easy to reproduce. Fails 100% of the time.
On a fresh and cleared install.

Wireless->Basic settings

set Network configuration Unbridged
set IP address (ie. 192.168.0.1) and subnet mask 255.255.255.0

save

Wireless->Wireless Security

set WPA (or wpa2) (either TKIP or AES will be fine)
set a key

save

Setup->Networking

DHCPD (multiple DHCP Server)
ADD

change interface to eth1

save

Apply settings

Everything should work. Wireless connects and gets an address from the 192.168.0.xxx range.

Unplug the wrt, and replug.

Now wireless wont work anymore. All the settings seem to be set. Press "Apply settings" and wireless works again.
GeeTek
DD-WRT Guru


Joined: 06 Jun 2006
Posts: 3753
Location: I'm the one on the plate.

PostPosted: Tue Sep 08, 2009 4:23    Post subject: Re: WPA fails after reboot Reply with quote
marvinpa wrote:
Needing multicast for IPTV I enabled multicast forwarding but wanted to disable it for WLAN.

Let's back up to this point. What would it hurt to have the multicast available to the wireless interface ?

_________________
http://69.175.13.131:8015 Streaming Week-End Disco. Station Ripper V 1.1 will do.
marvinpa
DD-WRT Novice


Joined: 04 Sep 2009
Posts: 6

PostPosted: Tue Sep 08, 2009 4:46    Post subject: Reply with quote
Sending a lot of UDP packets on wireless is a horrible idea. Usually the stream is unusable because of dropped packets anyway. It also uses a lot of bandwidth, so any other data is slow or wont get trough at all.
marvinpa
DD-WRT Novice


Joined: 04 Sep 2009
Posts: 6

PostPosted: Thu Sep 10, 2009 13:06    Post subject: workaround Reply with quote
If anybody else has the same problem the simplest way to get wireless working is to add in the startup script:

ifconfig eth1 down
ifconfig eth1 up

Hopefully the real issue is fixed in future releases though.
It takes a few minutes to start working.
Murrkf
DD-WRT Guru


Joined: 22 Sep 2008
Posts: 12666

PostPosted: Thu Sep 10, 2009 13:36    Post subject: Reply with quote
It won't be fixed unless you file a bug report in trac...
_________________
SIG:
I'm trying to teach you to fish, not give you a fish. If you just want a fish, wait for a fisherman who hands them out. I'm more of a fishing instructor.
LOM: "If you show that you have not bothered to read the forum announcements or to follow the advices in them then the level of help available for you will drop substantially, also known as Murrkf's law.."
marvinpa
DD-WRT Novice


Joined: 04 Sep 2009
Posts: 6

PostPosted: Thu Sep 10, 2009 14:35    Post subject: Reply with quote
That's been done awhile ago. Doubt there is much interest from the developers. Hope I'm wrong.
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum