[SOLVED] [WRT54G v8.2] [v24 preSP2 - 13525] No DHCP/DNS

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Author Message
joypunk
DD-WRT Novice


Joined: 08 Feb 2010
Posts: 10

PostPosted: Mon Feb 08, 2010 16:49    Post subject: [SOLVED] [WRT54G v8.2] [v24 preSP2 - 13525] No DHCP/DNS Reply with quote
Hi guys and gals,

New DD-WRT user here as of last night. The install went (fairly) smooth for me, but the setup afterwards has been a nightmare so far.

First, the needed information:

Modem: SpeedStream 4100
ISP: AT&T Yahoo DSL
Primary (DD-WRT) Router: Linksys WRT54G v8.2
Secondary (non-DD) Router: Linksys BEFSR41
DD-WRT Version: v24 preSP2 Build 13525 Micro Generic (found here - As recommended in the announcement.)
Primary Router IP: 192.168.2.1
Secondary Router IP: 192.168.2.2
Modem Config IP: 192.168.0.1
DHCP Settings: Starting at 192.168.2.100

Did I miss anything?

Now, the problem(s).

I currently have PPPoE on the router with the correct login information for AT&T Yahoo DSL. As said above, my DHCP is enabled and set to start assigning IP addresses at 192.168.2.100. However, any computer on my network that I plug directly into the router via ethernet cable is receiving an IP address of 192.168.1.64. From what I've read, that is the IP of the router as viewed by the modem?

So first problem is why isn't my DHCP assigning correct IP addresses over the ethernet? I'm sure it's a setting in DD-WRT that I've messed up (I've doen a 30/30/30 reset and changed the password, setup my PPPoE, and changed nothing else and I am at this state).

Second problem...

When I connect to the router over wireless, I *do* get a proper IP address (laptop received a 192.168.2.111). However, I have no internet access/DNS available. Also when assigning an IP address manually, I am unable to access the internet despite everything else appearing to be connected properly.

Troubleshooting already done:

(Not necessarily in order, just as I remember them.)

  • I changed my modem to have PPP on the modem. This allowed me to access the internet via any computer on my network, but my IP was assigned by the modem and everything just seemed to be passing through the router. I also couldn't access the router config this way.

  • Rebooted the entire network. Powered down everything (modem, router, PC) and powered on in order: modem (until all lights were on solid)... router (gave it a few minutes to boot)... then PC.

  • I've done a 30/30/30 reset on the router more than once in order to start over. As said above, just changing the login password, my PPPoE login information, and the router's IP to 192.168.2.1 gets me to the state I'm in now.

  • Manually assigning an IP to my ethernet connected computers will connect me to the router, but I cannot access the internet. I am using the correct DNS servers for my IP that I used previously on my Linksys firmware (68.94.156.1 and 68.94.157.1).

  • For Wireless connections where I am receiving a proper DHCP assigned IP but no internet access/DNS... I have tried setting the DHCP settings in the router config to use the two DNS IP addresses listed in the bullet point above. Still no luck.

------

Additonal unrelated question:

Since my ethernet computers receive a x.x.1.64 IP, I'm unable to access the router config unless I manually assign a proper IP (using 192.168.2.99 - outside the DHCP pool - and gateway set to 192.168.2.1 - the router's IP). I'm also unable to access the router config over my wireless connection, despite being assigned a proper IP from the DHCP server. My Linksys firmware had a setting that allowed config over a wireless connection. Does DD-WRT have this as well?

Thank you in advance for your help!

-jp


Last edited by joypunk on Tue Feb 09, 2010 1:29; edited 1 time in total
Sponsor
Donny
DD-WRT Guru


Joined: 13 Nov 2008
Posts: 5266
Location: CENTRAL Midnowhere

PostPosted: Mon Feb 08, 2010 17:25    Post subject: Reply with quote
You keep referring to "the router" when there are three. I presume that it is that secondary router that is mucking things up as it cannot be bridged with stock linksys firmware. You haven't explained how it is supposed to fit into the mix. But if the modem is at 192.168.0.1, and the primary router is at 192.168.2.1, and you are getting 192.168.1.x IP addresses, it would seem that this has to be coming from another device that is issueing dhcp leases on the wrong subnet....presumably the bef unit.

Bridge the modem. Let the primary router handle PPPoe and dhcp. Get that working first before adding any other devices.

_________________
Warning: I'm "out of my element!"
http://www.youtube.com/watch?v=MjYJ7zZ9BRw&NR=1

Peacock Thread Sticky- Just read it! (Anyone using SP1 will be taken out back and shot)
http://www.dd-wrt.com/phpBB2/viewtopic.php?t=51486
joypunk
DD-WRT Novice


Joined: 08 Feb 2010
Posts: 10

PostPosted: Mon Feb 08, 2010 17:30    Post subject: Reply with quote
Sorry, I should have included that information.

The secondary router is simply adding more ethernet ports to my network. It's setup in router mode, no DHCP, nothing... it just passes traffic down to the devices plugged into it.

The Primary router is hooked into my modem in my computer room. The Secondary router is uplinked via a 25 ft. CAT5 cable in my living room (I have my PS3, DVD player, Slingbox, and Satellite receiver hooked into the BEFSR).

Everytime I've mentioned the "router" in my first post, I meant the WRT54G.
joypunk
DD-WRT Novice


Joined: 08 Feb 2010
Posts: 10

PostPosted: Mon Feb 08, 2010 18:49    Post subject: Reply with quote
Just found this thread in a Google search. I will try this when I get home and see how it works out for me.

Quote:
Well,I was going to suggest setting the router WAN IP address to a Static setup. I personally used this setup,when I had the SpeedStream 5100b modem,and it worked very well. The setting are a little different between the SpeedStream(4100,4100b,5100b) and the Motorola(2210-02),but it works the same way.First,change the default LAN IP address of the router from 192.168.1.1 to 192.168.X.1(X being any number between 2 to 254). Make sure you change the third octet,and not the fourth.

The router's WAN IP address would be as follows,

IP:192.168.1.64
Subnet Mask:255.255.255.0
Gateway IP:192.168.1.254

DNS Servers
68.94.156.1
68.94.157.1


Earlier in the thread it was said to use PPP on the modem with this configuration. I'll report back later tonight... if I can get online with this.
joypunk
DD-WRT Novice


Joined: 08 Feb 2010
Posts: 10

PostPosted: Tue Feb 09, 2010 1:30    Post subject: Reply with quote
I'm so embarrassed... can someone please delete this thread?

Well. Here's the scoop. I have two grey 25ft CAT5 cables on my network. One runs from the BEFSR41 to the WRT54G. The other runs from the Modem to the WRT54G.

Do you see where this is going?

I had the cables backwards. The BEFSR41 was plugged into my WAN port and the Modem was plugged into Port4 on the LAN.

/sigh

Sorry for being a newb.
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum