NAT Loopback (port forwarding) fix for builds 15760-19969

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8, 9, 10  Next
Author Message
kt_haddock
DD-WRT Guru


Joined: 25 Dec 2009
Posts: 620

PostPosted: Sat Apr 16, 2011 7:57    Post subject: Reply with quote
kamileczek123 wrote:
Tested on WRT610N v1 with pre v24-sp2 build 16454 (K2.6-NEWD-2) and this script doesn't work... too bad.


NAT Loopback fix for 15760 and higher

_________________
| ASUS 2x RT-N16 | .-. | @ |
[I prefer answere in whole sentence]
Sponsor
heffneil
DD-WRT Novice


Joined: 05 Apr 2011
Posts: 8

PostPosted: Sat Apr 16, 2011 12:49    Post subject: Reply with quote
Didn't work for me :(

Guys I ma baffled how this doesn't work with such a powerful router. I am going to have to revert back to my time capsule which I really do not want to?!

Just about everything in my house uses the wan domain name to access all the port forwards?! There has to be a working decent solution here?
poldim
DD-WRT Novice


Joined: 14 Apr 2011
Posts: 7

PostPosted: Sat Apr 16, 2011 18:26    Post subject: Reply with quote
heffneil wrote:
I believe this is exactly what I need to do on my router but the question is do I have to run commands for iptables before or is setting up port forwards essentially the same thing?!

Thanks!

Neil


Sent, thanks for your help.
basmaf
DD-WRT Guru


Joined: 24 Feb 2011
Posts: 1042

PostPosted: Mon Apr 18, 2011 0:35    Post subject: Reply with quote
Thanx phuzi0n

Code working fine on my E4200 on NEWD K2.6

Checked with nmap before adding code.
Port was filtered with firewall disabled.

BM..
lev
DD-WRT Novice


Joined: 21 Apr 2011
Posts: 2

PostPosted: Fri Apr 22, 2011 0:06    Post subject: Thanks so much! Reply with quote
Works for me on DD-WRT v24SP2-MULTI (12/17/10) std SVN revision 15940 which came with my Buffalo WZR-HP-AG300H.

I was about to pull my hair out trying to figure out why I could not access my FTP using the external IP / DDNS.

I cannot understand why the devs keep marking it "wontfix" cause it's like the only router firmware I've ever used that had no way to support this functionality (and always using port forwarding to do it)...

Anyways, I want to say thanks to you for sticking with this & finding a solution!

Mr. Green
forkless
DD-WRT Novice


Joined: 05 Apr 2011
Posts: 8

PostPosted: Sat Apr 23, 2011 12:39    Post subject: Finally :) Reply with quote
Works great on my Netgear 3700 v1 (f/w DD-WRT v24-sp2 (04/13/11) std - build 16785)

Was pulling my hair on why the forwarding refused to work out of the box. Thanks for this!
gothfebrio
DD-WRT Novice


Joined: 03 Jul 2010
Posts: 31

PostPosted: Sat Apr 23, 2011 19:14    Post subject: Reply with quote
works on my RT-N12 using build 16754, thanks.
_________________
dd-wrt.v24-16754_NEWD-2_K2.6_mini_RT-N12.trx
heffneil
DD-WRT Novice


Joined: 05 Apr 2011
Posts: 8

PostPosted: Wed Apr 27, 2011 2:26    Post subject: Reply with quote
Is this really only an issue with the broadcom routers? I am wondering because if that is the case maybe I will look at other hardware to run DDWRT?

Thanks,

Neil
buddee
DD-WRT Guru


Joined: 06 Feb 2010
Posts: 7371
Location: Little Rock

PostPosted: Wed Apr 27, 2011 11:08    Post subject: Reply with quote
heffneil wrote:
Is this really only an issue with the broadcom routers? I am wondering because if that is the case maybe I will look at other hardware to run DDWRT?

Thanks,

Neil


This affects all dd-wrt supported units, its not model/chip/brand specific.

_________________
Wireless N Config | Linking Routers | DD-WRT Wiki | DD-WRT Builds | Peacock - Broadcom FAQ

Having problems with port forwarding? Check out Port Forward Troubleshooting for more info.
MisterP
DD-WRT Novice


Joined: 29 Apr 2007
Posts: 6

PostPosted: Sat Apr 30, 2011 14:07    Post subject: Re: NAT Loopback fix for 15760 and higher, (Port forward iss Reply with quote
phuzi0n wrote:
Save the following commands to the Firewall Script on the Administration->Commands page to fix loopback.

insmod ipt_mark
insmod xt_mark
iptables -t mangle -A PREROUTING -i ! `get_wanface` -d `nvram get wan_ipaddr` -j MARK --set-mark 0xd001
iptables -t nat -A POSTROUTING -m mark --mark 0xd001 -j MASQUERADE


thank you! With this solution i can access my LAN-Webserver from LAN via DynDNS-Domain.

DD-WRT v24-sp2 (12/24/10) vpn-special (SVN revision 15962)
coyotle
DD-WRT Novice


Joined: 01 May 2011
Posts: 1

PostPosted: Sun May 01, 2011 22:55    Post subject: Reply with quote
Don't work for me.
May be it doesn't work because i use pptp for internet connection and "nvram get wan_ipaddr" return WAN but not pptp/internet address?!
get_wanface return ppp0

UPD
I change "nvram get wan_ipaddr" to "nvram get pptp_get_ip" and now it work.
MrCommunistGen
DD-WRT Novice


Joined: 19 Jul 2009
Posts: 8

PostPosted: Mon May 09, 2011 7:36    Post subject: n00b question Reply with quote
To clarify: the bug being discussed here breaks port forwarding in newer releases, correct? Does this include UPnP based forwarding? If yes, does that mean that UPnP forwarding is broken even though the UPnP page says it is working?

I'm running mini - build 16403M NEWD-2 K2.6 Eko on an Asus RT-N12.
Bronsen
DD-WRT Novice


Joined: 18 Jun 2006
Posts: 4
Location: Grid Square FN43MG

PostPosted: Mon May 09, 2011 17:02    Post subject: Re: n00b question Reply with quote
MrCommunistGen wrote:
To clarify: the bug being discussed here breaks port forwarding in newer releases, correct? Does this include UPnP based forwarding? If yes, does that mean that UPnP forwarding is broken even though the UPnP page says it is working?

I'm running mini - build 16403M NEWD-2 K2.6 Eko on an Asus RT-N12.


It doesn't break Port forwarding what is broken is the Local Loop back other wise known as "WAN NAT Redirection".

The only affect that this fix has is on poorly written QoS Scripts.

I hope this answers your Question.


Last edited by Bronsen on Mon May 09, 2011 17:23; edited 1 time in total
phuzi0n
DD-WRT Guru


Joined: 10 Oct 2006
Posts: 10143

PostPosted: Mon May 09, 2011 17:15    Post subject: Re: n00b question Reply with quote
MrCommunistGen wrote:
To clarify: the bug being discussed here breaks port forwarding in newer releases, correct? Does this include UPnP based forwarding? If yes, does that mean that UPnP forwarding is broken even though the UPnP page says it is working?

I'm running mini - build 16403M NEWD-2 K2.6 Eko on an Asus RT-N12.

It does not break port forwarding at all, it breaks NAT loopback which is when you access port forwards from within your local LAN instead of from the WAN. It does affect NAT loopback for all kinds of port forwards.

_________________
Read the forum announcements thoroughly! Be cautious if you're inexperienced.
Available for paid consulting. (Don't PM about complicated setups otherwise)
Looking for bricks and spare routers to expand my collection. (not interested in G spec models)
graegos
DD-WRT Novice


Joined: 08 Jul 2008
Posts: 39

PostPosted: Fri May 13, 2011 13:30    Post subject: Wow! Webserver Stopped Working Local Machine Email Too Reply with quote
Updated my dd-wrt, sites hosted on webserver wouldn't show on local machines, seemed like a loopback problem, checked loopback and that didn't help. The above fix did though, thanks MisterP. I wasn't able to access my pop3 emails even, was in a slight panic Shocked
_________________
Router Model: Buffalo WZR-HP-AG300H
Firmware Version: DD-WRT v24-sp2 (01/24/13) std - build 20548
Kernel Version: Linux 3.5.7-svn20542 #4384
Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8, 9, 10  Next Display posts from previous:    Page 3 of 10
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum