Option to set AOSS button to turn radio off does not work

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Author Message
arthng
DD-WRT Novice


Joined: 30 Apr 2011
Posts: 4

PostPosted: Fri Jun 10, 2011 11:17    Post subject: Option to set AOSS button to turn radio off does not work Reply with quote
I got a buffalo wzr-hp-g300nh and the option to set the AOSS button to turn the wireless off does not work. It appears that Atheros units use a different command to turn the radio off. Is there a work around or best to wait till the firmware is updated. Is there a place to log this bug?

Broadcom | Atheros
wl assoclist | wl_atheros assoclist (wlanconfig ath0 list sta)
wl radio up | ifconfig ath0 up
wl radio down | ifconfig ath0 down
wl txpwr1 -d n | iwconfig ath0 txpower n
Sponsor
buddee
DD-WRT Guru


Joined: 06 Feb 2010
Posts: 7385
Location: Little Rock

PostPosted: Fri Jun 10, 2011 11:41    Post subject: Reply with quote
Which build # did you happen to say you were using? Because on my wzr-hp-g300nh setting that works fine.
_________________
Wireless N Config | Linking Routers | DD-WRT Wiki | DD-WRT Builds | Peacock - Broadcom FAQ

Having problems with port forwarding? Check out Port Forward Troubleshooting for more info.
arthng
DD-WRT Novice


Joined: 30 Apr 2011
Posts: 4

PostPosted: Fri Jun 10, 2011 12:00    Post subject: Reply with quote
I tried the latest firmwares from dd-wrt and buffalo and both did not work for me. I did notice that my router sticker says it is a WZR-HP-G301NH - could be the Japanese version. I flashed the latest firmwares for both WZR-HP-G301NH and WZR-HP-G300NH and both did not work. In both cases dd-wrt reported it as a WZR-HP-G300NH.

When I telnet to the router and login, 'wl radio off' does not work but 'ifconfig ath0 down' does turn the wireless off.
RouterSau
DD-WRT Novice


Joined: 10 Nov 2010
Posts: 1

PostPosted: Thu Jan 12, 2012 16:53    Post subject: Same problem here Reply with quote
I have a Buffalo WZR-HP-G300NH. I did everything according to the description in the wiki: Enable Reset button and under "Services" - "AOSS Button Function" I selected the 1st option "Turning off Radio".

Pressing AOSS button short => nothing happens.
Pressing AOSS button long (0.5 seconds or longer) => the red LED with the lock symbol goes on as long as I press the button.
But in both cases WLAN stays on.

I can also turn it off from the web-interface "Administration" - "Commands" and sending "ifconfig ath0 down".

Firmware: "DD-WRT v24SP2-MULTI (10/31/11) std - build 17798"
Binary: wzrhpg300nh-pro-v24sp2-17798-alpha.enc
From archive: WZR-HP-G300NH_pro-v24sp2-17798-alpha.zip

This is the latest recommended version on buffalo site for this router.
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum