ASUS RT-N16 drops every 5 mins on WAN DHCP lease time

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page Previous  1, 2
Author Message
Venique
DD-WRT Novice


Joined: 09 Jun 2011
Posts: 6

PostPosted: Fri Jun 10, 2011 16:13    Post subject: Reply with quote
I'm just trying to simulate situation when DHCP will renew automaticly. So if internet drops when I pressing DHCP Release and DHCP Renew it will be dropped when ISP will do it!
Sponsor
phuzi0n
DD-WRT Guru


Joined: 10 Oct 2006
Posts: 10143

PostPosted: Fri Jun 10, 2011 20:06    Post subject: Reply with quote
Venique wrote:
I'm just trying to simulate situation when DHCP will renew automaticly. So if internet drops when I pressing DHCP Release and DHCP Renew it will be dropped when ISP will do it!

No, release means to get rid of your lease, and then renewing without a lease causes it to ask for a new lease. Only press renew!

The command posted before isn't quite right for all connection types anymore and so you should use this instead.

iptables -I INPUT 2 -i `get_wanface` -p udp --sport 67 --dport 68 -j ACCEPT

_________________
Read the forum announcements thoroughly! Be cautious if you're inexperienced.
Available for paid consulting. (Don't PM about complicated setups otherwise)
Looking for bricks and spare routers to expand my collection. (not interested in G spec models)
Venique
DD-WRT Novice


Joined: 09 Jun 2011
Posts: 6

PostPosted: Fri Jun 10, 2011 20:40    Post subject: Reply with quote
Enter this command, reboot router, lauch radio and EVE client, press "renew" few times - all work stable!
Thanks a lot for help.
lazeekat
DD-WRT Novice


Joined: 18 Jun 2011
Posts: 1

PostPosted: Sat Jun 18, 2011 4:30    Post subject: Solution for TomatoUSB Reply with quote
Yes, I realize this bb is meant for dd-wrt, but I spent an hour trying to find the TomatoUSB equivalent firewall script.

To solve the DHCP renew issue in Tomato, go to Administration > Scripts > Firewall, and paste the following:

Code:

iptables -I INPUT -p udp --sport 67 --dport 68 --source 192.168.1.1 -j ACCEPT


Replace 192.168.1.1 with the IP address of your router if different.
spittadagawd
DD-WRT Novice


Joined: 12 Mar 2012
Posts: 2

PostPosted: Mon Mar 12, 2012 13:00    Post subject: Reply with quote
phuzi0n wrote:
iptables -I INPUT 2 -i `get_wanface` -p udp --sport 67 --dport 68 -j ACCEPT


This code and the other previously suggested does not seem to change anything. I have also tried disabling SPI firewall.

Everyday is a roll of the dice when I turn on the computers whether they will get a DHCP lease or not. So what are we supposed to do?

Perhaps I have a different issue?

I'm running ddwrt 14929 on a Linksys WRT320N which I flashed by religiously following the instructions found in the stickies.
phuzi0n
DD-WRT Guru


Joined: 10 Oct 2006
Posts: 10143

PostPosted: Mon Mar 12, 2012 21:59    Post subject: Reply with quote
This thread and the fix is for the router renewing it's WAN lease to a half-bridge modem causing momentary connection loss. It has nothing to do with local devices having problems getting a lease from the router.

DD-WRT has two different DHCP servers built in. You can try switching which DHCP server you use by toggling the "Use DNSMasq for DHCP" option on the basic setup page.

_________________
Read the forum announcements thoroughly! Be cautious if you're inexperienced.
Available for paid consulting. (Don't PM about complicated setups otherwise)
Looking for bricks and spare routers to expand my collection. (not interested in G spec models)
spittadagawd
DD-WRT Novice


Joined: 12 Mar 2012
Posts: 2

PostPosted: Wed Mar 14, 2012 10:01    Post subject: Reply with quote
phuzi0n wrote:
This thread and the fix is for the router renewing it's WAN lease to a half-bridge modem causing momentary connection loss. It has nothing to do with local devices having problems getting a lease from the router.

DD-WRT has two different DHCP servers built in. You can try switching which DHCP server you use by toggling the "Use DNSMasq for DHCP" option on the basic setup page.

Thank you for the reply, and forgive me for hijacking the thread. The symptoms seemed similar in my mind.

I tried turning off DNSMasq but the problem remains.

There are 4 PCs, two wired and two wireless, connected to the router, in addition to IPTV (blocked multicast from wifi, and doesn't seem to have any effect of wired connections) and VoIP.

Upon investigating further it seems that at any point in time, only two of the PCs receive a lease from the router. This is regardless whether wired or wireless and not always the same PCs.

So two PCs have internet connectivity. When I change the TCPIP 4 settings on the other PCs and specify IPs of the device, subnet, DNS etc, then they also immediately get internet access, and the problem is gone. I suppose I could run it like this indefinitely, but I would appreciate any ideas of why this is the case and if there is a solution.

Edit: Solution: The devices were connecting to the VoIP device as a gateway instead of the router. Maybe there is another way to stop this but I got myself a Linksys SE2500 switch that I plug in first, and to which I connect the IPTV, VoIP and router WAN. No problems now.
erocks
DD-WRT Novice


Joined: 07 Jul 2012
Posts: 4

PostPosted: Sat Jul 07, 2012 6:24    Post subject: Reply with quote
thank you soooooo much for this thread. been dying trying to figure out why connections keep dropping on my router. 5min lease renew apparently. This solved it!! fuck i was about to shell out for ANOTHER router. phew thanks again
Goto page Previous  1, 2 Display posts from previous:    Page 2 of 2
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum