mac address changes at reboot

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Author Message
PetervdM
DD-WRT User


Joined: 11 Jun 2009
Posts: 282
Location: EU

PostPosted: Mon Jun 13, 2011 8:50    Post subject: mac address changes at reboot Reply with quote
i'm running dd-wrt.v24-17084_NEWD-2_K2.6_big-nv60k.bin on my new E4200. i'm wireless connected to it. after each reboot of the router the arp table at my pc shows a different mac address for the E4200.
this is a nuiseance because my pc tools firewall constantly discovers a new network and generates a popup for it.
my old wrt610n running dd-wrt.v24-16773_NEWD-2_K2.6_big.bin didn't show this behaviour afaik.
anyone else noticed this?

_________________
now running tomato by shibby
E4200v1 cfe 2010.09.20.0
Sponsor
LOM
DD-WRT Guru


Joined: 28 Dec 2008
Posts: 7215

PostPosted: Mon Jun 13, 2011 8:57    Post subject: Reply with quote
What is the relation between old and new mac? +1?
_________________
I'm on a whiskey diet, lost 3 days already
PetervdM
DD-WRT User


Joined: 11 Jun 2009
Posts: 282
Location: EU

PostPosted: Mon Jun 13, 2011 11:08    Post subject: Reply with quote
no, pretty random. for instance previous was 00-ff-26-e2-08-4e, now it is 00-ff-3f-f5-69-8d. looks like it is the mac of br0. but why does that change?
_________________
now running tomato by shibby
E4200v1 cfe 2010.09.20.0
LOM
DD-WRT Guru


Joined: 28 Dec 2008
Posts: 7215

PostPosted: Mon Jun 13, 2011 12:12    Post subject: Reply with quote
Which radio do you connect to, the 5GHz?
In my understanding your client should see the mac of the routers radio and not the mac of lan bridge.
But the radio is part of the bridge so it may appear there as well..

_________________
I'm on a whiskey diet, lost 3 days already
PetervdM
DD-WRT User


Joined: 11 Jun 2009
Posts: 282
Location: EU

PostPosted: Mon Jun 13, 2011 12:43    Post subject: Reply with quote
both 2.4 and 5 GHz give the same mac address. flashed back to dd-wrt.v24-16773_NEWD-2_K2.6_big-nv60k.bin, but br0 mac address remains.
i also have tried clearing my firewall script, but that didn't help either.
any suggestions? should i make a ticket?

_________________
now running tomato by shibby
E4200v1 cfe 2010.09.20.0
LOM
DD-WRT Guru


Joined: 28 Dec 2008
Posts: 7215

PostPosted: Mon Jun 13, 2011 13:35    Post subject: Reply with quote
PetervdM wrote:

any suggestions? should i make a ticket?


Test with stock firmware first to make sure it is a dd-wrt related behaviour before making the ticket.
Does your nvram mac variables also change?

There's a bell ringing in my head, something about mfgr not supplying unique and full mac addresses but I cant put my finger onto it.
May have been from the Atheros forum and not Broadcom..

_________________
I'm on a whiskey diet, lost 3 days already
somms
DD-WRT User


Joined: 21 Mar 2008
Posts: 258

PostPosted: Mon Jun 13, 2011 13:47    Post subject: Reply with quote
Guess this would explain why my network location always changes back to public under Vista on my wireless computers and the network name under Network and Sharing Center won't stick and changes after a couple of reboots. Just noticed this recently and more than likely running 17084M on my E4200 gateway router is probably the culprit...
PetervdM
DD-WRT User


Joined: 11 Jun 2009
Posts: 282
Location: EU

PostPosted: Mon Jun 13, 2011 18:27    Post subject: Reply with quote
loaded stock firmware FW_E4200_1.0.01.010_US_20110221_code.bin, set to default, all OK.
loaded dd-wrt mini dd-wrt.v24-17084_NEWD-2_K2.6_mini-e4200.bin, set to default, all OK
loaded dd-wrt dd-wrt.v24-17084_NEWD-2_K2.6_big-nv60k.bin, set to default, all OK
applied my settings, and found the culprit in my startup script.
as i have configured my vpn by configfile per wiki ( VPN (the easy way) v24+ ), part of the commands is in the startup script. it reads:
Code:
sleep 20
killall openvpn
openvpn --mktun --dev tap0
brctl addif br0 tap0
ifconfig tap0 0.0.0.0 promisc up
ln -s /usr/sbin/openvpn /tmp/myvpn
/tmp/myvpn /mnt/OVPN/server.conf

this gives me the br0 mac address. if i comment out the rule starting with brctl and all below, it is OK. if i run the brctl command manually, i get the br0 mac address. any suggestions?

_________________
now running tomato by shibby
E4200v1 cfe 2010.09.20.0
somms
DD-WRT User


Joined: 21 Mar 2008
Posts: 258

PostPosted: Mon Jun 13, 2011 20:03    Post subject: Reply with quote
http://www.dd-wrt.com/phpBB2/viewtopic.php?p=614906&highlight=#614906

Figures...I'm running OpenVPN tap as well on my E4200 although its turned on/configured thru the GUI as I have nothing scripted under Startup. Guess the easiest solution would be to not use OpenVPN tap(bridge) or in my case via the OpenVPN client GUI, disable Bridge Tap to br0? Although there is no option like this under the OpenVPN Server/Daemon GUI tab like there is for the client...

FWIW: The E4200 w/OpenVPN tap returns brctl showmacs command as follows:
Code:
root@OpenVPN00:~# brctl showmacs br0
port no mac addr                is local?       ageing timer
  1     00:0b:82:21:96:61       no                 1.10
  1     00:13:b6:38:49:6c       no               167.12
  1     00:13:b6:48:58:ce       no                 0.03
  1     00:23:69:6a:35:8a       no                10.47
  4     00:ff:54:58:41:6a       no                 0.01
  4     00:ff:ae:7f:72:b0       yes                0.00
  1     1c:c1:de:4b:4a:1e       no                26.25
  1     b8:ac:6f:db:e3:2d       no                 0.01
  1     c0:c1:c0:33:ea:0f       yes                0.00
  2     c0:c1:c0:33:ea:11       yes                0.00
  3     c0:c1:c0:33:ea:12       yes                0.00
  3     c0:cb:38:58:ed:b3       no               192.41
  3     c2:c1:c0:33:ea:12       no                 0.62
  1     f0:7d:68:01:66:aa       no               156.00
  1     f0:7d:68:02:eb:27       no               185.22
root@OpenVPN00:~#


c0:c1:c0:33:ea:12=wl1
c0:c1:c0:33:ea:0f=LAN

Same showmacs command following a reboot:

Code:
BusyBox v1.13.4 (2011-05-17 17:38:11 CEST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

root@OpenVPN00:~# brctl showmacs br0
port no mac addr                is local?       ageing timer
  1     00:21:70:6b:5b:83       no                 0.01
  4     00:ff:e1:07:1b:b4       yes                0.00
  1     c0:c1:c0:33:ea:0f       yes                0.00
  2     c0:c1:c0:33:ea:11       yes                0.00
  3     c0:c1:c0:33:ea:12       yes                0.00
root@OpenVPN00:~#


This is a bug since the private named network switching to public under Vista after a reboot wasn't occuring with my previous WRT600N running a bridged tap connection. Whether it is related to the hardware(E4200) or Eko's latest build I'm not sure of though...
LOM
DD-WRT Guru


Joined: 28 Dec 2008
Posts: 7215

PostPosted: Tue Jun 14, 2011 4:24    Post subject: Reply with quote
PetervdM wrote:
no, pretty random. for instance previous was 00-ff-26-e2-08-4e, now it is 00-ff-3f-f5-69-8d. looks like it is the mac of br0. but why does that change?


I was googling a bit for vpn tunnel bridge mac address and found this:

"The first devices connected to the bridge are often TAP devices with
random generated MAC addresses
(00:FF:xx:xx:xx:xx). Actual ethernet
interfaces are connected and disconnected later on, on the fly.

_________________
I'm on a whiskey diet, lost 3 days already
rivalcomp
DD-WRT Novice


Joined: 09 May 2011
Posts: 1
Location: Budapest, Hungary

PostPosted: Thu Nov 03, 2011 8:33    Post subject: Reply with quote
Is there any workaround? I've the same problem and I haven't found any solution yet. Using Linksys E3000 with Eko's 17598M.
ivkra
DD-WRT Novice


Joined: 16 Mar 2010
Posts: 9

PostPosted: Sun Nov 27, 2011 15:55    Post subject: Reply with quote
Try to change MAC adress of the br0 interface after adding tap0 to the bridge:

rc_startup:
Code:
openvpn --mktun --dev tap0
brctl addif br0 tap0
ifconfig br0 hw ether XX:XX:XX:XX:XX:XX
ifconfig tap0 0.0.0.0 promisc up


XX:XX:XX:XX:XX:XX is the mac address of the eth0 (LAN interface).
Works for me on build 15962 (E2000)
fxdxrycz
DD-WRT Novice


Joined: 26 Jun 2011
Posts: 37

PostPosted: Thu Jan 12, 2012 10:32    Post subject: Reply with quote
i have set up the openvpn server via gui, so now i'm trying this in the startup commands:

sleep 4
ifconfig br0 hw ether (eth0 mac)



seems to be working fine... am i doing something wrong?
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum