Does disabling SSID broadcast work?

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8, 9  Next
Author Message
mikeb
DD-WRT Novice


Joined: 27 Apr 2009
Posts: 3

PostPosted: Sat May 09, 2009 15:49    Post subject: Reply with quote
Just to confirm, I am seeing this problem as well. In REPEATER mode (it works fine in AP mode), the enable/disable SSID broadcast button on the virtual interfaces does not have any effect - the ssids are broadcast regardless. The work around discussed above does work to an extent - if you flip back into AP mode and choose disable ssid on the wl0, save, then change back to repeater, it disables broadcast of ALL the virtual interface SSIDs (seems to work like a global disable).

So we can fudge all ssids to be disabled in repeater mode, but what I really want to be able to do is have a mixture - wl0.1 broadcasting, and wl0.2 hidden. Note - this is on a Buffalo router (broadcom chipset 5352), I have heard musings that some other routers may actually not show this issue.

I have tried numerous firmware versions, right back to v23 when virtual interfaces were first introduced, and up to the most recent v24 SP2 builds (both VINT and NEWD), and the bug is always present.
Sponsor
drumstyx
DD-WRT Novice


Joined: 04 Aug 2010
Posts: 7

PostPosted: Sat Aug 07, 2010 17:49    Post subject: Reply with quote
This will be a necro of over a year, but I thought I should post; this is still an issue. I cannot disable my VAP SSID broadcast alone while in repeater mode. The workaround by going into AP mode, disabling SSID broadcast, and then returning to repeater mode (in my case repeater bridge) DOES work.

This isn't too much of an issue for me right now, as I was just trying to figure out how to hide all my WLAN's, but should anyone ever want to have 1 VAP visible and another not, they would have problems.
redhawk0
DD-WRT Guru


Joined: 04 Jan 2007
Posts: 10939
Location: Wherever the wind blows- North America

PostPosted: Sat Aug 07, 2010 18:44    Post subject: Reply with quote
drumstyx wrote:
This will be a necro of over a year, but I thought I should post; this is still an issue. I cannot disable my VAP SSID broadcast alone while in repeater mode. The workaround by going into AP mode, disabling SSID broadcast, and then returning to repeater mode (in my case repeater bridge) DOES work.

This isn't too much of an issue for me right now, as I was just trying to figure out how to hide all my WLAN's, but should anyone ever want to have 1 VAP visible and another not, they would have problems.


Yeah..this has been broken forever...but hiding SSID's is not to be used in place of security encryption....make sure you have WPA or WPA2 enabled to secure your wireless.

redhawk

_________________
I currently test dd-wrt on Asus, Buffalo, Linksys, and Netgear. Too many to list.

Looking for more test units (newer models) for the project...got a brick?...PM me to make a hardware donation. (USA) A donation is not a debricking service....it is a way to "Give back" to the dd-wrt project.

I do NOT provide personal assistance through chat or phone....so please don't ask.
drumstyx
DD-WRT Novice


Joined: 04 Aug 2010
Posts: 7

PostPosted: Sat Aug 07, 2010 19:43    Post subject: Reply with quote
redhawk0 wrote:
Yeah..this has been broken forever...but hiding SSID's is not to be used in place of security encryption....make sure you have WPA or WPA2 enabled to secure your wireless.

redhawk



I'm absolutely using security on my networks, I just want to hide my networks in my dorm, so at least it's not OBVIOUS I'm breaking the rules Razz.

Edit: Of course in my case, the workaround works great! And it doesn't really bother me that it's a workaround, since it's something of a 'set it and forget it' thing to do.
barryware
DD-WRT Guru


Joined: 26 Jan 2008
Posts: 12846
Location: Behind The Reset Button

PostPosted: Sat Aug 07, 2010 20:15    Post subject: Reply with quote
redhawk0 wrote:

Yeah..this has been broken forever...but hiding SSID's is not to be used in place of security encryption....make sure you have WPA or WPA2 enabled to secure your wireless.

redhawk


Agreed.. However, ssid broadcast (enable / disable) is a fundamental function. Kinda needs to be fixed.

_________________
[Moderator Deleted] Shocked
redhawk0
DD-WRT Guru


Joined: 04 Jan 2007
Posts: 10939
Location: Wherever the wind blows- North America

PostPosted: Sat Aug 07, 2010 20:55    Post subject: Reply with quote
Oh...I won't argue that...it should be fixed....but so far....it hasn't...along with many other fundamental functions.

But we'll spend hours and hours of time to support new routers...won't we Rolling Eyes

redhawk

_________________
I currently test dd-wrt on Asus, Buffalo, Linksys, and Netgear. Too many to list.

Looking for more test units (newer models) for the project...got a brick?...PM me to make a hardware donation. (USA) A donation is not a debricking service....it is a way to "Give back" to the dd-wrt project.

I do NOT provide personal assistance through chat or phone....so please don't ask.
tomkiv897
DD-WRT Novice


Joined: 13 Jul 2011
Posts: 1

PostPosted: Wed Jul 13, 2011 0:42    Post subject: Reply with quote
the issue still present in latest firmware s24 v2 on linksys e1000. I have repeater mode and 2 virtual SSIDs
fotosdobrasil.fot.br
DD-WRT Novice


Joined: 19 Dec 2011
Posts: 20

PostPosted: Mon Dec 19, 2011 20:05    Post subject: Is there any solution? Reply with quote
Somebody have a solution?

DD-WRT v24-sp2 13064M VINT Eko still have the bug Sad

Best regards!
fggs
DD-WRT Guru


Joined: 28 Jan 2008
Posts: 1716

PostPosted: Mon Dec 19, 2011 20:14    Post subject: Reply with quote
Please read Peacock announcement, specially notes 1 & 3.

13064 is a bad build!
zoomlink
DD-WRT User


Joined: 08 May 2011
Posts: 221

PostPosted: Tue Dec 20, 2011 1:29    Post subject: Re: Is there any solution? Reply with quote
fotosdobrasil.fot.br wrote:
Somebody have a solution?

DD-WRT v24-sp2 13064M VINT Eko still have the bug Sad

Best regards!


A v13064 e um grande BUG Smile uma aranha!.
Joga fora isso ontem! tem muitos defeitos e falhas.

Por favor usa svn14929 ou 15508 ou 15528, tem muito mais estabilidade.
fotosdobrasil.fot.br
DD-WRT Novice


Joined: 19 Dec 2011
Posts: 20

PostPosted: Thu Dec 22, 2011 21:29    Post subject: Still not work with the last avaliable version.. Reply with quote
I had test with the last avaliable version,

DD-WRT v24-sp2 (12/20/11) mini
(SVN revision 18024)

And the trouble remains, SSID still remains in broadcast mode.

Anybody know some workaround?

Best regards,

Leonardo Daciole
fggs
DD-WRT Guru


Joined: 28 Jan 2008
Posts: 1716

PostPosted: Thu Dec 22, 2011 21:54    Post subject: Reply with quote
Start by using a recommended build, 18024 was just released and it's not yet tested to be considered stable nor recommended
fotosdobrasil.fot.br
DD-WRT Novice


Joined: 19 Dec 2011
Posts: 20

PostPosted: Thu Dec 22, 2011 23:50    Post subject: 14289 the same thing Reply with quote
DD-WRT v24-sp2 (04/16/10) mini
(SVN revision 14289)

Same Thing

Some solution available?
fotosdobrasil.fot.br
DD-WRT Novice


Joined: 19 Dec 2011
Posts: 20

PostPosted: Wed Dec 28, 2011 22:17    Post subject: 10 days after... Reply with quote
Somebody has a solution??
fotosdobrasil.fot.br
DD-WRT Novice


Joined: 19 Dec 2011
Posts: 20

PostPosted: Sun Jan 22, 2012 22:52    Post subject: Dead... Reply with quote
Well, dead topic, no solution available, bye!

As The Doors: "This is the end.."
Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8, 9  Next Display posts from previous:    Page 8 of 9
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum