[Howto] Install Optware on Atheros units (such as WNDR3700)

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Goto page Previous  1, 2, 3 ... 15, 16, 17 ... 27, 28, 29  Next
Author Message
furic
DD-WRT Novice


Joined: 27 Dec 2011
Posts: 12

PostPosted: Mon Jan 02, 2012 12:55    Post subject: Reply with quote
If i disable the automount option in dd-wrt gui, I can manually mount /dev/sda using usbfs and then I see 2 directories 001 and 002, but seems I can't create folder inside them , is there solution for this issue ?:
Code:

root@DD-WRT:/# ls /dev/s*
/dev/sda   /dev/sda1  /dev/sda2
root@DD-WRT:/# mount
rootfs on / type rootfs (rw)
/dev/root on / type squashfs (ro,relatime)
proc on /proc type proc (rw,relatime)
sysfs on /sys type sysfs (rw,relatime)
ramfs on /tmp type ramfs (rw,relatime)
none on /dev type tmpfs (rw,relatime,size=512k)
devpts on /dev/pts type devpts (rw,relatime,mode=600)
devpts on /proc/bus/usb type usbfs (rw,relatime)
root@DD-WRT:/# mount -t usbfs /dev/sda/ /mnt
root@DD-WRT:/# mount
rootfs on / type rootfs (rw)
/dev/root on / type squashfs (ro,relatime)
proc on /proc type proc (rw,relatime)
sysfs on /sys type sysfs (rw,relatime)
ramfs on /tmp type ramfs (rw,relatime)
none on /dev type tmpfs (rw,relatime,size=512k)
devpts on /dev/pts type devpts (rw,relatime,mode=600)
devpts on /proc/bus/usb type usbfs (rw,relatime)
/dev/sda/ on /mnt type usbfs (rw,relatime)
root@DD-WRT:/# ls -l /mnt
dr-xr-xr-x    2 root     root            0 Jan  1 00:00 001
dr-xr-xr-x    2 root     root            0 Jan  1 00:00 002
-r--r--r--    1 root     root            0 Jan  1 00:00 devices
root@DD-WRT:/# chmod -R 777 /mnt/001
root@DD-WRT:/# ls -l /mnt/001
-rwxrwxrwx    1 root     root           43 Jan  1 00:00 001
-rwxrwxrwx    1 root     root           50 Jan  1 00:00 002
root@DD-WRT:/# cd /mnt/001
root@DD-WRT:/mnt/001# mkdir etc
mkdir: cannot create directory 'etc': Operation not permitted

Sponsor
furic
DD-WRT Novice


Joined: 27 Dec 2011
Posts: 12

PostPosted: Mon Jan 02, 2012 14:02    Post subject: Reply with quote
Juniorek wrote:
hmmm

i`ve got 18024 so maybe the automount system is diferent cause when i use it ot mount my pen to /mnt i get somthin like /mnt/sda_partX

then i manualy mount what i want


you can also do dmesg and search for mount points like

Code:

<6>[  324.440000] scsi0 : usb-storage 1-1:1.0
<5>[  325.460000] scsi 0:0:0:0: Direct-Access     TOSHIBA  TransMemory      5.00 PQ: 0 ANSI: 0 CCS
<5>[  327.180000] sd 0:0:0:0: [sda] 8058880 512-byte logical blocks: (4.12 GB/3.84 GiB)
<5>[  327.190000] sd 0:0:0:0: [sda] Write Protect is off
<7>[  327.190000] sd 0:0:0:0: [sda] Mode Sense: 23 00 00 00
<3>[  327.190000] sd 0:0:0:0: [sda] Assuming drive cache: write through
<3>[  327.200000] sd 0:0:0:0: [sda] Assuming drive cache: write through
<6>[  327.210000]  sda: sda1
<3>[  327.210000] sd 0:0:0:0: [sda] Assuming drive cache: write through
<5>[  327.220000] sd 0:0:0:0: [sda] Attached SCSI removable disk


and the show us and maybe will get it working;)

Can you please show the result of mount command ?
Which fs type /mnt uses ?
Juniorek
DD-WRT Novice


Joined: 14 Feb 2011
Posts: 38

PostPosted: Mon Jan 02, 2012 14:47    Post subject: Reply with quote
here is my mount


Code:

rootfs on / type rootfs (rw)
/dev/root on / type squashfs (ro,relatime)
proc on /proc type proc (rw,relatime)
sysfs on /sys type sysfs (rw,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
ramfs on /tmp type ramfs (rw,relatime)
none on /dev type tmpfs (rw,relatime,size=512k)
devpts on /dev/pts type devpts (rw,relatime,mode=600)
/dev/sda1 on /tmp/mnt/sda_part1 type ext2 (rw,relatime,errors=continue)
/dev/sda1 on /jffs type ext2 (rw,relatime,errors=continue)
[part deleted;p]


this
Code:
/dev/sda1 on /tmp/mnt/sda_part1 type ext2 (rw,relatime,errors=continue)
is my automount part from the web gui


when i had 3 partitions i had /mnt/sda_part1 2 and 3
furic
DD-WRT Novice


Joined: 27 Dec 2011
Posts: 12

PostPosted: Mon Jan 02, 2012 15:08    Post subject: Reply with quote
Juniorek wrote:
here is my mount


Code:

rootfs on / type rootfs (rw)
/dev/root on / type squashfs (ro,relatime)
proc on /proc type proc (rw,relatime)
sysfs on /sys type sysfs (rw,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
ramfs on /tmp type ramfs (rw,relatime)
none on /dev type tmpfs (rw,relatime,size=512k)
devpts on /dev/pts type devpts (rw,relatime,mode=600)
/dev/sda1 on /tmp/mnt/sda_part1 type ext2 (rw,relatime,errors=continue)
/dev/sda1 on /jffs type ext2 (rw,relatime,errors=continue)
[part deleted;p]


this
Code:
/dev/sda1 on /tmp/mnt/sda_part1 type ext2 (rw,relatime,errors=continue)
is my automount part from the web gui


when i had 3 partitions i had /mnt/sda_part1 2 and 3

OK, so /dev/sda is NOT mounted.
What release do you use ? I'm thinking about upgrade from 16785 to have this issue fixed and looking for less evilness release Very Happy
Juniorek
DD-WRT Novice


Joined: 14 Feb 2011
Posts: 38

PostPosted: Mon Jan 02, 2012 15:36    Post subject: Reply with quote
i recently changed my router and now i use 18024
_________________
TP-Link TL-WDR4300 v1 - DD-WRT std svn 23503;?
guerie
DD-WRT Novice


Joined: 04 Jan 2012
Posts: 1

PostPosted: Wed Jan 04, 2012 12:13    Post subject: ssh public key authentication glitch after opkg install Reply with quote
trumanwu wrote:
gingerbreadassassin wrote:
trumanwu wrote:
do you really need to mount /etc?

it seems my ssh public key is stored in /etc. After run the script to mount /mnt/etc to /etc. my ssh authentication is not working any more. After I removed the startup script, it's working again.

could you please give me some advice on this?
is there any workaround to avoid break my ssh authentication? or I just need to remove the ssh config and then re-config ssh again?

Thank you.
I suffer the same symptoms and would also like to know what to do in this situation. If it's really as simple as not having authentication before applying the script, that'd be awesome.


I guess something affected my authentication files. What I did is remove the key, save, and then add the SSH key again, save. It worked!


Hi,
I just had the same ssh-public-key issue after setting up the opkg. The problem is caused by the
Code:

mount -o bind /mnt/root /tmp/root

command, because this mount hides the files which reside in /tmp/root. Under /tmp/root normally dd-wrt stores the ssh-authentication keys. Now there are two options:
a) re-enter and save the key, as you did
b) script around the issue
Currently I don't know, what dd-wrt additionaly stores in the /tmp/root directory, so I decided to choose option b. I changed the start-script-mount to:
Code:

# copy all files form /mnt/root to /tmp/root, this fixes the .ssh glitch
if [ -f /mnt/move.root2tmp ]; then
if [ -d /mnt/root ]; then
tar -C /mnt/root -cf - . | tar -C /tmp/root -xf -
fi
else
# old mechanism
mount -o bind /mnt/root /tmp/root
fi

To activate the "copy-root" feature just create the /mnt/move.root2tmp file:
Code:

touch /mnt/move.root2tmp


A similar condition could be used for the "/etc" update problem.
msymmes
DD-WRT Novice


Joined: 07 Jan 2010
Posts: 6
Location: Toronto

PostPosted: Thu Jan 05, 2012 5:10    Post subject: Confirming a fix for: cant resolve symbol glob64 in lib opkg Reply with quote
For the NetGear WNDR3700.. running build 17210...

I found that by using the libc and opkg packages from release candidate 4 (ie: 10.03.1-rc4) rather than 6 (10.03.1-rc6) fixed the problem with 'opkg: can't resolve symbol 'glob64' in lib 'opkg'.

So step 5 below needs to be modified to use the older .../10.03.1-rc4/... packages.

I just wish I could find the posting in this forum that suggested this workaround. Thanks to whomever.

5. Install the required libraries for the MIPS (big-endian) architecture and OpenWRT's opkg

cd /tmp
wget http://downloads.openwrt.org/backfire/10.03.1-rc6/ar71xx/packages/libc_0.9.30.1-43.29_ar71xx.ipk
wget http://downloads.openwrt.org/backfire/10.03.1-rc6/ar71xx/packages/opkg_576-2_ar71xx.ipk
ipkg install libc_0.9.30.1-43.29_ar71xx.ipk opkg_576-2_ar71xx.ipk

_________________
Dlink DIR-825's run non-stop forever!
glundby
DD-WRT Novice


Joined: 05 Jan 2012
Posts: 8

PostPosted: Sun Jan 08, 2012 8:47    Post subject: cannot resolve symbol 'glob64' Reply with quote
Hi! Long tread to read through, finally at last someone claims to have found solution to 'glob64' problem. However when I full of hope tried it I got:

root@DD-WRT root $ cd /tmp
root@DD-WRT /tmp $ wget http://downloads.openwrt.org/backfire/10.03.1-rc6/ar71xx
/packages/libc_0.9.30.1-43.29_ar71xx.ipk
Connecting to downloads.openwrt.org (78.24.191.177:80)
libc_0.9.30.1-43.29_ 100% |*******************************| 219k 00:00:00 ETA
root@DD-WRT /tmp $ wget http://downloads.openwrt.org/backfire/10.03.1-rc6/ar71xx
/packages/opkg_576-2_ar71xx.ipk
Connecting to downloads.openwrt.org (78.24.191.177:80)
opkg_576-2_ar71xx.ip 100% |*******************************| 57114 --:--:-- ETA
root@DD-WRT /tmp $ ipkg install libc_0.9.30.1-43.29_ar71xx.ipk opkg_576-2_ar71xx
.ipk
ERROR: File not found: //usr/local/lib/ipkg/lists/whiterussian
You probably want to run `ipkg update'
ERROR: File not found: //usr/local/lib/ipkg/lists/non-free
You probably want to run `ipkg update'
ERROR: File not found: //usr/local/lib/ipkg/lists/backports
You probably want to run `ipkg update'
/bin/ipkg: line 1184: sort: not found
mkdir: cannot create directory '/jffs/tmp/': Read-only file system

root@DD-WRT /tmp $ opkg update
opkg: can't resolve symbol 'glob64' in lib 'opkg'.
root@DD-WRT /tmp $
Evil or Very Mad
glundby
DD-WRT Novice


Joined: 05 Jan 2012
Posts: 8

PostPosted: Sun Jan 08, 2012 20:47    Post subject: My last post about glob-64 Reply with quote
Solved it by hand entering parts of the script offered earlier in this tread. Very Happy
Ёжик
DD-WRT Novice


Joined: 17 Nov 2011
Posts: 2

PostPosted: Fri Jan 13, 2012 17:04    Post subject: Reply with quote
4edibg

Please help me. I did everything according to your manuals. when you start transmisson issues here this error:
Code:
root @ gw root $ / opt / etc / init.d / transmission start
/ bin / sh: can't open '/ etc / rc.common'



What to do? how to fix?
P.S. I am Russian. Sorry for the mistake. English I know is very bad.
vijayadik
DD-WRT Novice


Joined: 10 Jun 2009
Posts: 20

PostPosted: Tue Jan 24, 2012 16:48    Post subject: ipkg - error Reply with quote
version : DD-WRT v24-sp2 (12/14/11) std - build 18007

ipkg is throws errors.

root@DD-WRT:/bin# ipkg list
head: invalid option -- 1
root@DD-WRT:/bin# ./ipkg list
head: invalid option -- 1
root@DD-WRT:/bin# ipkg update
head: invalid option -- 1

Any clue/ideas?
KingJL
DD-WRT User


Joined: 04 Feb 2011
Posts: 95

PostPosted: Tue Jan 24, 2012 17:31    Post subject: Re: ipkg - error Reply with quote
vijayadik wrote:
version : DD-WRT v24-sp2 (12/14/11) std - build 18007

ipkg is throws errors.

root@DD-WRT:/bin# ipkg list
head: invalid option -- 1
root@DD-WRT:/bin# ./ipkg list
head: invalid option -- 1
root@DD-WRT:/bin# ipkg update
head: invalid option -- 1

Any clue/ideas?

This is just the beginning of your problems and there will be no help forth-coming from dd-wrt devs. Your immediate problem can be solved by copying ipkg to /tmp and editing the file (ipkg is simply a shell script). Change all instances of 'head -1' to 'head -n1' (there are 5 instances) and executing that file. I hope you compatible with unending frustration!

_________________
WRT54G V1.0, build 14853 VINT mini_USB_FTP, USB mod, pixelserv
Buffalo WZR-HP-AG300H build 17461, pixelserve
Buffalo WZR-HP-G300NH, OpenWrt (trunk build 29606), ath9k drivers, pixelserv
Ubiquiti Bullet M2, AirOS
vijayadik
DD-WRT Novice


Joined: 10 Jun 2009
Posts: 20

PostPosted: Tue Jan 24, 2012 18:57    Post subject: On to another .. Reply with quote
Thx King ...
Yup. On to another problems...
Question: How come some of the folks were able to install and run the Optware ? Agreed, I am not an expert in dd-wrt, but I am fairly ok with unix...

The problem message is :
./ipkg install libc_0.9.30.1-43.29_ar71xx.ipk o
pkg_576-2_ar71xx.ipk
ERROR: File not found: //usr/local/lib/ipkg/lists/whiterussian
You probably want to run `ipkg update'
ERROR: File not found: //usr/local/lib/ipkg/lists/non-free
You probably want to run `ipkg update'
ERROR: File not found: //usr/local/lib/ipkg/lists/backports
You probably want to run `ipkg update'
./ipkg: line 1184: sort: not found
tar: invalid option -- z
tar: invalid option -- z
ipkg_install_file: ERROR unpacking control.tar.gz from libc_0.9.30.1-43.29_ar71xx.ipk
KingJL
DD-WRT User


Joined: 04 Feb 2011
Posts: 95

PostPosted: Tue Jan 24, 2012 19:45    Post subject: Re: On to another .. Reply with quote
vijayadik wrote:
Thx King ...
Yup. On to another problems...
Question: How come some of the folks were able to install and run the Optware ? Agreed, I am not an expert in dd-wrt, but I am fairly ok with unix...

Basically, the problems that you are presently experiencing are caused by a dis-functional 'busybox'. I mistakenly in the past had said busybox was broken. I was informed that busybox was not broken, but that the problem was a 'build problem' where some of the busybox configuration parameters had not been set properly during the build process. To me, I really don't see the validity of the distinction... BusyBox still does not function as it should!

Quote:

The problem message is :
./ipkg install libc_0.9.30.1-43.29_ar71xx.ipk o
pkg_576-2_ar71xx.ipk
ERROR: File not found: //usr/local/lib/ipkg/lists/whiterussian
You probably want to run `ipkg update'
ERROR: File not found: //usr/local/lib/ipkg/lists/non-free
You probably want to run `ipkg update'
ERROR: File not found: //usr/local/lib/ipkg/lists/backports
You probably want to run `ipkg update'
./ipkg: line 1184: sort: not found
tar: invalid option -- z
tar: invalid option -- z
ipkg_install_file: ERROR unpacking control.tar.gz from libc_0.9.30.1-43.29_ar71xx.ipk

Again, the current problem is busybox... it has not been configured to support tar -z option (gzip support). You cannot edit around this error. If you do happen to find a way around that error, I assure you, there will be more that are far more serious. You will not find a build of optware packages that is compatible with your dd-wrt build. The toolchains/libraries (mainly UlibC) have become incompatible. If your objective is to run optware and take advantage of the increased memory/storage available newer units, then dd-wrt has become the wrong choice.

_________________
WRT54G V1.0, build 14853 VINT mini_USB_FTP, USB mod, pixelserv
Buffalo WZR-HP-AG300H build 17461, pixelserve
Buffalo WZR-HP-G300NH, OpenWrt (trunk build 29606), ath9k drivers, pixelserv
Ubiquiti Bullet M2, AirOS
vijayadik
DD-WRT Novice


Joined: 10 Jun 2009
Posts: 20

PostPosted: Tue Jan 24, 2012 23:42    Post subject: Agree Reply with quote
Yup. KingJL.

The lib seems to be out of date totally. eg., whiterussian was last updated on 2007. Is it affecting only the Atheros or it affects other HW also ?

Is there a way to bring this upto BS's attention or some other developer's attention?

Or just a bad luck and wait for a few years, some one will resolve !!
Goto page Previous  1, 2, 3 ... 15, 16, 17 ... 27, 28, 29  Next Display posts from previous:    Page 16 of 29
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum