WRT54G V.2 won't reset

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Author Message
golfdude
DD-WRT Novice


Joined: 24 Feb 2012
Posts: 4

PostPosted: Fri Feb 24, 2012 14:50    Post subject: WRT54G V.2 won't reset Reply with quote
I need some help! This router was given to me without any documentation. No one knows what the password is for the wifi or web interface.

I have tried to reset the router to factory defaults without any luck. I have tried regular reset method and 30/30/30 and still it is holding on to the custom settings. Here is what I know:
1. The router can be pinged without any errors.
2. The logon screen comes up requesting username and password. I have tried all of the default inputs (blank/admin, admin/admin).
3. The wireless is working and the SSID is Linksysxx.
4. I tried the following:
at the DOS prompt typed cd\
then, TFTP -i 192.168.1.1 PUT (my fw).bin
unplugged the router, plugged in and hit "Enter"

After about 15 seconds I got the error message, "Invalid Password". I tried this again and got the same results.

I know the router is working, but I can not get it for go back to factory settings.

Any thoughts? I am just stuborn and don't want the darn thing to whip me.
Sponsor
()blivion
DD-WRT Novice


Joined: 05 Aug 2010
Posts: 20

PostPosted: Fri Feb 24, 2012 16:19    Post subject: Reply with quote
I'm more of a DD-WRT user, not a DD-WRT engineer. So take any thing I say with a grain of salt.

From what I know, An SSID of anything like "Linksysxx" most likely means stock Linksys firmware... thus *NOT* a DD-WRT issue. I can't imagine some one changing the SSID to mimic the default Linksys one. If I'm right, then your *NOT* in the right area of the internet to get help with your problem. As such the mods and gurus will likely ignore your problem feeling you did not read the announcements and otherwise "do your part" to help yourself.

The reason for all this is because this forum is for "DD-WRT", the third party "hacked" firmware that can be loaded into the Linksys WRT54G routers. DD-WRT and the WRT54G are *NOT* the same thing, but they are related. This forum is *NOT* intended for stock WRT54G's. I sympathize with you COMPLETELY that this is some what confusing and probably should be made more clear. But it is what it is and I can't change it.

In any case, I'm a hardware person. So I see every problem as a hardware one. But as far as I know the only practical reason a otherwise working WRT54G, (Stock or not) device would not reset is if the reset button physically was not activating or not signaling to the chip to reset. And I know from experience that lifting traces or broken solder joints are VERY common with those types of buttons if they have ever been pressed to hard. But problems with these buttons can happen for various other reasons too. Such as the switch being corroded, cold solder joint, or bad tie down resistor.

You don't have a warranty for the device, as they are years old. So you might as well take it apart and at least look at the board near the reset button to see if a broken trace is the problem. It will do no harm to look and is easy to do and fix. You just need to mind not to pull the antenna wires to hard, which will be obvious and easy to avoid. I have taken mine apart dozens of times as well as done much worse despicable things to it. It still lives.

The front blue part is just snapped on and will come off if you grab one of the legs and pull while twisting. You may have to pull/twist hard. Or some times they just pop off on you when you pick them up. Anyway, after that, the top black part slides exposing the top of the board. To look at the bottom you just have to undo the screws holding the board to the bottom. There should be two right in the center. #2 phillips head.

The crack in the trace may be *TINY*. You may need a magnifying glass to see it. But you can be sure it will be very close to the button. Probably right where the solder and the trace meet. An easy way to find it is look while trying to move the whole button back and forth a bit. And in case you don't know, "trace" is the established name for the small light green colored wires on the circuit board. They connect the switch to the main system on a chip (SoC), among other things.

Notice before I said "otherwise working WRT54G"? It's physically possible for the firmware that's in the permanent memory chip to be just slightly broken. Or it's possible for that chip to some how be unwritable, but still be readable. Or it's even possible for the input path in the main system chip to be burned up. And it's possible none of these things would effect the rest of the system. However, this is VERY UNLIKELY. Like... I would almost say impossible. I only mention it because I realize you may know about these things, thinking I some how do not know.

I am aware of the possibility... and no... highly unlikely IMO.

Sorry for the wall of text, but I hope it was helpful.
-()blivion

_________________
Quote: "The big bang violates the first law of thermodynamics, TWICE!!"
golfdude
DD-WRT Novice


Joined: 24 Feb 2012
Posts: 4

PostPosted: Fri Feb 24, 2012 16:51    Post subject: Reply with quote
()blivion,

Thank you for the response Very Happy

I have taken the case apart and haven't found any issues. When you push the reset button it goes through the motions of resetting. Lights flashing on and off and such.
It just won't reset to default settings. Is there any way to purge the custom cofig's that you know of?

I would even consider installing the third party software. Anything just to get it to work.

I have tried holding the reset button for 5 minutes and watching the lights go through the motions. Still keeps the custom configs.

Anyway to short out the memory location?

Let me know if you have any thoughts. This is more about me beating the thing than anything else.

Thanks again.
()blivion
DD-WRT Novice


Joined: 05 Aug 2010
Posts: 20

PostPosted: Fri Feb 24, 2012 17:29    Post subject: Reply with quote
!!!WOW!!! that's really odd. Are you 100% sure your doing the reset correctly? here is a link to the stock manual for the WRT54G. Or just Google "WRT54G manual" your self.

http://ec1.images-amazon.com/media/i3d/01/A/man-migrate/MANUAL000000300.pdf

Give that a read and after a reset try to get into the box via web GUI again. I suspect it may actually be reset to defaults after all and you in fact didn't get the username/pass correct or something.

Also make sure your using IE7+ as some of the other browsers have had issues with some of the web GUI's if I remember correctly. Not sure if it matters here or not.

Otherwise it really is one of the unlikely scenarios or I missed something else.

_________________
Quote: "The big bang violates the first law of thermodynamics, TWICE!!"
golfdude
DD-WRT Novice


Joined: 24 Feb 2012
Posts: 4

PostPosted: Fri Feb 24, 2012 18:17    Post subject: Reply with quote
Thanks for the reply again, but I am resetting the unit as the instructions state to do it.

Also, if the unit was reset to the factory defaults, there would not be any security on the wireless- which there still is.

The unit just will not clear its custom settings and go back to default settings for some reason.
Murrkf
DD-WRT Guru


Joined: 22 Sep 2008
Posts: 11360

PostPosted: Fri Feb 24, 2012 18:36    Post subject: Reply with quote
Read the peacock note 1 and see if this unit has a reset problem. I can't recall if it is the g or the gs v2.

If no reset problem, flash it with dd-wrt, following the wiki instructions. Then try the 30-30-30 reset. If that doesn't work go in with a telnet connection and

erase nvram
reboot

_________________
SIG:
I'm trying to teach you to fish, not give you a fish. If you just want a fish, wait for a fisherman who hands them out. I'm more of a fishing instructor. So See this:
http://i31.tinypic.com/24mz3ms.png

LOM: "If you show that you have not bothered to read the forum announcements or to follow the advices in them then the level of help available for you will drop substantially, also known as Murrkf's law.."
golfdude
DD-WRT Novice


Joined: 24 Feb 2012
Posts: 4

PostPosted: Fri Feb 24, 2012 21:05    Post subject: Reply with quote
Thank you Murrkf for replying to my post Very Happy

I will do my best to follow the instructions. However, a lot of this is new to me and I may have some questions. Please be patient with me.

Thanks again.
josephdennis
DD-WRT Novice


Joined: 23 Mar 2013
Posts: 1

PostPosted: Sat Mar 23, 2013 3:33    Post subject: Reply with quote
Well crap I am having the same problem. Also I have tried tftp flash and it did not work. I am sure that the original poster is long gone but I just wanted to get it out there that I am having the same problem. Does anybody else have an idea on how to fix this? Or is there an easy way to crack the password?
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum