How to setup Wi-Fi repeater in a TL-WR741ND

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Author Message
userrrrr
DD-WRT Novice


Joined: 24 Feb 2012
Posts: 2

PostPosted: Fri Feb 24, 2012 16:46    Post subject: How to setup Wi-Fi repeater in a TL-WR741ND Reply with quote
Hello

I'm new to DD-WRT and I'm trying to set up a wi-fi repeater on a TL-WR741ND

I have installed the firmware but there is no option for "Repeater" on Wireless -> Basic Settings. Only Client, Client Bridge and WDS.

Is there any hardware requirement for using the repeater mode? Is it possible to use it on this particular router?

I would rather not use WDS because of the timing problems between different devices

Thanks
Sponsor
habeIchVergessen
DD-WRT User


Joined: 04 May 2010
Posts: 277

PostPosted: Fri Feb 24, 2012 17:06    Post subject: Reply with quote
for atheros use client-bridge.
Yoghurt
DD-WRT Novice


Joined: 25 Feb 2012
Posts: 5

PostPosted: Sat Feb 25, 2012 14:58    Post subject: Reply with quote
I seem to have a similar problem on my TEW-632BRP with TRENDNet router which has Atheros AR9130.

I am runing DD-wrt SVN revision 18024, which is relatively new.

There is no Repeater option in the selection box. I have Client, Client Bridge (routed), AP, WDS AP, WDS Station...
I am missing the repeater option very much.

Is it an issue with my router that does not support it or should I get a different build of the program? Currently I am runing the Client bridge (routed) mode which is working fine but I would prefer the Repeater variant.
habeIchVergessen
DD-WRT User


Joined: 04 May 2010
Posts: 277

PostPosted: Sat Feb 25, 2012 16:13    Post subject: Reply with quote
client bridge just connects to the router.

under Wireless -> Basic Settings add an virtual interface (vap).
try the ssid and security settings from router for vap.
Yoghurt
DD-WRT Novice


Joined: 25 Feb 2012
Posts: 5

PostPosted: Sat Feb 25, 2012 19:46    Post subject: Reply with quote
Aha, so the virtual interface would in effect make it into a repeater.
When I enable it, it does transmit an SSID. There aren't many settings to apply, no secutity options you speak of. I can connect to the newly established network but there is no Internet or Net access. It seems I am not getting an IP.

Can you point me to some instructions or help me yurself. I feel I'm getting close to the solution. Maybe your help will get me there.
habeIchVergessen
DD-WRT User


Joined: 04 May 2010
Posts: 277

PostPosted: Sat Feb 25, 2012 22:01    Post subject: Reply with quote
i played around with an WZR-HP-G300NH and got the same problems (no dhcp response for wireless connected clients).

after save/apply added vap just press wireless security in sub-menus and configure the vap.
Yoghurt
DD-WRT Novice


Joined: 25 Feb 2012
Posts: 5

PostPosted: Sat Feb 25, 2012 23:37    Post subject: Reply with quote
I continue fiddling with the router but it still gives me problems. I sense the solution is near.
I found a thread on the forum with instructions:
http://www.dd-wrt.com/phpBB2/viewtopic.php?t=39507

I followed the instructions which match what you said (apart from setting it to RIP2) but still no luck. I get the nework up, connect but cant get through to internet without an IP.

I also join the network on Status/wireless/site survey (what does that do?)

Any more ideas?
habeIchVergessen
DD-WRT User


Joined: 04 May 2010
Posts: 277

PostPosted: Sun Feb 26, 2012 11:28    Post subject: Reply with quote
i'm not sure that the post from 2008 gives you same useful help.

rather you should adress the issue to dev, because wired clients works as expected.
Yoghurt
DD-WRT Novice


Joined: 25 Feb 2012
Posts: 5

PostPosted: Sun Feb 26, 2012 13:36    Post subject: Reply with quote
I'm not sure what you mean by addressing the issue to dev.
habeIchVergessen
DD-WRT User


Joined: 04 May 2010
Posts: 277

PostPosted: Sun Feb 26, 2012 14:18    Post subject: Reply with quote
development
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum