DHCP client fail on linux (with DNSMasq activated)

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Author Message
Mastah
DD-WRT Novice


Joined: 20 Mar 2009
Posts: 5

PostPosted: Sun Mar 04, 2012 15:39    Post subject: DHCP client fail on linux (with DNSMasq activated) Reply with quote
Hello

I'm currently on a E4200 router. If I ever activate DNSMasq for DHCP all my Linux based dhcp client will not get the proper info (but windows client will), so they can automatically get the network info (ip, netmask, dns, ...)

It's doing the same thing on my old wrt54gl. But I know for a fact with previous revision of the dd-wrt version it was working. I can't remember with which revision it was working but it definitely was.

The weird part come here. All my windows client manage to get the DHCP info and setup the network, but all Linux based can't.

Any clue what could cause this problem ? Anyone else having this problem ?

Thanks in advance.


Edit: I'm currently on 18024
Sponsor
slobodan
DD-WRT Guru


Joined: 03 Nov 2011
Posts: 1280
Location: Zwolle

PostPosted: Mon Mar 05, 2012 13:37    Post subject: Reply with quote
There is a bug with DNSmasq and enabling Filter WAN NAT Redirection. Solution: use dhcpd instead of DNSmasq or disable that option.
_________________
Asus RT-N16 running Merlin (latest), formerly used Kong 22000++ kingkong-nv32k-broadcom with OTRW2

E4200 V1 running Kong 22000++ kingkong-nv60k-broadcom with OTRW2

2 times Linksys WRT610N V2 converted to E3000 running Kong 22000++ usb-ftp-samba3-dlna-nv60k-broadcom with OTRW2 (bridged with LAN cable)


Mastah
DD-WRT Novice


Joined: 20 Mar 2009
Posts: 5

PostPosted: Mon Mar 05, 2012 14:38    Post subject: Reply with quote
I'm using DNSmasq to pass argument for PXE. So I can't realy turn off DNSMasq for dchpd expect if you can do the pxe argument with dhcpd.
LOM
DD-WRT Guru


Joined: 28 Dec 2008
Posts: 7219

PostPosted: Mon Mar 05, 2012 15:03    Post subject: Re: DHCP client fail on linux (with DNSMasq activated) Reply with quote
Mastah wrote:
Hello

I'm currently on a E4200 router. If I ever activate DNSMasq for DHCP all my Linux based dhcp client will not get the proper info (but windows client will), so they can automatically get the network info (ip, netmask, dns, ...)

It's doing the same thing on my old wrt54gl. But I know for a fact with previous revision of the dd-wrt version it was working. I can't remember with which revision it was working but it definitely was.



Well, then load an older version of dd-wrt onto the wrt54gl and test if it works, I don't think your problem is the dd-wrt firmware.
There is no general Linux incompatibility with dnsmasq, I' running 2 Ubuntu clients, 2 linux based sat receivers, and 2 WRT54GL behind my main router (Asus RT-N16) and none of these linux clients has any problem with pulling a dhcp lease from the Asus.

What linux flavour are you using?
Have you checked if there is any known problems with it?

_________________
I'm on a whiskey diet, lost 3 days already
Mastah
DD-WRT Novice


Joined: 20 Mar 2009
Posts: 5

PostPosted: Mon Mar 05, 2012 15:33    Post subject: Reply with quote
I just did a 30/30/30 and it seem it's working properly now.
It seem it was sending a character that Linux couldn't not understand.

Anyway the 30/30/30 did the trick.
Mastah
DD-WRT Novice


Joined: 20 Mar 2009
Posts: 5

PostPosted: Fri Mar 09, 2012 15:20    Post subject: Reply with quote
After 4 days it's back to having the problem. So it's not related to 30/30/30.

It seems it's really a DDWRT problem.
Mastah
DD-WRT Novice


Joined: 20 Mar 2009
Posts: 5

PostPosted: Fri Mar 09, 2012 15:34    Post subject: Reply with quote
It seem to be a bug that does occur when you activate NAT "port/port range/..." forward.

I've also discovered that if you reboot the router, during it's reboot phase, it will provide proper information to DHCP client so they'll get network info (and change ethernet settings according to them)

So that's definitely a bug in DDWRT.
slobodan
DD-WRT Guru


Joined: 03 Nov 2011
Posts: 1280
Location: Zwolle

PostPosted: Thu Mar 29, 2012 0:27    Post subject: Reply with quote
Hi, I think I have solved it:

First, in Security / Firewall uncheck Filter WAN NAT Redirection. Click Apply.

Second, in Services / Services check Use NVRAM for client lease DB, set Used Domain to LAN and WLAN, type your domain in LAN Domain.

Set DNSMasq Enable, Local DNS Enable, No DNS Rebind Enable, and under Additional DNSMasq Options type:

bogus-priv
domain-needed
local=/yourdomainname/
expand-hosts
user=root

(Take care: in the DNSMasq options should be no domain=yourdomainname entry!)

Click Apply.

Third, under Setup / Basic Setup choose:

DHCP Type: DHCP Server
DHCP Server Enable
Check Use DNSMasq for DHCP, Use DNSMasq for DNS and DHCP-Authoritative. Click Apply.

_________________
Asus RT-N16 running Merlin (latest), formerly used Kong 22000++ kingkong-nv32k-broadcom with OTRW2

E4200 V1 running Kong 22000++ kingkong-nv60k-broadcom with OTRW2

2 times Linksys WRT610N V2 converted to E3000 running Kong 22000++ usb-ftp-samba3-dlna-nv60k-broadcom with OTRW2 (bridged with LAN cable)


Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum