TP-Link TL-WR1043ND periodically hangs, v24-sp2 svn 16994

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Author Message
swifu
DD-WRT Novice


Joined: 17 Jul 2011
Posts: 1

PostPosted: Sun Jul 17, 2011 9:44    Post subject: TP-Link TL-WR1043ND periodically hangs, v24-sp2 svn 16994 Reply with quote
Hello folks

I'm just getting started with dd-wrt. I have two WR1043ND routers that worked for several months with their default firmwares flawlessly - not a single drop of WAN or WIFI connections.

A few weeks ago I researched and identified rev 16994 as probably the best version for this model, and carefully installed it on both routers precisely according to the instructions.

The installations seemed successful except that once every couple of days the routers seem to drop the WAN connection. There is still a WIFI connection though, but when I try accessing the router via the web interface the router either doesn't respond or, sometimes, I can get the status page briefly and after a few seconds the web interface stops responding.

To restore operation of the router I am cycling the power for it, and occasionally I need to do 2-4 cycles until it reconnect properly.

How should I approach this?
Sponsor
linnemann
DD-WRT Novice


Joined: 06 Jan 2012
Posts: 1

PostPosted: Fri Jan 06, 2012 6:37    Post subject: Reply with quote
Hi

I have exactly the same problem with my TL-WR1043ND
iamgoinbiking
DD-WRT Novice


Joined: 09 Jan 2012
Posts: 3

PostPosted: Mon Jan 09, 2012 6:03    Post subject: Reply with quote
Guys, My router has been doing the same after I updated to the latest TP-Link firmware. I was going to flash DD-WRT hoping that would solve my problem but looks like the flashing process inherently screws up (potentially) the router no matter what you are flashing.
mrbrdo
DD-WRT Novice


Joined: 30 Jan 2008
Posts: 15

PostPosted: Sun Feb 12, 2012 17:09    Post subject: Reply with quote
I have the exact same problem. Never used the original firmware.
1 hardware reboot (disconnect power) always works for me.
lsd2k
DD-WRT Novice


Joined: 30 Jan 2012
Posts: 7

PostPosted: Mon Feb 13, 2012 22:14    Post subject: Reply with quote
Who do you say that 16994 is most stable?
giovanni000
DD-WRT Novice


Joined: 12 Apr 2012
Posts: 1

PostPosted: Thu Apr 12, 2012 7:07    Post subject: Same problem here.. Reply with quote
i'am using brand new Router Model TP-Link TL-WR1043ND
Firmware Version DD-WRT v24-sp2 (08/07/10) std - build 14896.

Every few days this router hangs up. No web login is possible so hard reset is the only way. After plug in&out it works normally.

All functions are working smoothly..

Any idea how to permanently fix this problem?

Thanks for advice.
Juniorek
DD-WRT Novice


Joined: 14 Feb 2011
Posts: 42

PostPosted: Thu Apr 12, 2012 8:17    Post subject: Reply with quote
update your router to 18024 or 18777

before doing it do a 30/30/30 and after the upgrade do it again

of course - lan cable not wifi


write down your configs


bet wifi conf for me: ng-mixed, manual channel setting, manual wide channel setting, channel width: if you`r using n-clients then turbo, if g/n then dynamic

_________________
TP-Link TL-WDR4300 v1 - DD-WRT std svn 23503;?
tatsuya46
DD-WRT Guru


Joined: 03 Jan 2010
Posts: 2323
Location: Winnipeg, Canada

PostPosted: Thu Apr 12, 2012 18:50    Post subject: Reply with quote
ftp://ftp.dd-wrt.com/others/eko/BrainSlayer-V24-preSP2/2012/03-19-12-r18777/tplink_tl-wr1043nd/
_________________
[QUALCOMM ATHEROS] D-Link DIR-825 B1 -----------> DD-WRT v24-sp2 (12/15/14) std - build 25648
[QUALCOMM ATHEROS] TP-LINK TL-WDR4900 v1.3 --> DD-WRT v24-sp2 (12/20/14) std - build 25684 (private test)
[QUALCOMM ATHEROS] NETGEAR WNDR3700 v1 -----> DD-WRT v24-sp2 (12/20/14) std - build 25684 (private test)
[QUALCOMM ATHEROS] NETGEAR WNDR4300 v1 -----> DD-WRT v24-sp2 (12/20/14) std - build 25684 (private test)

LATEST FIRMWARE(S) --> ftp://ftp.dd-wrt.com/betas/
Qualcomm Atheros Wi-Fi Settings --> http://dd-wrt.com/wiki/index.php/QCA_wireless_settings
Qualcomm Atheros Client/Repeater Bridge --> http://dd-wrt.com/wiki/index.php/Repeater_Bridge#Qualcomm_Atheros

BrainSlayer wrote:
we just do it since we do not like any restrictions enforced by stupid cocaine snorting managers
checho
DD-WRT Guru


Joined: 27 Feb 2007
Posts: 505
Location: Bulgaria

PostPosted: Fri Apr 13, 2012 8:24    Post subject: Reply with quote
Juniorek wrote:
update your router to 18024 or 18777

before doing it do a 30/30/30 and after the upgrade do it again

of course - lan cable not wifi


yes. Update any atheros build you may have to newer than 18024. Newer are with kernel ver.3.
Look at this -> http://svn.dd-wrt.com:8000/ticket/2427
I think your complaints are quite similar to what I noted before switching to newer kernel. If yes, then upgrade.

I recommend one who wants to upgrade their atheros to wait for the new beta after 18777 which is promised to appear 'soon'. This is because 18777 does have some LED issues with TP-LINK devices like TL-WR741ND having all lights on. Also, TL-WR841N will have its wifi led working on the next beta. Not to mention the newer wifi driver after 17990 which has made a difference like that in driving bentley instead of 20-year old car...
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum