dlink 825 multiple wlans, port forwarding

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Author Message
supernoman
DD-WRT Novice


Joined: 23 Apr 2012
Posts: 4

PostPosted: Mon Apr 23, 2012 22:03    Post subject: dlink 825 multiple wlans, port forwarding Reply with quote
I followed the wiki here, http://www.dd-wrt.com/wiki/index.php/Multiple_WLANs. I have all (private, 5ghz private, guest) all working. Bridges can't access one another.

My port forwards set in the gui don't seem to be working. I have an ftp server with a static IP that I can't access remotely even when I set tcp port 21 to forward to it. Are the firewall rules that I added to Administration -> commands, overriding the port forwarding in the gui?

Build BrainSlayer-V24-preSP2/2012/03-19-12-r18777


Last edited by supernoman on Mon Apr 23, 2012 22:24; edited 1 time in total
Sponsor
buddee
DD-WRT Guru


Joined: 06 Feb 2010
Posts: 7382
Location: Little Rock

PostPosted: Mon Apr 23, 2012 22:13    Post subject: Reply with quote
How would we know if the firewall rules are blocking? You don't list them..
_________________
Wireless N Config | Linking Routers | DD-WRT Wiki | DD-WRT Builds | Peacock - Broadcom FAQ

Having problems with port forwarding? Check out Port Forward Troubleshooting for more info.
supernoman
DD-WRT Novice


Joined: 23 Apr 2012
Posts: 4

PostPosted: Mon Apr 23, 2012 22:17    Post subject: Reply with quote
I know...I will update post once I can get home to do so (since I lost remote access).

From the wiki, I should have:

iptables -t nat -I POSTROUTING -o `get_wanface` -j SNAT --to `nvram get wan_ipaddr`
iptables -I FORWARD -i br1 -o br0 -m state --state NEW -j DROP
iptables -I FORWARD -i br0 -o br1 -m state --state NEW -j DROP
iptables -I FORWARD -i br1 -d `nvram get wan_ipaddr`/`nvram get wan_netmask` -m state --state NEW -j DROP
iptables -I INPUT -i br1 -m state --state NEW -j DROP
iptables -I INPUT -i br1 -p udp --dport 67 -j ACCEPT
iptables -I INPUT -i br1 -p udp --dport 53 -j ACCEPT
iptables -I INPUT -i br1 -p tcp --dport 53 -j ACCEPT

Save Firewall
buddee
DD-WRT Guru


Joined: 06 Feb 2010
Posts: 7382
Location: Little Rock

PostPosted: Mon Apr 23, 2012 22:19    Post subject: Reply with quote
Do you have the FTP setup on br1?
_________________
Wireless N Config | Linking Routers | DD-WRT Wiki | DD-WRT Builds | Peacock - Broadcom FAQ

Having problems with port forwarding? Check out Port Forward Troubleshooting for more info.
supernoman
DD-WRT Novice


Joined: 23 Apr 2012
Posts: 4

PostPosted: Mon Apr 23, 2012 22:20    Post subject: Reply with quote
No, FTP (static IP, ethernet) is on br0 with eth0, ath0, ath1
br1 has ath0.1.
buddee
DD-WRT Guru


Joined: 06 Feb 2010
Posts: 7382
Location: Little Rock

PostPosted: Mon Apr 23, 2012 22:24    Post subject: Reply with quote
I don't see anything in your rule set that would block access to an FTP server running on br0...

Have you tried the loopback code fix, and then once entered, try to access it? Not sure why it would matter but its worth a try..

_________________
Wireless N Config | Linking Routers | DD-WRT Wiki | DD-WRT Builds | Peacock - Broadcom FAQ

Having problems with port forwarding? Check out Port Forward Troubleshooting for more info.
supernoman
DD-WRT Novice


Joined: 23 Apr 2012
Posts: 4

PostPosted: Mon Apr 23, 2012 22:29    Post subject: Reply with quote
I'll try adding this when I get home, per the thread I found about NAT loopback issue. 192.168.0.0/24 is my eth0/ath0/ath1/br0 network.

iptables -t nat -I POSTROUTING -o br0 -s 192.168.0.0/24 -d 192.168.0.0/24 -j MASQUERADE
chezpaul
DD-WRT Novice


Joined: 14 Apr 2012
Posts: 7

PostPosted: Thu Apr 26, 2012 7:01    Post subject: Reply with quote
My port forwarding also doesn't work on my dir 825 running r18777
Could it be the D link itself?
I've read posts of people having problems with stock firmware and port forwarding
pbgarcol
DD-WRT Novice


Joined: 20 Feb 2012
Posts: 27

PostPosted: Sun Apr 29, 2012 7:12    Post subject: Reply with quote
chezpaul wrote:
My port forwarding also doesn't work on my dir 825 running r18777
Could it be the D link itself?
I've read posts of people having problems with stock firmware and port forwarding

Hi,
I would not say it has something to do with the D-link. I use port forwarding to access an IP camera remotely and it worked fine with stock firmware. I flashed to DD-WRT (build 18024 for me, did not try later versions so far) and port forwarding works fine as well. maybe you should check your settings (common tools work with http or ftp)?
paulpianta
DD-WRT Novice


Joined: 02 May 2012
Posts: 4

PostPosted: Wed May 02, 2012 4:38    Post subject: Reply with quote
I have been killing myself over the same issue here with a DIR-825 and trying to forward port 21 to a DNS-323 with the ftp server running.

It has been working before and for some reason now it isn't.

Other ports that I forward seem to work ok (bitorrent, rdp, etc) but it is really just 21 that seems to be bugging.

I can access the ftp server internally no problem. But from outside, even a telnet to port 21 fails. It isn't refused - it times out.

Paul
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum