Huawei E398 (an 4g USB modem) on an Linksys E4200

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Author Message
makke
DD-WRT Novice


Joined: 26 Apr 2012
Posts: 6

PostPosted: Thu Apr 26, 2012 22:00    Post subject: Huawei E398 (an 4g USB modem) on an Linksys E4200 Reply with quote
Modem: Huawei E398
Router: Linksys E4200 running DD-WRT v24-sp2 (03/19/12) mega - build 18777

I have connected the USB modem to the USB port, and choosen WAN connection Type according to the settings I should have,
the modem starts flashing blue as if it has connected, but my router doesn't get any WAN IP and when I press connect it just load
some and then stays disconnected. I read a bunch on the forum and found some post saying that i should have the router in switch mode,
tried to change all the settings, but it still doesn't work.
I have also tried a bounch of other stuff I found on the forum, but nothing seams to help.

I read the post Huawei "e398 USB modem as WAN" but nothing in there helped.


cat /proc/bus/usb/devices gives:

T: Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 4 Spd=480 MxCh= 0
D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
P: Vendor=12d1 ProdID=1505 Rev= 0.00
S: Manufacturer=Huawei Technologies
S: Product=HUAWEI Mobile
C:* #Ifs= 1 Cfg#= 1 Atr=c0 MxPwr=500mA
I:* If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=(none)
E: Ad=81(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E: Ad=01(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms

I have removed the pin for the modem to see if that helped, but it didn't.
Under Status/WAN i can see the strenght of the reception, but it just won't connect.

I'm using the same Dail String as the software that came with the modem, and same with APN.

Any one have an idéa? I'm kinda new to this, so if you need more info, please tell me and also how i get it. There must be something that I have missed.
Thanks
Sponsor
LOM
DD-WRT Guru


Joined: 28 Dec 2008
Posts: 7095

PostPosted: Fri Apr 27, 2012 3:39    Post subject: Reply with quote
Your stick has not switched from cd-rom mode to modem mode, it should have since the stick is supported from changeset 18756.

Test with Eko's latest build here:
ftp://dd-wrt.com/others/eko/V24-K26/svn18946/

and do also test with a build type different from mega (big or usb_nas) in case something has gone missing in the mega build.

_________________
I'm on a whiskey diet, lost 3 days already
makke
DD-WRT Novice


Joined: 26 Apr 2012
Posts: 6

PostPosted: Fri Apr 27, 2012 7:27    Post subject: Reply with quote
Thanks for the reply, how can you see that it has not switched? I have tried dd-wrt.v24-18774_NEWD-2_K2.6_big but it had the same result as this one, but I will check out the latest build, will post the results.
makke
DD-WRT Novice


Joined: 26 Apr 2012
Posts: 6

PostPosted: Fri Apr 27, 2012 7:58    Post subject: Reply with quote
dd-wrt.v24-18946_NEWD-2_K2.6_big-nv60k

T: Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 3 Spd=480 MxCh= 0
D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
P: Vendor=12d1 ProdID=1506 Rev= 0.00
S: Manufacturer=Huawei Technologies
S: Product=HUAWEI Mobile
C:* #Ifs= 7 Cfg#= 1 Atr=c0 MxPwr=500mA
I:* If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=01 Prot=01 Driver=(none)
E: Ad=81(I) Atr=03(Int.) MxPS= 64 Ivl=2ms
E: Ad=82(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E: Ad=01(O) Atr=02(Bulk) MxPS= 512 Ivl=4ms
I:* If#= 1 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=01 Prot=02 Driver=(none)
E: Ad=83(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E: Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=4ms
I:* If#= 2 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=01 Prot=03 Driver=(none)
E: Ad=84(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E: Ad=03(O) Atr=02(Bulk) MxPS= 512 Ivl=4ms
I:* If#= 3 Alt= 0 #EPs= 1 Cls=ff(vend.) Sub=01 Prot=09 Driver=(none)
E: Ad=85(I) Atr=03(Int.) MxPS= 64 Ivl=2ms
I:* If#= 4 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=01 Prot=08 Driver=(none)
E: Ad=86(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E: Ad=04(O) Atr=02(Bulk) MxPS= 512 Ivl=4ms
I:* If#= 5 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=(none)
E: Ad=87(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E: Ad=05(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
I:* If#= 6 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=(none)
E: Ad=06(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E: Ad=88(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms

dd-wrt.v24-18946_NEWD-2_K2.6_std_usb_nas-nv60k

Doesn't show 3G connections as an option.

dd-wrt.v24-18946_NEWD-2_K2.6_mega-nv60k

cat /proc/bus/usb/devices

T: Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 3 Spd=480 MxCh= 0
D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
P: Vendor=12d1 ProdID=1506 Rev= 0.00
S: Manufacturer=Huawei Technologies
S: Product=HUAWEI Mobile
C:* #Ifs= 7 Cfg#= 1 Atr=c0 MxPwr=500mA
I:* If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=01 Prot=01 Driver=(none)
E: Ad=81(I) Atr=03(Int.) MxPS= 64 Ivl=2ms
E: Ad=82(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E: Ad=01(O) Atr=02(Bulk) MxPS= 512 Ivl=4ms
I:* If#= 1 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=01 Prot=02 Driver=(none)
E: Ad=83(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E: Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=4ms
I:* If#= 2 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=01 Prot=03 Driver=(none)
E: Ad=84(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E: Ad=03(O) Atr=02(Bulk) MxPS= 512 Ivl=4ms
I:* If#= 3 Alt= 0 #EPs= 1 Cls=ff(vend.) Sub=01 Prot=09 Driver=(none)
E: Ad=85(I) Atr=03(Int.) MxPS= 64 Ivl=2ms
I:* If#= 4 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=01 Prot=08 Driver=(none)
E: Ad=86(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E: Ad=04(O) Atr=02(Bulk) MxPS= 512 Ivl=4ms
I:* If#= 5 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=(none)
E: Ad=87(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E: Ad=05(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
I:* If#= 6 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=(none)
E: Ad=06(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E: Ad=88(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms

And still no connection, altho I did not turn my router in to a switch this time, is it necessary to do that?
I would like it as an router just as it is now, but with the 4G modem instead of the DSL modem that I have.
LOM
DD-WRT Guru


Joined: 28 Dec 2008
Posts: 7095

PostPosted: Fri Apr 27, 2012 9:14    Post subject: Reply with quote
makke wrote:
Thanks for the reply, how can you see that it has not switched? I have tried dd-wrt.v24-18774_NEWD-2_K2.6_big but it had the same result as this one, but I will check out the latest build, will post the results.


Your first devices list had the stick with usb vid:pid 12d1:1505 which is an id for cd-rom mode and consequently also has only 1 interface which is of type Storage.

After changing build your stick has switched mode into modem mode (12d1:1506) and has now 7 different interfaces.

There must have been some quirk with E4200 and r18777 then or maybe you forgot to configure WAN as 3G when running r18777 ?

There is still one remaining problem in your devices list and that is "Driver=(none) ".
It is caused by an older driver not having your stick supported, I will have to push for the developers to update it.

_________________
I'm on a whiskey diet, lost 3 days already
makke
DD-WRT Novice


Joined: 26 Apr 2012
Posts: 6

PostPosted: Fri Apr 27, 2012 9:19    Post subject: Reply with quote
Ok, thanks for you replies, so in short, there is nothing I can do right now, but to see when there is a newer build I can test, and see when the stick picks up an driver?

Even if there is nothing to do but wait, I'm still very great full for your help!
walinaya
DD-WRT Novice


Joined: 17 Sep 2010
Posts: 2

PostPosted: Sun Apr 29, 2012 3:00    Post subject: Reply with quote
makke wrote:
Ok, thanks for you replies, so in short, there is nothing I can do right now, but to see when there is a newer build I can test, and see when the stick picks up an driver?

Even if there is nothing to do but wait, I'm still very great full for your help!


getting same problem but solved by disabling cd-rom and card reader-mode on usb stick.

heres the step :
1) Connect the modem to a PC running Windows and make sure it works.
2) Disconnect your computer from the network and the Internet and run Hyper Terminal.
Hyper Terminal program found under Start> Programs> Accessories> Communications> Hyper Terminal - in running Windows XP, and for Windows7 it to load.
3) In the "Connection Description" write any name, say "Huawei", and press ENTER. We are waiting for the appearance of the window "Connect". In his latest column "Connect using" to select "HUAWEI Mobile Connect - 3G Modem" and click OK.
Next after that a window with a phone number and other parameters need to just close by pressing the "Cancel".
4) Now on the toolbar of the program, press the last button "Properties":
And that opens the Properties window: the modem "select the tab" Options:
Click "Options ASCII":
Put a tick in the second top box "Show input characters on the screen."
Click OK. The top window is closed. Click OK. The last window closes, and the main window, flashing cursor.
5) Turn on CAPS LOCK and print command AT. Press ENTER. Comes the answer: OK. Means connected to the modem is installed. Introduce one of the following:
AT ^ U2DIAG = 0 (device-only modem)
AT ^ U2DIAG = 1 (the device as a modem + CD-ROM)
AT ^ U2DIAG = 255 (the device as a modem + CD-ROM + Card Reader)
AT ^ U2DIAG = 256 (the device as a modem + Card Reader).
For successful operation the modem into a tablet to take command AT ^ U2DIAG = 0, and put it to "just a modem." Typing, press ENTER, and in return see OK.
Close the window Hyper Terminal, answering "Yes" to the proposal to interrupt a session and refusing to stay connected.
6) Make sure that emulation CD-ROM is disabled. To do this, disconnect the modem from the USB port and then connected in the same port. In "My Computer" should not appear "new" CD-ROM - only those that actually are.
If they need to return the modem to its original state, you must repeat the entire procedure, but with the team AT ^ U2DIAG = 255 (the device as a modem + CD-ROM + Card Reader).


Now usb stick being detected as modem but still not able to connect

BTW using Huawei e1550 , 18946-TNG on wrt350n . Hope someone might help.
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum