Configuring CHAP Authentication for usb 3g modem

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Advanced Networking
Author Message
chomli1981
DD-WRT Novice


Joined: 24 Dec 2007
Posts: 3

PostPosted: Sat Jun 02, 2012 8:04    Post subject: Configuring CHAP Authentication for usb 3g modem Reply with quote
I have gigaset sx763 router with FW version v24-sp2(03/06/12)std-build 18678.

When I'm connecting with ISP that requires PAP authentication, usb 3g modem(huawei K3565) works OK,
but with ISP that requires CHAP authentication,modem cannot connect. Is there way to configure this?

Also I tried other several usb 3g modems that are listed as "supported" but I couldn't find a way to make connection.
Sponsor
BrainSlayer
Site Admin


Joined: 06 Jun 2006
Posts: 6113
Location: Dresden, Germany

PostPosted: Sat Jun 02, 2012 13:55    Post subject: Reply with quote
for chap authentication a valid username and password is required. thats all. otherwise the reason for your fail must be different. so check that all data you entered is correct
_________________
one cigarette costs 2 minutes of your life.
one bottle of beer costs 4 minutes of your life.
one working day costs 8 hours of your life.

DD-WRT supported Concerts @ Bunker Dresden
03.10.2014 - Front 242 / Haujobb / Planet Myer Day
LOM
DD-WRT Guru


Joined: 28 Dec 2008
Posts: 7163

PostPosted: Sat Jun 02, 2012 15:06    Post subject: Re: Configuring CHAP Authentication for usb 3g modem Reply with quote
chomli1981 wrote:
with ISP that requires CHAP authentication,modem cannot connect. Is there way to configure this?



What info have your ISP given to you for doing the CHAP connection?

1. user/pwd (PAP-secret)

or

2. clientname/servername/secret (CHAP-secret)

_________________
I'm on a whiskey diet, lost 3 days already
BrainSlayer
Site Admin


Joined: 06 Jun 2006
Posts: 6113
Location: Dresden, Germany

PostPosted: Sat Jun 02, 2012 15:39    Post subject: Reply with quote
der username is the client name and the secret is the password. the server is masked as a asterisk
_________________
one cigarette costs 2 minutes of your life.
one bottle of beer costs 4 minutes of your life.
one working day costs 8 hours of your life.

DD-WRT supported Concerts @ Bunker Dresden
03.10.2014 - Front 242 / Haujobb / Planet Myer Day
BrainSlayer
Site Admin


Joined: 06 Jun 2006
Posts: 6113
Location: Dresden, Germany

PostPosted: Sat Jun 02, 2012 16:05    Post subject: Reply with quote
this firmware contains experimental chap-secrets support. i have no idea if this will work. i also have not tested it on the gigaset itself since my device is not here locally where i'm working currently
_________________
one cigarette costs 2 minutes of your life.
one bottle of beer costs 4 minutes of your life.
one working day costs 8 hours of your life.

DD-WRT supported Concerts @ Bunker Dresden
03.10.2014 - Front 242 / Haujobb / Planet Myer Day
LOM
DD-WRT Guru


Joined: 28 Dec 2008
Posts: 7163

PostPosted: Sat Jun 02, 2012 16:09    Post subject: Re: Configuring CHAP Authentication for usb 3g modem Reply with quote
BrainSlayer wrote:
der username is the client name and the secret is the password. the server is masked as a asterisk


ok, got it.


chomli1981 wrote:

Also I tried other several usb 3g modems that are listed as "supported" but I couldn't find a way to make connection.


http://www.dd-wrt.com/wiki/index.php/Mobile_Broadband#Not_Supported_Modems_or_Not_Working_Modems

Give me the first info ie lsusb or equivalent (dmesg and comgt not needed) and I can tell you if they are currently unsupported or are already included for support in the next published build.

_________________
I'm on a whiskey diet, lost 3 days already
chomli1981
DD-WRT Novice


Joined: 24 Dec 2007
Posts: 3

PostPosted: Sat Jun 02, 2012 19:04    Post subject: Reply with quote
Ok guys, thanks for you respond.
Well I was wrong...

I found out that my other ISP(I gonna call it ISP2)actually doesnt need CHAP, only username and password.
I'm 100% sure that username/password are correct becouse it works when I plug modem directly into PC but dd-wrt cannot connect...

ISP1(which works) doesn't require username/password so it's only difference.

This new firmware from BrainSlayer doesn't fix this problem above but my other usb 3g modem(zte mf100) now works too(ofc with ISP1)! Smile so I'm grateful for that Smile
BrainSlayer
Site Admin


Joined: 06 Jun 2006
Posts: 6113
Location: Dresden, Germany

PostPosted: Sat Jun 02, 2012 20:02    Post subject: Reply with quote
if one isp works and the other does not, the modem is not the problem. but the data you entered usually. for example. some carriers do not require username or password but they required something which must be entered into the fields. the code for username and password data is definitly correct. so what ever this isp is doing has something todo with the data which needs to be entered. apn, etc. something must be incorrect
_________________
one cigarette costs 2 minutes of your life.
one bottle of beer costs 4 minutes of your life.
one working day costs 8 hours of your life.

DD-WRT supported Concerts @ Bunker Dresden
03.10.2014 - Front 242 / Haujobb / Planet Myer Day
chomli1981
DD-WRT Novice


Joined: 24 Dec 2007
Posts: 3

PostPosted: Sat Jun 02, 2012 20:32    Post subject: Reply with quote
this are router settings:


and this are settings on pc that works:
mehnihma
DD-WRT Novice


Joined: 28 Oct 2012
Posts: 1

PostPosted: Sun Oct 28, 2012 14:30    Post subject: PAP Reply with quote
I have the same problem, I have USB stick MF 190,
I have tried to enter:
usb_modeswitch -I -v 19d2 -p 2000 -V 19d2 -P 0017 -M "55534243123456780000000000000011062000000100000000000000000000"


But nothing works, downloaded newest firmware. How can I accomplish this?
oskreso
DD-WRT Novice


Joined: 17 Dec 2011
Posts: 11

PostPosted: Sat Jan 26, 2013 15:30    Post subject: pap authentification Reply with quote
Hello,

I am using sx763 router with SVN revision 18687.

I can't make 3g wan connection to "carnet" apn which requires pap auth.
I am able to create 3g wan connection to second apn which doesn't require authentification.

I've set this parameters with nvram:

l2tp_ref_pap=no
l2tp_ref_chap=yes
l2tp_req_chap=no

But it's still not working.
Does anyone knows how to make pap (only) work?


chomli1981 wrote:
this are router settings:


and this are settings on pc that works:
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Advanced Networking All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum