D-Link DIR-632

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Goto page Previous  1, 2, 3 ... 15, 16, 17 ... 27, 28, 29  Next
Author Message
Cmp_Cmndo
DD-WRT User


Joined: 14 Dec 2011
Posts: 99
Location: FL-USA

PostPosted: Fri Jun 08, 2012 23:11    Post subject: Reply with quote
There is no reason to setup a static IP. If you make a connection to the router & can communicate with it, that's all that matters.
The "How to upgrade with new DD-WRT firmware" is much more important.
http://www.dd-wrt.com/wiki/index.php/D-Link_DIR-632

There are no guarantees when flashing new firmware. I can guarantee that the DD-WRT firmware will eliminate the WiFi dropouts.
Sponsor
DasShrubber2
DD-WRT User


Joined: 31 Oct 2011
Posts: 61

PostPosted: Sun Jun 10, 2012 23:08    Post subject: Reply with quote
New version of firmware seems to work ok.

DD-WRT v24-sp2 (06/08/12) std
(SVN revision 19342)
Plopsicle
DD-WRT Novice


Joined: 08 Jun 2012
Posts: 4

PostPosted: Tue Jun 12, 2012 3:39    Post subject: Reply with quote
So I tried making my router flash yellow, but instead it flashes orange. However, when it's flashing orange, my computer can't access 192.168.0.1, though one time I got this weird page, but I didn't want to risk messing up.


--D-LINK Firmware Upgrade System

-------- Version 1.0.0.0 (Language Pack Support)

------ -Date 2009/07/15

File Path

NOTICE !!
If you upload the binary file to the wrong TARGET, the router may not work properly or even could not boot-up again.
Support Flash Intel J28F128, MXIC 29LV640BT, ST 29W640FT

Help would be greatly appreciated!
Cmp_Cmndo
DD-WRT User


Joined: 14 Dec 2011
Posts: 99
Location: FL-USA

PostPosted: Thu Jun 14, 2012 23:16    Post subject: Reply with quote
DasShrubber2 wrote:
New version of firmware seems to work ok.

DD-WRT v24-sp2 (06/08/12) std
(SVN revision 19342)

I'm still using Firmware Version
DD-WRT v24-sp2 (12/20/11) std - build 18024

Any compelling reason to change it?
Plopsicle
DD-WRT Novice


Joined: 08 Jun 2012
Posts: 4

PostPosted: Fri Jun 15, 2012 4:53    Post subject: Reply with quote
Is it fine If I just load dd wrt without making the router flash yellow? Holding it for 30s just makes it reset, and holding it while it resets makes it flash orange, but the admin page won't load. Sorry If I seem impatient, but my return time on the router is up in a few days!
Cmp_Cmndo
DD-WRT User


Joined: 14 Dec 2011
Posts: 99
Location: FL-USA

PostPosted: Fri Jun 15, 2012 11:58    Post subject: Reply with quote
Plopsicle wrote:
Is it fine If I just load dd wrt without making the router flash yellow? Holding it for 30s just makes it reset, and holding it while it resets makes it flash orange, but the admin page won't load. Sorry If I seem impatient, but my return time on the router is up in a few days!

Yes. No need to reset router. Not sure why those steps are listed. Could be a remnant from another router's Wiki. DasShrubber2 might know. He is able to edit the Wiki which needs updating.

5-1. The D-link's default login details are user "admin", password is blank.
5-2. Tools -> Firmware
5-3. Click "browse" button -> select the "factory-to-ddwrt_NA.bin" file -> click "Upload" button.
5-4. Wait 2 or 3 minutes for the DIR-632 to flash and do the update. You will see a status page that shows you the progress as it happens. After the flash & update is done, the router will reboot to dd-wrt, and the IP address will have changed to 192.168.1.1. There is no need to reset.
cassioac
DD-WRT Novice


Joined: 26 Apr 2007
Posts: 7

PostPosted: Sat Jun 16, 2012 5:13    Post subject: Australia is 02 Reply with quote
I confirm that the signature for Australia dir-623 is A101-AR7242-RT-100324-02.

DasShrubber2 wrote:
What Brainslayer would need is the Firmware Signature for the box in Australia. This would be similar to the DIR-825

dir-825
NA 00AP94-AR7161-RT-080619-00
TW AP94-AR7161-RT-080619-00
WW 01AP94-AR7161-RT-080619-00

dir-623
NA A101-AR7242-RT-100324-01
TW A101-AR7242-RT-100324-02 (got this from the TW firmware download page).
WW A101-AR7242-RT-100324-03 (a guess... )

You can try a Hex Editor and modify the bin file. The Signature is right at the end.
Cmp_Cmndo
DD-WRT User


Joined: 14 Dec 2011
Posts: 99
Location: FL-USA

PostPosted: Sat Jun 16, 2012 20:26    Post subject: Reply with quote
I guess you missed this post back in Dec 2011.

DasShrubber2 wrote:
Perfect. So the signature suffix pretty well corresponds to the geographical breakdown as shown on dlink.com

NA (I think all the americas) = 1
SA (Southeast Asia) = 2
WW (Europe) = 3

I've ammended the wiki page.

This is the NA signature for R19342:
A101-AR7242-RT-100324-01
monkUsa
DD-WRT Novice


Joined: 18 Jun 2012
Posts: 6

PostPosted: Mon Jun 18, 2012 15:34    Post subject: Re: Dropped Wifi Reply with quote
psmedley wrote:
davidjaquith wrote:
So, I bought the DIR-632 and I immediately put DD-WRT on it.


Same here. Got the router on a one day sale for $A49.95 delivered - had to edit the firmware with a hex editor to make it load on an AU model, but process was pretty trivial.

All working great now as a second AP in my house Smile


I picked up two of these routers from Officeworks for AU$58 each.

One will stay stock standard until I get all the settings worked out. The other one is flashed with "Factory-to-ddwrt r18777"; I did the hex edit and changed the region from "1" to "2".

If anyone is interested, I have uploaded it to my UpLoaded.Net and RapidShare.Com account to share. (NOTE: These BIN files have been successfully installed on Australian models of the router, P/N: IIR632NEU....A1G, Model No.: DIR-632, H/W Ver.: A1, F/W Ver.: 1.02, UPC Code: 790069340697.)

Release r20548 : 29-January-2013
Code:
http://ul.to/t0k45f6p
OR
http://rapidshare.com/files/1034915186/factory-to-ddwrt_r20548AU.bin


Release r19342 : 9-July-2012
Code:
http://ul.to/eyffghin
OR
https://rapidshare.com/files/300422164/factory-to-ddwrt_r19342AU.bin


Release r18777 : 18-June-2012
Code:
http://ul.to/gizvrbkc
OR
https://rapidshare.com/files/301703455/factory-to-ddwrt_r18777AU.bin


[EDIT]
I now have both DIR-632's running DD-WRT and configured the way I want.

I'll post my configuration details with pictures to help others set themselves up.

In summary, I have a Modem Router connected to the Internet. I then have each DIR-632 connected to the router in individual ports. All connected network devices (Media Centre, Printer, Games Console, etc.) are accessible from anywhere within the network.


Last edited by monkUsa on Mon Jan 28, 2013 21:13; edited 3 times in total
monkUsa
DD-WRT Novice


Joined: 18 Jun 2012
Posts: 6

PostPosted: Thu Jun 21, 2012 2:30    Post subject: Reply with quote
Here is some information that may help others (not just DD-WRT users) on how I connected 3 routers together with the ability to use the Internet from anywhere on the network and also to see all devices and shares regardless of where they linked into the network.

Please see attachment below for the basic network layout (you must be a registered user and logged in to be able to see images in these forums).

Most of the set up of the routers is very basic and you will be able to easily follow the diagram. Set up your Modem Router with the IP Address 192.168.1.1 and Subnet Mask 255.255.0.0.

Now, the tricky part is getting the Lounge Room router and the Study Room router to talk to one another. The basic steps are as follows...

Lounge Room router
Set up the local IP 192.168.2.1, Subnet Mask 255.255.0.0, the Gateway is your Modem Router's IP which is 192.168.1.1, and the DNS address will be also be 192.168.1.1. Find the options for DHCP settings, and choose to make this router a DHCP Forwarder and the IP Address of the DHCP server is 192.168.1.1. Save your settings.

Now you need to go to the Wireless tab, then on the Basic Settings sub-tab you need to select "AP" for its Wireless Mode. Also, set a Wireless Network Name (SSID) that is simple, e.g. Lounge. Save your settings. Next, you can click on the Wireless Security sub-tab and set up your security. Save your settings first. After the save, you can then Apply Settings and the router will reboot automatically.

Study Room router
Set up the local IP 192.168.3.1, Subnet Mask 255.255.0.0, the Gateway is your Lounge Room Router's IP which is 192.168.2.1 and the DNS server is your Modem Router's address which is 192.168.1.1. You will notice that there is an option for DHCP which we will ignore because this option will disappear when we set up the wireless in the next section. Save your settings.

Click on the Wireless tab, then on the Basic Settings sub-tab you need to select "Client Bridge (Routed)" for its Wireless Mode. Save your settings. You will now see that you have some new options to fill in on the page. For the Default GW Mode, select Manual. Then, for your Gateway enter the IP Address of the Lounge router, e.g. 192.168.2.1 Now, your Wireless Network Name (SSID) must be identical to the name given to your lounge room router, e.g. Lounge. Save your settings again- DO NOT APPLY SETTINGS YET. Next, you can click on the Wireless Security sub-tab and set up your security to be identical (including password) to the lounge room router. Save your settings first. After the save, you can then Apply Settings and the router will reboot automatically.

The Final Step - Reboot the whole Network
The final step to get everything talking correctly to one another is to reboot the whole network.

Turn off all of your routers (your attached devices should also be switched off to ensure correct IP assignments are made).

Switch ON the LAST router; in my case, it is the Study Room router. But do not turn any attached devices on.

Wait 30 seconds to 60 seconds.

Switch the next router in line ON (2nd last router); in my case it is the Lounge Room router.

Wait 30 seconds to 60 seconds.

Switch the next router ON (my first router); in my case it is the Modem Router.

Wait 30 seconds to 60 seconds.

Now you can switch any or all of your network attached devices in no particular order.

Testing the Network
Jump onto the Internet from any device that is connected to any of the routers, or log into any of the routers using their IP address.

Enjoy!
adayforgotten
DD-WRT Novice


Joined: 16 Dec 2010
Posts: 10

PostPosted: Thu Jun 21, 2012 17:35    Post subject: Flat Network? Reply with quote
monkUsa wrote:
Here is some information that may help others (not just DD-WRT users) on how I connected 3 routers together with the ability to use the Internet from anywhere on the network and also to see all devices and shares regardless of where they linked into the network.

Please see attachment below for the basic network layout (you must be a registered user and logged in to be able to see images in these forums).

Most of the set up of the routers is very basic and you will be able to easily follow the diagram. Set up your Modem Router with the IP Address 192.168.1.1 and Subnet Mask 255.255.0.0.

Now, the tricky part is getting the Lounge Room router and the Study Room router to talk to one another. The basic steps are as follows...

Lounge Room router
Set up the local IP 192.168.2.1, Subnet Mask 255.255.0.0, the Gateway is your Modem Router's IP which is 192.168.1.1, and the DNS address will be also be 192.168.1.1. Find the options for DHCP settings, and choose to make this router a DHCP Forwarder and the IP Address of the DHCP server is 192.168.1.1. Save your settings.

Now you need to go to the Wireless tab, then on the Basic Settings sub-tab you need to select "AP" for its Wireless Mode. Also, set a Wireless Network Name (SSID) that is simple, e.g. Lounge. Save your settings. Next, you can click on the Wireless Security sub-tab and set up your security. Save your settings first. After the save, you can then Apply Settings and the router will reboot automatically.

Study Room router
Set up the local IP 192.168.3.1, Subnet Mask 255.255.0.0, the Gateway is your Lounge Room Router's IP which is 192.168.2.1 and the DNS server is your Modem Router's address which is 192.168.1.1. You will notice that there is an option for DHCP which we will ignore because this option will disappear when we set up the wireless in the next section. Save your settings.

Click on the Wireless tab, then on the Basic Settings sub-tab you need to select "Client Bridge (Routed)" for its Wireless Mode. Save your settings. You will now see that you have some new options to fill in on the page. For the Default GW Mode, select Manual. Then, for your Gateway enter the IP Address of the Lounge router, e.g. 192.168.2.1 Now, your Wireless Network Name (SSID) must be identical to the name given to your lounge room router, e.g. Lounge. Save your settings again- DO NOT APPLY SETTINGS YET. Next, you can click on the Wireless Security sub-tab and set up your security to be identical (including password) to the lounge room router. Save your settings first. After the save, you can then Apply Settings and the router will reboot automatically.

The Final Step - Reboot the whole Network
The final step to get everything talking correctly to one another is to reboot the whole network.

Turn off all of your routers (your attached devices should also be switched off to ensure correct IP assignments are made).

Switch ON the LAST router; in my case, it is the Study Room router. But do not turn any attached devices on.

Wait 30 seconds to 60 seconds.

Switch the next router in line ON (2nd last router); in my case it is the Lounge Room router.

Wait 30 seconds to 60 seconds.

Switch the next router ON (my first router); in my case it is the Modem Router.

Wait 30 seconds to 60 seconds.

Now you can switch any or all of your network attached devices in no particular order.

Testing the Network
Jump onto the Internet from any device that is connected to any of the routers, or log into any of the routers using their IP address.

Enjoy!


I am actually a bit confused by your configuration. Your network's address space is flat (every device is in the same subnet: 192.168.0.0/16). Yet it seems like you still have the DIR-632a's routing traffic. Why did you select a /16 address space for a home network that will support less than 254 devices?

I have two suggestions:
1. If you like having a flat network, that's fine, but consider the way your connections are made (as it is very unclear from your diagram/description). To create a flat network, you should not use the WAN port at all (or you should assign it to the LAN in software - not sure if that feature is functioning in this build though). In the context of a flat network, your current address scheme is strange. The address 192.168.2.1 comes after 192.168.1.255, which is way out there in your total address space. It makes more sense to set your routers sequentially in a flat network (although, technically speaking, it doesn't matter at all). The addresses you chose make more sense in the routed configuration.
2. Routed networks have advantages over flat networks. Broadcasts are limited to their locale, and it helps to reduce the propagation of unnecessary traffic. In order to set this up, you would give each router it's own subnet and set static routes between them. This configuration is more complicated than a flat network so I will leave it at this unless you are interested in actually setting it up.

Lastly, and possibly the most important since it is an indicator of whether or not your configuration is correct, the gateway on the study room router should NOT be the lounge router. The gateway for every device in a flat network should be the same if the traffic will all eventually go out the same path. If setting the gateway on the study to be 192.168.1.1 (the modem router) does not work, that means you have an error in your configuration. Since the modem router, and the study router are both in the same subnet (192.168.0.0/16), there should not be a gateway between them.
monkUsa
DD-WRT Novice


Joined: 18 Jun 2012
Posts: 6

PostPosted: Fri Jun 22, 2012 3:29    Post subject: Reply with quote
Hello adayforgotten

I am thinking that our discussion may need to be moved to a different area... but until a moderator instructs it, we'll keep it going here because it involves DD-WRT and the D-Link DIR-632 routers.

Your network's address space is flat (every device is in the same subnet: 192.168.0.0/16). Yet it seems like you still have the DIR-632a's routing traffic. Why did you select a /16 address space for a home network that will support less than 254 devices?
I used a Subnet Calculator (http://www.subnetmask.info/). According to the calculated result of using a Subnet of 255.255.0.0, I am able to set the IP range from 192.168.0.0 through to 192.168.255.255 on my network. Also, reading information from various sources suggested that having the same Subnet will allow me to see and share devices from anywhere in the network.

If I was to use a Subnet of 255.255.255.0 then I would be limited to 254 devices (192.168.1.1 IP range only).

Also, from what I could understand, I must assign a different IP to each router. That is why I used 192.168.1.1 for the Modem Router, 192.168.2.1 for the Lounge router and 192.168.3.1 for the Study router. Then, by using the Subnet of 255.255.0.0 I am able to share all connected devices.

I could have used a Subnet of 255.255.252.0 but the Billion Modem Router would not allow it.

"To create a flat network, you should not use the WAN port at all"
I have disabled the WAN ports on both DIR-632's using the DD-WRT GUI interface for the routers. The WAN ports are not being used at all.

"The addresses you chose make more sense in the routed configuration."
I am a novice at networking. I followed several guides on how to make my devices (such as my printer, shared drives, media centre, etc.) see each other even though they were on different routers.

Also, I needed each device to be able to get on the Internet.

"Routed networks have advantages over flat networks. Broadcasts are limited to their locale, and it helps to reduce the propagation of unnecessary traffic."
Yes, this makes sense.

"In order to set this up, you would give each router it's own subnet and set static routes between them."
The problem I have with using a different Subnet for each router is that the attached devices cannot be accessed from an external router. For example; if I have my Western Digital Media Centre on LOUNGE router, and my Laptop on STUDY router I am unable to access it to upload or download, stream etc when the routers have a different Subnet.

The moment I have the same Subnet I am then able to access the media centre.

"I will leave it at this unless you are interested in actually setting it up."
I would be interested in reducing unnecessary network traffic because I can see the lights going crazy, flashing all the time. Hopefully, there is a solution that will work the way you say and I can utilise all of my devices from anywhere within the network.

"possibly the most important since it is an indicator of whether or not your configuration is correct, the gateway on the study room router should NOT be the lounge router. The gateway for every device in a flat network should be the same if the traffic will all eventually go out the same path."
I have set up the LOUNGE router as a DHCP Forwarder. I assumed that since it is forwarding the DHCP address then any router that connects to it will see it as a Gateway.

"If setting the gateway on the study to be 192.168.1.1 (the modem router) does not work, that means you have an error in your configuration."
I have not tried this at all. I'll give it a try over the weekend.

"Since the modem router, and the study router are both in the same subnet (192.168.0.0/16), there should not be a gateway between them."
I am not entirely clear with what you are saying here. If you have time, could you propose a general set up that I could utilise taking into consideration the following requirements.

Modem Router
- Connects to the Internet
- Has 4x Ethernet ports
- 1x of the Ethernet ports is directly connected to the LOUNGE router

LOUNGE router
- Is connected directly to the Modem Router from LAN port (not WAN)
- Wireless Radio is ON so I can connect laptops and other mobile devices to it

STUDY router
- Is too far away from Modem Router and LOUNGE router so it needs to connect wirelessly to LOUNGE router.

Global requirements
- Any and all devices need to be accessible regardless of where in the network a user connects.
-eg. If I have a network printer attached to STUDY router, I need to be able to print to it from a PC connected to the Modem Router.

That said, everything works correctly with the current set up, but as you pointed out there is a lot of network traffic - and there is probably a significant amount that is uneccessary!

Thanks for looking into it for me, and hopefully I can fine tune it with your help.[/url]
SaintPeter
DD-WRT Novice


Joined: 22 Jun 2012
Posts: 2

PostPosted: Fri Jun 22, 2012 4:31    Post subject: Can't Make WAN port work Reply with quote
I just bought a DIR-632. First thing I did was install dd-wrt 18777, as per the instructions in the wiki.

Now I can't seem to get the WAN port to work . . or at least I can't get it to talk to my cable modem. I have an old Linksys router which picks it up via DHCP pretty much immediately.

Do I need to do anything special in the stock dd-wrt settings to make the WAN port work properly? Is there some way I can validate if it is even being seen by dd-wrt?

Everything else seems to be working - DHCP, etc. Just can't get it to talk to the cable modem.

Edited to Add:
I tried downgrading to the stock firmware (downloaded from the D-link site) but get a message "Upgrade Failed".
monkUsa
DD-WRT Novice


Joined: 18 Jun 2012
Posts: 6

PostPosted: Fri Jun 22, 2012 13:09    Post subject: Re: Can't Make WAN port work Reply with quote
SaintPeter wrote:
...I can't seem to get the WAN port to work . . or at least I can't get it to talk to my cable modem.

Do I need to do anything special in the stock dd-wrt settings to make the WAN port work properly?


I won't claim to be an expert; here is what I suggest, based on my experience over the past few days using DD-WRT on my DIR-632.

(1) Hard reset the router back to DD-WRT defaults by pressing the RESET button for 5 to 7 seconds. The power light will blink etc. and the router will be back to default.

(2) Log into the router on 192.168.1.1 and create the username and password for a first time log in.

(3) Set the DIR-632 up the way you think it should work for you.

(4) At every page, make sure you save your settings, but do not APPLY SETTINGS.

(5) Once you have made all the necessary changes and saved them as you go, you can then Apply Settings.

(6) While the DIR-632 is rebooting, now would be a good time to power cycle all of the devices that you have attached to it.

(7) I also advise that while or after the router reboots, you should also power cycle your MODEM ROUTER.

I have found that when things don't seem to work, even though they logically should, a power cycle of all the devices (resetting your network) can sometimes solve the problem.

If the above advice does not work, then see the image below. This is how I have one of my DD-WRT flashed DIR-632 connected to my Modem Router.

I am not using the WAN port at all for any connections. Everything is through the Ethernet ports.

Also, you will see that I have DHCP set as a DHCP Forwarder; I suggest that you let your Modem Router do the DHCP assignments; that is, disable DHCP on the DIR-632.

Set yours up in a similar way to see how you go; remember to power cycle at the end.

Sorry, I could not be of more help.
adayforgotten
DD-WRT Novice


Joined: 16 Dec 2010
Posts: 10

PostPosted: Fri Jun 22, 2012 21:48    Post subject: Network Setup Reply with quote
monkUsa wrote:
Hello adayforgotten

I am thinking that our discussion may need to be moved to a different area... but until a moderator instructs it, we'll keep it going here because it involves DD-WRT and the D-Link DIR-632 routers.

Agreed, this is more of a general networking query. I think it is okay to deviate for a few posts though so I will continue here until instructed otherwise. I would argue that it is relevant on the basis of testing advanced features. If you try to do this, your results will shed light on possible issues that no one else has run into yet simply because no one else has tried to use these functions.
monkUsa wrote:

Your network's address space is flat (every device is in the same subnet: 192.168.0.0/16). Yet it seems like you still have the DIR-632a's routing traffic. Why did you select a /16 address space for a home network that will support less than 254 devices?
I used a Subnet Calculator (http://www.subnetmask.info/). According to the calculated result of using a Subnet of 255.255.0.0, I am able to set the IP range from 192.168.0.0 through to 192.168.255.255 on my network. Also, reading information from various sources suggested that having the same Subnet will allow me to see and share devices from anywhere in the network.

If I was to use a Subnet of 255.255.255.0 then I would be limited to 254 devices (192.168.1.1 IP range only).

Sounds like you very intentionally are using the flat network as that is the simplest way to get everyone to talk to everyone happily. With a routed configuration, you could have three(3) subnets (192.168.1.0/24, 192.168.2.0/24, 192.168.3.0/24) each supporting 253 devices. With static routes defined, anyone on any of the subnets would be able to communicate with anyone else on the same or another subnet. The one caveat here is that broadcasts are not passed between subnets. This is the idea as it limits broadcast traffic from consuming network resources beyond its local subnet. This could cause problems depending on the way your Western Digital Media Center is accessing data. If it relies on broadcasts, it will not work. If you can manually specify network locations, it will work (somewhat generalized).
monkUsa wrote:

Also, from what I could understand, I must assign a different IP to each router. That is why I used 192.168.1.1 for the Modem Router, 192.168.2.1 for the Lounge router and 192.168.3.1 for the Study router. Then, by using the Subnet of 255.255.0.0 I am able to share all connected devices.

I could have used a Subnet of 255.255.252.0 but the Billion Modem Router would not allow it.

You are correct, every networked device must have unique IP address in order to communicate without error. Mainly, what I was getting at here is that the distance from the address 192.168.1.1 and 192.168.2.1 is an arbitrary number that doesn't actually mean anything in a /16 subnet (255.255.0.0 = /16). It makes more logical sense to number them sequentially since they are in the same subnet.

For example:
Modem Router - 192.168.1.1
Lounge Router - 192.168.1.2
Study Router - 192.168.1.3
DHCP would be disabled/set as a forwarder for the latter two and the gateway should be 192.168.1.1 for all devices on the network.
monkUsa wrote:

"To create a flat network, you should not use the WAN port at all"
I have disabled the WAN ports on both DIR-632's using the DD-WRT GUI interface for the routers. The WAN ports are not being used at all.

Perfect. For a flat network, this is correct. It makes your DIR-632a act as a layer-2 switch instead of a layer-3 router since it doesn't do any routing.
monkUsa wrote:

"The addresses you chose make more sense in the routed configuration."
I am a novice at networking. I followed several guides on how to make my devices (such as my printer, shared drives, media centre, etc.) see each other even though they were on different routers.

This goes with what I said a few lines up. Incrementing the third octet (192.168.XXX.1) doesn't make sense in a flat /16 subnet. It would make sense if you were creating three(3) separate subnets with the DIR-632a's performing layer-3 routing between them.
monkUsa wrote:

Also, I needed each device to be able to get on the Internet.

Essentially, as long as a device can get to your Modem Router at 192.168.1.1, it will have Internet access. In a flat network, that is pretty easy. For the routed variant, you have to set up routes between the subnets. For example, in order for the traffic connected to your Study Router to get to the Internet, your Study Router needs to know how to get to the Modem Router's subnet, AND traffic in the Modem Router's subnet needs to know how to get to the Study Router's subnet. This means you would need a static route on each router that points to the other subnet. Does this make sense?
monkUsa wrote:

"In order to set this up, you would give each router it's own subnet and set static routes between them."
The problem I have with using a different Subnet for each router is that the attached devices cannot be accessed from an external router. For example; if I have my Western Digital Media Centre on LOUNGE router, and my Laptop on STUDY router I am unable to access it to upload or download, stream etc when the routers have a different Subnet.

If you set the routes like I was glossing over in the paragraph above, then your subnets will be able to communicate with each other. Only the broadcast traffic will be blocked.
monkUsa wrote:

The moment I have the same Subnet I am then able to access the media centre.

This can mean a number of things. You never set up static routes correct? Without the routes, your subnets are isolated from each other, and likely the Internet since the two(2) subnets beyond your Modem Router don't know how to get to the Modem Router. If they can get to the Internet, it is due to the DIR-632a being in "gateway mode" which is the default and this enables a feature called "Network Address Translation" which can really throw a wrench in things if you don't understand what it's doing to your network traffic. For your use, whether a flat, or subnetted network, I would recommend setting it to "Router" on the "Setup -> Advanced Routing" page. This is also the page where you would set your static routes.
monkUsa wrote:

"possibly the most important since it is an indicator of whether or not your configuration is correct, the gateway on the study room router should NOT be the lounge router. The gateway for every device in a flat network should be the same if the traffic will all eventually go out the same path."
I have set up the LOUNGE router as a DHCP Forwarder. I assumed that since it is forwarding the DHCP address then any router that connects to it will see it as a Gateway.
"Since the modem router, and the study router are both in the same subnet (192.168.0.0/16), there should not be a gateway between them."
I am not entirely clear with what you are saying here. If you have time, could you propose a general set up that I could utilise taking into consideration the following requirements.

On a flat network with only one connection to other subnets/the Internet, there is only one gateway. The purpose of a gateway in networking is to pass traffic to a different subnet/network. Since the Study Router, and the Modem Router are on the same subnet, there is no gateway between them. Think of gateways as the gateway to the outside world of other subnets.
monkUsa wrote:

"If setting the gateway on the study to be 192.168.1.1 (the modem router) does not work, that means you have an error in your configuration."
I have not tried this at all. I'll give it a try over the weekend.

Let me know how it goes. Based on what you have told me so far, I think you will be fine as your network is flat and your WAN ports are disabled.

monkUsa wrote:

Modem Router
- Connects to the Internet
- Has 4x Ethernet ports
- 1x of the Ethernet ports is directly connected to the LOUNGE router

LOUNGE router
- Is connected directly to the Modem Router from LAN port (not WAN)
- Wireless Radio is ON so I can connect laptops and other mobile devices to it

STUDY router
- Is too far away from Modem Router and LOUNGE router so it needs to connect wirelessly to LOUNGE router.

Global requirements
- Any and all devices need to be accessible regardless of where in the network a user connects.
-eg. If I have a network printer attached to STUDY router, I need to be able to print to it from a PC connected to the Modem Router.

That said, everything works correctly with the current set up, but as you pointed out there is a lot of network traffic - and there is probably a significant amount that is uneccessary!

Thanks for looking into it for me, and hopefully I can fine tune it with your help.

Your flat network design is mostly correct aside from the small technicalities I've pointed out above, so you could continue using it in this fashion without much issue other than somewhat degraded performance. This degradation will be most noticeable for the Study Router connected devices especially when there are other wireless clients connected. The wireless interface is much more susceptible to getting bogged down as only one client can talk at a time (generally speaking).
monkUsa wrote:

"I will leave it at this unless you are interested in actually setting it up."
I would be interested in reducing unnecessary network traffic because I can see the lights going crazy, flashing all the time. Hopefully, there is a solution that will work the way you say and I can utilise all of my devices from anywhere within the network.

Before you get started, back up all your configurations. Things go wrong, and sometimes even when you are doing everything right. This is especially true in the case of firmware builds that are not final yet. Some of the functionality may not work as expected on your DIR-632a as a result of the software still being in development. That being said, I don't want you to point at me if things break, so please have a recovery plan to get back to the status quo.

To switch to a routed configuration, you need to make the following changes:

Modem Router
- Change the subnet mask to 255.255.255.0 (/24)
- Add static routes to the other subnets (192.168.2.0/24 and 192.168.3.0/24). I will need screen shots from your Modem Router's config page if you want detailed instruction.

Lounge Router
- Connect the uplink to the Modem Router to the WAN port
- Leave the IP address set to 192.168.2.1 for the local network
- Set the Gateway to 0.0.0.0 for the local network
- Set the WAN connection type to "Static IP"
- Set the WAN IP address to 192.168.1.2
- Set the WAN gateway to 192.168.1.1
- Enable the DHCP and have it start at the default of .100
- Go to the "Advanced Routing" page and set the "Operating Mode" to "Router"
- You shouldn't need to add a static route for the 192.168.1.0/24 subnet since it is directly connected to the WAN port
- Add a static route to the 192.168.3.0/24 network since it is "hidden behind" the Study Router and you have to tell the Lounge Router it exists and how to get there:
- Route Name: Arbitrary, I would name it something like "Study Network"
- Metric: 2
- Destination LAN Net: 192.168.3.0
- Subnet Mask: 255.255.255.0
- Gateway: 192.168.2.2
- Interface: LAN & WLAN

Study Router
- Set the wireless mode to "Client"
- This setting detaches the WLAN from the LAN and makes it the WAN connection.
- This is a setting that may not work with this build as it is still beta.
- Leave the IP address set to 192.168.3.1 for the local network
- Set the Gateway to 0.0.0.0 for the local network
- Set the WAN connection type to "Static IP"
- Set the WAN IP address to 192.168.2.2
- Set the WAN gateway to 192.168.2.1
- Enable the DHCP and have it start at the default of .100
- Go to the "Advanced Routing" page and set the "Operating Mode" to "Router"
- You shouldn't need to add a static route for the 192.168.2.0/24 subnet since it is directly connected to the WAN port
- Add a static route to the 192.168.1.0/24 network since it is "hidden behind" the Lounge Router and you have to tell the Study Router it exists and how to get there:
- Route Name: Arbitrary, I would name it something like "Modem Router Network"
- Metric: 2
- Destination LAN Net: 192.168.1.0
- Subnet Mask: 255.255.255.0
- Gateway: 192.168.2.1
- Interface: WAN (It is also likely that this setting is broken in this build as I have had issues with it in the past)

That should do it. I would recommend a full reboot of everything after setting this up. Make sure the settings all stuck, and report back with results. Since you are making minimal to no changes on the Modem Router itself, you can feel safe that the Internet will be available to devices directly connected to the Modem Router. Good luck.
Goto page Previous  1, 2, 3 ... 15, 16, 17 ... 27, 28, 29  Next Display posts from previous:    Page 16 of 29
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum