[NEW FRACTAL BUILD] 10-31-2012 r20202

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page Previous  1, 2, 3, 4  Next
Author Message
Bird333
DD-WRT Guru


Joined: 07 Jun 2006
Posts: 809

PostPosted: Mon Nov 05, 2012 12:05    Post subject: Reply with quote
Fractal any thoughts?
Sponsor
slobodan
DD-WRT Guru


Joined: 03 Nov 2011
Posts: 1463
Location: Zwolle

PostPosted: Mon Nov 05, 2012 20:26    Post subject: Reply with quote
Überkinger wrote:
If i switch to tomato-E4200USB-NVRAM60K-1.28.0500.5MIPSR2Toastman-RT-N, i have full 100Mbit in Download. Why?

See my download meter below? It is obtained with an E3000 (RAM and CPU are quite similar to an E4200) running a Kong build and having these tweaks in the startup script:
Code:
echo 262144 > /proc/sys/net/core/rmem_max
echo 262144 > /proc/sys/net/core/wmem_max
echo "4096 16384 262144" > /proc/sys/net/ipv4/tcp_wmem
echo "4096 87380 262144" > /proc/sys/net/ipv4/tcp_rmem
echo 1000 > /proc/sys/net/core/netdev_max_backlog

_________________
2times RT-AC56U running 33345 with entware-ng, Yamon 3 (SFE disabled).

Asus RT-N16 running Merlin LTS fork RT-N16_3.0.0.4_374.43_2-25E8j9527.trx with entware-ng.

2 times Asus RT-N16 running dd-wrt.v24-33215_NEWD-2_K3.x_big.bin with entware-ng

E4200 V1 running dd-wrt.v24-33215_NEWD-2_K3.x_mega-e3000.bin

3 times Linksys WRT610N V2 converted to E3000 and 1 original E3000 running dd-wrt.v24-33215_NEWD-2_K3.x_mega-e3000.bin (bridged with LAN cable)


Fractal
DD-WRT Guru


Joined: 19 Apr 2010
Posts: 1241

PostPosted: Mon Nov 05, 2012 23:42    Post subject: Reply with quote
I am getting similar results as well, over 100mb/s on my wan port.. Only change I did was change tcp congestion control to westwood.

-Fractal
snooze7555
Donator


Joined: 08 Jun 2006
Posts: 256
Location: Netherlands, Hengelo ov

PostPosted: Tue Nov 06, 2012 6:30    Post subject: Reply with quote
Hello Fractal,

WDS connection lost after a while. I have a e3000 connected to two e2000, with WDS. First huge pings and then after a while the connection lost. When i go to the WDS connection Tab and push first save and then save settings, then the connection is comming up. I don't have this with build
16785.

Is there something changed with WDS.

Smile Smile

Thanks defs

_________________

1 E3000 AND 1 E2000 WPA2 AES
DD-WRT v3.0-r31277
cullons
DD-WRT Novice


Joined: 12 Oct 2011
Posts: 24

PostPosted: Tue Nov 06, 2012 11:50    Post subject: Reply with quote
Working pefect e4200 v1)

Thanks.
Fractal
DD-WRT Guru


Joined: 19 Apr 2010
Posts: 1241

PostPosted: Tue Nov 06, 2012 17:08    Post subject: Reply with quote
The reason I recommended westwood in tcp congestion control as I have done extensive research on this. And there is a huge topic of it discussed in numerous places... However TCP Reno/Vegas have no effect on routed traffic to/from router only passthrough.... However TCP CUBIC and WESTWOOD do at the kernel level... I would welcome anyone's findings, including stability and throughput.

-Fractal
slobodan
DD-WRT Guru


Joined: 03 Nov 2011
Posts: 1463
Location: Zwolle

PostPosted: Wed Nov 07, 2012 0:02    Post subject: Reply with quote
cullons wrote:
Working pefect e4200 v1)

Including OTRW?

_________________
2times RT-AC56U running 33345 with entware-ng, Yamon 3 (SFE disabled).

Asus RT-N16 running Merlin LTS fork RT-N16_3.0.0.4_374.43_2-25E8j9527.trx with entware-ng.

2 times Asus RT-N16 running dd-wrt.v24-33215_NEWD-2_K3.x_big.bin with entware-ng

E4200 V1 running dd-wrt.v24-33215_NEWD-2_K3.x_mega-e3000.bin

3 times Linksys WRT610N V2 converted to E3000 and 1 original E3000 running dd-wrt.v24-33215_NEWD-2_K3.x_mega-e3000.bin (bridged with LAN cable)


Mangix
DD-WRT User


Joined: 04 Aug 2011
Posts: 372

PostPosted: Wed Nov 07, 2012 4:57    Post subject: Reply with quote
Fractal wrote:
The reason I recommended westwood in tcp congestion control as I have done extensive research on this. And there is a huge topic of it discussed in numerous places... However TCP Reno/Vegas have no effect on routed traffic to/from router only passthrough.... However TCP CUBIC and WESTWOOD do at the kernel level... I would welcome anyone's findings, including stability and throughput.

-Fractal


My findings mirror yours. No effect from Reno and Vegas but definitely an effect from CUBIC and Westwood.

Last I used CUBIC was when I had a PPPoE DSL connection. It gave me weird latency and YouTube buffering issues but was otherwise fast. Westwood seems to work better for WiFi connections and similar if not better to Reno/Vegas on wired connections.

As an aside, I really made a mess on the LI forums about this...
Fractal
DD-WRT Guru


Joined: 19 Apr 2010
Posts: 1241

PostPosted: Wed Nov 07, 2012 5:49    Post subject: Reply with quote
I was posting to see if anyone noticed results with any changes... This has been debated for a long time. I am not pro one way or the other as which to use, however in my testing I have found that westwood gives better performance. I am mostly interested in reliability and throughput.

On a different note, I have been watching svn and it looks like 3.x kernel may be on the horizon for some new devices.

-Fractal
Mangix
DD-WRT User


Joined: 04 Aug 2011
Posts: 372

PostPosted: Wed Nov 07, 2012 8:51    Post subject: Reply with quote
by new devices do you mean broadcom based? atheros and i believe everything else has had 3.x builds for a while.
Bird333
DD-WRT Guru


Joined: 07 Jun 2006
Posts: 809

PostPosted: Thu Nov 08, 2012 1:26    Post subject: Reply with quote
Fractal have you looked into any of my issues?
snooze7555
Donator


Joined: 08 Jun 2006
Posts: 256
Location: Netherlands, Hengelo ov

PostPosted: Thu Nov 15, 2012 18:20    Post subject: Reply with quote
Hello Fractal

I have test the wds function for a while, there are some problems with this firmware. After a few hours the connection lost to the WDS Clients. I have to reboot the client to get the connection back. I went back to version 16785 and i had no disconnections anymore.
I resetted the firmware and tried it again with the fimware 20202 and the i get the disconnections back.

I use one router with 4 clients in WDS mode WPA 2 AES channel 1 and wireless mixed mode.

Confused Confused Confused


Wireless Mode
AP

Wireless Network Mode
Mixed


Wireless Channel
1 - 2.412
Channel Width
Auto 20 MHz

Wireless SSID Broadcast
Enable

Sensitivity Range (ACK Timing)
2000


Security Mode
WPA2 Personal

WPA Algorithms
AES

Key Renewal Interval (in seconds)
3600

_________________

1 E3000 AND 1 E2000 WPA2 AES
DD-WRT v3.0-r31277
SHoTTa35
DD-WRT User


Joined: 09 May 2011
Posts: 243

PostPosted: Fri Nov 16, 2012 1:26    Post subject: Reply with quote
Fractal wrote:
Überkinger wrote:
SHoTTa35 wrote:

Copying files from my network server to my laptop (download) maxes out at say 10MB/s but uploads can push 30MB/s. I've tried without security as well.

Switch to tomato-E4200USB-NVRAM60K-1.28.0500.5MIPSR2Toastman-RT-N

and instantly I can copy at 25-30MB/s from the server.


Same on my config with two e4200v1.
Primary e4200v1: Accespoint 5GHz/40MHz, Gateway
Secondory e4200v1: WLAN Bridge to Primary e4200
(afterburner / frameburst on or off, no significant difference)

I got only 66-75Mbit in Downstream (100/6 MBit Cable)

If i switch to tomato-E4200USB-NVRAM60K-1.28.0500.5MIPSR2Toastman-RT-N, i have full 100Mbit in Download. Why?


Try changing tcp congestion control to westwood, and do some speed tests... let me know if that changes anything?

in my tests over wifi:

Vegas= 65.25/35.5mb/s
Cubic= 73.12/38.0mb/s
Westwood 89.93/41.24mb/s

I ran 5 speed tests on each over wifi on a 100mb/s internet connection and took the average and displayed them here... Let me know if you find simular results.


Makes no difference and I tried every option there in that list.

From long ago I noticed that the 100MW power seemed to be too high (or it doesn't work) but lowering it to 30 or below seem to bump speeds to 15MB/s vs ~10MB/s.

Again, Laptop to server (upload) is always fast (even if still slower, get 20-22MB/s vs 27-30MB/s with other firmware). It shows a 450Mbps connection in either case, I just cant figure it out. Someone said before about CTF which could be it because the standard Linksys firmware has CTF also and I get full speeds there as well! Smile

My WAN connection is only 50Mbps (pushes to 60Mbps) so I can't really test out that part, works just fine there.



That's using Vegas.

Copying from LAN to LAN of-course is fast (800-900Mbps!) since that doesn't use the CPU or any "routing" - all switching.
snooze7555
Donator


Joined: 08 Jun 2006
Posts: 256
Location: Netherlands, Hengelo ov

PostPosted: Sat Nov 17, 2012 11:49    Post subject: Reply with quote
Hello Fractal,

I went back to firmware 16785 because the speed problems en de disconnecting from de WDS clients.

With the firmware 20202 i get max 78Mb download and with the old 16785 firmware my max from 120 Mb download.

I tested setting westwood end cubic both a low speed on de firmware 20202 and full speed on de firmware 16785.

My test is done with E2000 en E3000 routers see my signature.

I waiting for a new firmware to test.

Thanks defs.

Very Happy Very Happy

_________________

1 E3000 AND 1 E2000 WPA2 AES
DD-WRT v3.0-r31277
callous
DD-WRT Novice


Joined: 27 Jun 2008
Posts: 45

PostPosted: Sun Nov 18, 2012 22:52    Post subject: Reply with quote
Shibby and tvlz got 5ghz working for the E3200 for a test build of tomato.

Fractal, any chance you could add 5ghz support for the E3200? Very Happy

http://www.linksysinfo.org/index.php?threads/wl_high-module-finally-compiled.48626/
Goto page Previous  1, 2, 3, 4  Next Display posts from previous:    Page 3 of 4
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum