New build: DD-WRT v3.0 --- 28444 --- 2015/12/05

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Goto page Previous  1, 2, 3, 4, 5  Next
Author Message
vdmz
DD-WRT Novice


Joined: 28 Nov 2015
Posts: 13

PostPosted: Mon Dec 07, 2015 10:03    Post subject: Reply with quote
habeIchVergessen wrote:
hardware: wzr-hp-ag300h

back on 27745

to much trouble with serveral android apps.


Could you please describe them shortly? It will be usefull for the developers in future...

_________________
Archer C7 V2 DD-WRT
Sponsor
vdmz
DD-WRT Novice


Joined: 28 Nov 2015
Posts: 13

PostPosted: Mon Dec 07, 2015 10:22    Post subject: Reply with quote
Behavior: WAN LED is not blinking, it is always switched off.
_________________
Archer C7 V2 DD-WRT
habeIchVergessen
DD-WRT User


Joined: 04 May 2010
Posts: 374

PostPosted: Mon Dec 07, 2015 10:56    Post subject: Reply with quote
vdmz wrote:
habeIchVergessen wrote:
hardware: wzr-hp-ag300h

back on 27745

to much trouble with serveral android apps.


Could you please describe them shortly? It will be usefull for the developers in future...


i guess that developers doesn't read our comments. for months freeradius is broken on my unit.

but back to your question: network connections stalling.
laurentiu.tns
DD-WRT Novice


Joined: 27 Sep 2014
Posts: 39

PostPosted: Mon Dec 07, 2015 16:37    Post subject: Reply with quote
Router: WDR4300v1.7
Firmware: 28444
Kernel: Linux 3.10.93 #12892
Status: working
Reset: yes
Errors: 5ghz disappears after a while
samgu
DD-WRT User


Joined: 17 Jul 2011
Posts: 67

PostPosted: Tue Dec 08, 2015 0:49    Post subject: Reply with quote
samgu wrote:
Oliverda wrote:
samgu wrote:
Router: TL-WDR4300 V1
Firmware: DD-WRT v3.0-r28444 std (12/05/15)
Kernel: Linux 3.10.93 #12954
Status: OK
Reset: No
Errors: see below.

It might not be errors, so forgive me if I am writing something obvious. All 5GHz clients cannot connect on HT40 unless I use lower extension channel. It doesn't matter the channel; if I set the extension to upper, it only connects in HT20.


Try to leave the WMM Support option enabled. It crashes ath1 if it's in AP (or WDS AP) mode. Rolling Eyes


It is enabled. I tried other settings but it is still disappearing. I will go back to factory and try to install DD-WRT again.


I give up!!!! Freaking 5GHz is gone again. It is transmitting apparently, but any device in my home sees it. I stays up for about 40 minutes and then disappears. I will stay with DD-WRT because it improved a lot the 2.4Ghz network, but too bad 5Ghz is not working for me.
un1versal
DD-WRT User


Joined: 12 Jul 2015
Posts: 80

PostPosted: Tue Dec 08, 2015 23:38    Post subject: WZR-HP-G300NH Reply with quote
Router: Buffalo WZR-HP-G300NH
Firmware: v3.0-r28444
Kernel: Linux 3.10.93 #12866
Status: OK
Reset: 30/30/30
Errors: 2 known errors

issue 1) http://svn.dd-wrt.com/ticket/4742

Flashing from r28417 to r28444 via webupgrade using wzr-hp-g300nh-dd-wrt-webupgrade-MULTI causes the router to go on a continuous and endless reboot loop.

Steps from r28417 with nvram backup made.

    1) Reset router 30/30/30
    2) enter password
    3) upload r28444 wzr-hp-g300nh-dd-wrt-webupgrade-MULTI via webinterface
    4) Wait
    5) wait somemore
    6) Wait even somemore to ensure the gods of ddwrt are appeased


after 1 hour and fed up of watching while router rebooted a few dozen times with no end in sight.
finally fired up tftp and uploaded r28444 wzr-hp-g300nh-dd-wrt-webupgrade-MULTI.bin and waited around 15 minutes.

Confirmed nvram is still OK and restored nvram backup. Everything seems to work

issue 2)
Since this firmware boast a openssl upgrade I wanted to check, but apprently something is wrong with config file or something not familiar with these bits in ddwrt...

Code:

root@argh:~# openssl version -a
WARNING: can't open config file: /etc/ssl/openssl.cnf


Seems something wasnt done quite right with this ssl upgrade.

_________________
Buffalo WZR-HP-G300NH - Firmware: DD-WRT v3.0-r29440 std (04/11/16)
_________________
Signature truncated: cannot exceed 20.000 lines!


Last edited by un1versal on Thu Dec 10, 2015 11:31; edited 1 time in total
bangirasu
DD-WRT Novice


Joined: 09 Dec 2015
Posts: 7

PostPosted: Wed Dec 09, 2015 0:39    Post subject: Reply with quote
Router: Buffalo WZR-HP-G300NH2
Firmware: DD-WRT v3.0-r28444 std (12/05/15)
Kernel: Linux 3.10.93 #12868 Sat Dec 5 03:06:14 CET 2015 mipsmips
Status: Not bricked (working wifi, usb, port forwarding, and ssh)
Reset: no
Errors: important problem with permissions! Read the following.

Code:

root@DD-WRT:/jffs# echo "echo hello" > test.sh
root@DD-WRT:/jffs# ls -al test.sh
-rw-r--r--    1 root     root            11 Dec  9 01:37 test.sh
root@DD-WRT:/jffs# ./test.sh
-sh: ./test.sh: Permission denied
root@DD-WRT:/jffs# chmod 777 test.sh
root@DD-WRT:/jffs# ./test.sh
-sh: ./test.sh: Permission denied
root@DD-WRT:/jffs# ls -al test.sh
-rwxrwxrwx    1 root     root            11 Dec  9 01:37 test.sh
un1versal
DD-WRT User


Joined: 12 Jul 2015
Posts: 80

PostPosted: Wed Dec 09, 2015 2:08    Post subject: WZR-HP-G300NH Reply with quote
bangirasu wrote:
Router: Buffalo WZR-HP-G300NH2
Firmware: DD-WRT v3.0-r28444 std (12/05/15)
Kernel: Linux 3.10.93 #12868 Sat Dec 5 03:06:14 CET 2015 mipsmips
Status: Not bricked (working wifi, usb, port forwarding, and ssh)
Reset: no
Errors: important problem with permissions! Read the following.

Code:

root@DD-WRT:/jffs# echo "echo hello" > test.sh
root@DD-WRT:/jffs# ls -al test.sh
-rw-r--r--    1 root     root            11 Dec  9 01:37 test.sh
root@DD-WRT:/jffs# ./test.sh
-sh: ./test.sh: Permission denied
root@DD-WRT:/jffs# chmod 777 test.sh
root@DD-WRT:/jffs# ./test.sh
-sh: ./test.sh: Permission denied
root@DD-WRT:/jffs# ls -al test.sh
-rwxrwxrwx    1 root     root            11 Dec  9 01:37 test.sh


I can confirm that on WZR-HP-G300NH, however running script with
Code:
sh ./text.sh
works, odd.
UberGeek451
DD-WRT Novice


Joined: 18 Apr 2015
Posts: 6

PostPosted: Wed Dec 09, 2015 6:23    Post subject: Eternal reboot problems Reply with quote
WNDR3700 V4
DD-WRT v3.0-r28444 std (12/05/15)
Linux 3.10.93 #12958 Sat Dec 5 05:14:54 CET 2015 mips
installed via GUI over 26587

Upgraded from r26587 to r28444 due to Samba-proFTPD boot/mount issues identical to bug #3871. After webflash, WNDR3700v4 entered a chronic reboot loop which have been irrecoverable so far.
Symptoms typically include successful reboots into GUI which remain stable, however, after applying configurations (NVRAM commits), device begins to boot-loop.
A series of downgrades failed to terminate the process, although OEM firmware appeared stable. Can not enable telnet, SSHd, or Syslogd without causing a reboot loop so can't post logs and therefore any suggestions would be helpful.
Not at all convinced this is a code issue but strongly suspect NVRAM is the source.
KrypteX
DD-WRT Guru


Joined: 18 Jan 2014
Posts: 2404

PostPosted: Wed Dec 09, 2015 6:45    Post subject: Reply with quote
For those having all kinds of strange issues, run the following commands from SSH or Telnet:
    erase nvram
    reboot

_________________
THERE ARE NO STRANGERS HERE; ONLY FRIENDS YOU HAVEN'T YET MET.
________________________________________________________________________________________________________
DD-WRT CHANGELOG | DEVICES | DD-WRT BUILDS | KONG BUILDS | UNOFFICIAL BUILDS | DD-WRT in VIRTUALBOX

Testing BrainSlayer's DD-WRT build 31924 on various units:
NETGEAR : WNDR3800 WNDR3800CH WNDRMACv2 WNDRMACv1 WNR2200 WNR2000v3
TP-LINK : ArcherC7v3 WR1043NDv3 WR740Nv4 WR740Nv6 WR710Nv1 WR810Nv1 WA850REv1 WA901NDv3 WA901NDv4
D-LINK : DIR-862L DIR-615D2
ASUS : RT-N10 C1
VirtualBox : x86_64
un1versal
DD-WRT User


Joined: 12 Jul 2015
Posts: 80

PostPosted: Wed Dec 09, 2015 7:22    Post subject: Reply with quote
KrypteX wrote:
For those having all kinds of strange issues, run the following commands from SSH or Telnet:
    erase nvram
    reboot


What kind of strange issues? whats the difference between that and 30/30/30
KrypteX
DD-WRT Guru


Joined: 18 Jan 2014
Posts: 2404

PostPosted: Wed Dec 09, 2015 7:32    Post subject: Reply with quote
un1versal wrote:
KrypteX wrote:
For those having all kinds of strange issues, run the following commands from SSH or Telnet:
    erase nvram
    reboot


What kind of strange issues? whats the difference between that and 30/30/30

What I know for sure is that erase nvram && reboot will erase nvram completely and it will be rebuilt from scratch after reboot.
OTOH, Restore Factory Defaults from WebGUI (and possibly 30/30/30 too - not sure about this one yet) will only reset certain nvram variables, but not all of them. I learned this the hard way, a while ago...

_________________
THERE ARE NO STRANGERS HERE; ONLY FRIENDS YOU HAVEN'T YET MET.
________________________________________________________________________________________________________
DD-WRT CHANGELOG | DEVICES | DD-WRT BUILDS | KONG BUILDS | UNOFFICIAL BUILDS | DD-WRT in VIRTUALBOX

Testing BrainSlayer's DD-WRT build 31924 on various units:
NETGEAR : WNDR3800 WNDR3800CH WNDRMACv2 WNDRMACv1 WNR2200 WNR2000v3
TP-LINK : ArcherC7v3 WR1043NDv3 WR740Nv4 WR740Nv6 WR710Nv1 WR810Nv1 WA850REv1 WA901NDv3 WA901NDv4
D-LINK : DIR-862L DIR-615D2
ASUS : RT-N10 C1
VirtualBox : x86_64
habeIchVergessen
DD-WRT User


Joined: 04 May 2010
Posts: 374

PostPosted: Wed Dec 09, 2015 8:30    Post subject: Reply with quote
you need a interpreter directive like this

echo -e "#! /bin/sh\necho hello" > test.sh
chmod u+x test.sh
./test.sh
redxii15
DD-WRT Novice


Joined: 25 May 2015
Posts: 16

PostPosted: Wed Dec 09, 2015 9:20    Post subject: Reply with quote
KrypteX wrote:
un1versal wrote:
KrypteX wrote:
For those having all kinds of strange issues, run the following commands from SSH or Telnet:
    erase nvram
    reboot


What kind of strange issues? whats the difference between that and 30/30/30

What I know for sure is that erase nvram && reboot will erase nvram completely and it will be rebuilt from scratch after reboot.
OTOH, Restore Factory Defaults from WebGUI (and possibly 30/30/30 too - not sure about this one yet) will only reset certain nvram variables, but not all of them. I learned this the hard way, a while ago...
I do 'erase nvram' on the current firmware, tell it to reset after flashing then do 'erase nvram' again after flashing.

I use mine as a client bridge (WZR-HP-G300NH2) and for some reason after a new firmware it would lose connection to the main AP on heavy usage like file transfers/streaming from a client on the main AP (the logs nor the GUI showed anything wrong or amiss, still showing connected to the main AP but no connectivity at all) only once requiring a reboot to fix it, and never ever happened again until I updated the firmware. It might be a coincidence but resetting like that since then has never again required this odd & annoying break-in procedure.
Freepix
DD-WRT Novice


Joined: 18 Apr 2013
Posts: 15

PostPosted: Wed Dec 09, 2015 10:27    Post subject: Reply with quote
Router: TP-Link WR841N V8
Firmware: upgrade from 27506 to DD-WRT v3.0-r28444 std
Kernel: Linux 3.10.93 #12952
Status: OK
Reset: No
Errors: None

Flashed using webgui/webflash, no reset done, no problems for 4 days, then the router bricked itself after a schedule reboot. I had to restore the stock firmware to make it work again.

Firmware 27506 was definitely more stable


Last edited by Freepix on Mon Dec 14, 2015 16:08; edited 2 times in total
Goto page Previous  1, 2, 3, 4, 5  Next Display posts from previous:    Page 3 of 5
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum