Wake on WAN over a DD-WRT Client Bridge?

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Author Message
Pizzimperfect
DD-WRT User


Joined: 13 Jun 2013
Posts: 56

PostPosted: Tue Oct 21, 2014 8:45    Post subject: Wake on WAN over a DD-WRT Client Bridge? Reply with quote
Hi all,

Hopefully someone here can shed some light on this issue as I was beating my head against the wall all evening last night with it!

Below is a (very scientific) diagram of my network at home.
Router 1 (connected to the modem) connected wirelessly to Router 2 which is running DD-WRT acting as a client bridge, hardwired to my PC in another room.

I'm trying to get my PC to wake from sleep to packets sent via the internet (Wake on WAN).

I have enabled the Wake on Lan settings in the PC BIOS. I've added an exception for UDP port 9 in windows firewall. I've port forwarded UDP port 9 on both routers to the PC internal static IP address, and i've been into my network adapters properties and enabled the required parts for WOL.

... PC just won't wake! Any ideas on where i've got wrong at all?

Thank you in advance! I'd love to get this working!

Sponsor
notorious.dds
DD-WRT User


Joined: 24 May 2012
Posts: 217
Location: Michigan

PostPosted: Wed Oct 22, 2014 3:26    Post subject: Reply with quote
Okay, I'm going to assume that your WOL works fine via intranet and fails via internet.

The WOL packet is a broadcast packet. (i.e. 192.168.1.255). The reason is that once a device goes into S3 or S4 sleep, it no longer has an IP address. So, a properly sent WOL packet goes out to everything on the network (i.e. "broadcast") and any device with the correct MAC address gets the packet.

That being the case, the main issue that you're probably having is that the broadcast packet will typically get blocked by your firewall. This is a good thing as it's not good practice to allow broadcast packets through the firewall.

So, I recommend remotely connecting to your router and having your router issue the WOL command. You can do this through the GUI or via telnet/SSH. If you use telnet or SSH, you can create a connection with your favorite client (PuTTY ?) and have the WOL command sent upon connection.

I've got my WOL via internet down to a simple double-click of the an ssh connection that automatically sends the WOL packet.

Try the GUI method first. Once successful, look into telnet/ssh to make things faster.
Pizzimperfect
DD-WRT User


Joined: 13 Jun 2013
Posts: 56

PostPosted: Wed Oct 22, 2014 6:00    Post subject: Reply with quote
Thank you for the reply!

I did wonder, if it's ever really a good idea to be leaving ports open on my router, for security reasons.

Would I still need to do this if using the gui method?

Would you recommend registering with a ddns service, as I believe my client bridge IP public IP will probably change?

Please correct me if I'm not thinking of this properly Smile

Your help is appreciated.

Thanks!
Pizzimperfect
DD-WRT User


Joined: 13 Jun 2013
Posts: 56

PostPosted: Wed Oct 22, 2014 12:00    Post subject: Reply with quote
I got this working through the GUI this morning, it was great!

However, I left the PC sleeping for an hour or so and now it won't wake...
I can still access the routers GUI over WAN, so I know there's no internet connection issue back home..

Odd how it was working, and now it isn't.
Any ideas?

Thanks,

Pete
notorious.dds
DD-WRT User


Joined: 24 May 2012
Posts: 217
Location: Michigan

PostPosted: Wed Oct 22, 2014 12:45    Post subject: Reply with quote
Quote:
Odd how it was working, and now it isn't.
Any ideas?

This is a pretty common WOL issue. Try googling sleep state defitions (i.e. S1 vs S2, S3, and S4). You'll get a better idea of why it wakes up after a short sleep and not always after a long sleep.

Typically, you'd issue the WOL command from your main router. Your setup suggests that the main one is not DD-WRT so I'm guessing you're doing it with the client bridge router, correct? I'm not sure if there's an issue with that approach, but it's a possible point of concern.

If you can get the computer to wake after a long sleep from within your LAN, then the problem lies in getting the proper WOL packet to your machine. If can't get it to wake from your LAN after a long sleep, you need to adjust the WOL settings on the computer itself.
Pizzimperfect
DD-WRT User


Joined: 13 Jun 2013
Posts: 56

PostPosted: Wed Oct 22, 2014 12:56    Post subject: Reply with quote
Thanks again.

Yeah, the problem is that my main router is in a different room, so can't be hardwired to my PC. Which is why I thought a client bridge setup would be a way around it.

I'll see if it wakes from the LAN when I get home.

Smile
ddaniel51
DD-WRT User


Joined: 19 Feb 2013
Posts: 282

PostPosted: Thu Oct 23, 2014 6:52    Post subject: Reply with quote
You may want to consider putting a wifi card in the computer, setting the computer to not remove power from the card and doing away with the bridge.
notorious.dds
DD-WRT User


Joined: 24 May 2012
Posts: 217
Location: Michigan

PostPosted: Fri Oct 24, 2014 1:03    Post subject: Reply with quote
ddaniel51 wrote:
You may want to consider putting a wifi card in the computer, setting the computer to not remove power from the card and doing away with the bridge.

I disagree. Keeping power to the NIC doesn't necessarily mean it'll keep itself connected to the network. In fact, it's very possible it will not stay connected if the rest of the computer is powered down. Using the client bridge seems more stable to me... although still not as good as a wire, obviously.
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum