DIR-615 C1 - revert r16454 to r16214 killed wireless

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Goto page 1, 2, 3  Next
Author Message
a1smith
DD-WRT Novice


Joined: 20 Mar 2011
Posts: 14

PostPosted: Sun Mar 20, 2011 7:39    Post subject: DIR-615 C1 - revert r16454 to r16214 killed wireless Reply with quote
DIR-615 C1 worked fine with r16214. I tried flashing to 16454 from firmware management page and it gave me an upgrade failed message. So, I went to the firmware flashing window you get with 30/30/30 reset. I flashed via IE8 to 16454 using factory to ddwrt file and it looks like flash takes, lights indicate reboot occurs, but then after reset the router won't respond to ping and no wireless signal detected by laptop. However, lights on front look like everything is OK (including wireless light is on.)

So, I revert to D-Link firmware ver 3.13NA to try flashing to 16454 from that. It works but I noticed that the wireless light is off on the front of the router and no wireless connections happen. Wireless options in the GUI pages are present and state that it is turned on.

I try flashing to 16454 with factory to ddwrt file again with same result as above (and wireless light is on.)

So, I flash back to the original 16214 and everything works EXCEPT wireless. Not only do I not have wireless connections but all of the screens in DD-WRT GUI for wireless have disappeared. It is as if the firmware now thinks that I have a wired router with no wireless capability.

I searched and didn't find anything regarding this problem. Does anyone have any ideas on how to restore wireless functionality?
Sponsor
Sash
DD-WRT Guru


Joined: 20 Sep 2006
Posts: 17473
Location: Hesse/Germany

PostPosted: Sun Mar 20, 2011 9:54    Post subject: Reply with quote
reset to defaults 1st
_________________
Forum Guidelines...How to get help
&
Forum Rules
&
RTFM/STFW
&
Throw some buzzwords into the WIKI search Exclamation
_________________
I'm NOT rude, just offer pure facts!
_________________
Atheros (TP-Link & Clones, etc ) debrick service in EU
_________________
Guide on HowTo be Safe, Secure and Protect Your Online Anonymity!
a1smith
DD-WRT Novice


Joined: 20 Mar 2011
Posts: 14

PostPosted: Sun Mar 20, 2011 13:55    Post subject: Reply with quote
Sorry, I should have mentioned that before. I reset the 16214 build to defaults before flashing. When I tried to flash to 16454 build from firmware flash window in dd-wrt I selected to reset to defaults (but upgrade failed.) When I flashed 3.13NA I reset to defaults to see if that would fix wireless not coming on, it didn't. And finally, when I flashed back to 16214 I did 30/30/30 reset which resets firmware to defaults and I also did it from within dd-wrt for good measure.

Are there any other ways that I can get a better reset to defaults? Maybe that clears some other area of nvram that might be causing a problem? On http://www.dd-wrt.com/wiki/index.php/Hard_reset_or_30/30/30 I read about using the commands 'erase nvram' and 'reboot' from SSH or telnet window. I have SSH set up and can try that but I'm hesitating to try this now because of the warnings listed about how on some routers it causes more problems than it fixes. Has anyone used those commands on a DIR-615 C1 successfully?
a1smith
DD-WRT Novice


Joined: 20 Mar 2011
Posts: 14

PostPosted: Sun Mar 20, 2011 14:13    Post subject: Reply with quote
I went ahead and tried the 'erase nvram' and 'reboot' commands from a telnet window. The 'erase nvram' command works fine on DIR-615 C1; it seems to just do the same procedure that restoring factory defaults does from dd-wrt GUI. However, it did not restore my wireless function. GUI still does not have any wireless functionality; all settings are gone, bandwidth plot for wireless gone, etc.

For good measure, I tried again to restore to defaults before flashing 16454 and I still get the 'Upgrade failed.' message.
a1smith
DD-WRT Novice


Joined: 20 Mar 2011
Posts: 14

PostPosted: Sun Mar 20, 2011 19:53    Post subject: Reply with quote
More info:

I tried flashing with the following firmwares to see if any would "wake up" the wireless capability; they are listed in order of flashing. Resetting to factory defaults was done before and after every flash.

dd-wrt b16212, dd-wrt b14896, D-Link 3.13NA, D-Link 3.12NA, D-Link 3.11NA, D-Link 3.10, then back to dd-wrt b16212. For all of the firmware everything works except the wireless.

With D-Link firmware the wireless options show up in the GUI but wireless doesn't work. Wireless is always enabled by default; all but one time I also saw wireless radio enabled in device info. One time it showed wireless radio off in device info (with it enabled); I went through wireless setup and then it showed enabled but still did not work.

With dd-wrt firmware all of the wireless options are gone in the GUI. No wireless setup, no wireless status, no wireless bandwidth. Even though the tab for it did not show up; I did try going to http://192.168.1.1/Status_Wireless.asp and here is what was shown:
    MAC Address (was correct)
    Radio Unknown
    Mode AP
    Network NG-Mixed
    SSID Newton
    Channel Unknown
    TX Power 4547928 dBm
    Rate Disabled
    ACK Timing0µs (0m)
    Encryption - Interface ath0 Enabled, WPA2 Personal
    PPTP Status Disconnected

It has my SSID because I restored the settings I had saved for this particular build. Shouldn't the settings restore also have reset the other settings?

Here is specific info for my router:
Model - DIR-615
Part # - BIR615ANA....C1
H/W Ver - C1
FCC ID - KA2DIR615C1
IC - 4216A-IR615

I opened the router and the two Atheros chips are AR9130-BC1E (CPU) and AR8216-BH1A (switch).

Does anyone have any suggestions on anything else to try to restore wireless capability? Maybe some Unix level commands? Or have I had a hardware failure of the wireless circuit after flash to b16454?
a1smith
DD-WRT Novice


Joined: 20 Mar 2011
Posts: 14

PostPosted: Sun Mar 20, 2011 20:11    Post subject: Reply with quote
Tried one more thing - I tried going to http://192.168.1.1/Wireless_Basic.asp but all I get is the three buttons at the bottom: Save, Apply Settings, and Cancel Changes. So, I can't try to set these values to something more reasonable like the 20 dBm I had for transmit power (default value).
tatsuya46
DD-WRT Guru


Joined: 03 Jan 2010
Posts: 1999
Location: Winnipeg, Canada

PostPosted: Sun Mar 20, 2011 23:59    Post subject: Reply with quote
16454 is too big for the DIR-615's flash space apparently.
_________________
[QUALCOMM ATHEROS] TP-LINK TL-WDR4900 v1.3 --> DD-WRT v24-sp2 (10/22/14) std - build 25139 (private test build)
[QUALCOMM ATHEROS] NETGEAR WNDR3700 v1 ----> DD-WRT v24-sp2 (10/22/14) std - build 25139 (private test build)
[QUALCOMM ATHEROS] D-Link DIR-825 B1 ----------> DD-WRT v24-sp2 (10/22/14) std - build 25139 (private test build)

LATEST FIRMWARE(S) --> ftp://ftp.dd-wrt.com/betas/

Qualcomm Atheros Wi-Fi Settings Wiki --> http://www.dd-wrt.com/wiki/index.php/QCA_wireless_settings

When im drunk im usually more helpful just saying..& also no im not japanese
BrainSlayer wrote:
we just do it since we do not like any restrictions enforced by stupid cocaine snorting managers
juandiablo
DD-WRT Novice


Joined: 24 Mar 2011
Posts: 1

PostPosted: Thu Mar 24, 2011 18:07    Post subject: same problem here Reply with quote
Just went trough a similar process and now the wireless radio is disabled on my DIR-615 C1. No matter what firmware I flash (dd-wrt/openwrt/DLink) the wireless radio shows no activity.

The wireless icon does briefly flash during startup but won't produce a signal.

Is it possible that the latest firmware has somehow cooked the wireless radio?
LOM
DD-WRT Guru


Joined: 28 Dec 2008
Posts: 7095

PostPosted: Fri Mar 25, 2011 5:30    Post subject: Re: same problem here Reply with quote
juandiablo wrote:


Is it possible that the latest firmware has somehow cooked the wireless radio?


Not cooked the radio but it has probably overwritten the board_config partition in flash which contains factory radio configuration. Radio won't work without that data.

_________________
I'm on a whiskey diet, lost 3 days already
FadeToBlack
DD-WRT Novice


Joined: 07 Apr 2007
Posts: 15
Location: Iasi, Romania

PostPosted: Fri Mar 25, 2011 13:26    Post subject: Reply with quote
Any solution to this problem?

I get this:

"Wireless Status
MAC Address

Radio
Unknown
Mode
AP
Network

SSID
dd-wrt
Channel
Unknown
TX Power
4547928 dBm
Rate
Disabled
ACK Timing
0µs (0m)
Encryption - Interface ath0
Disabled
PPTP Status
Disconnected
".
BlCa`
DD-WRT User


Joined: 16 Nov 2009
Posts: 135

PostPosted: Fri Mar 25, 2011 17:23    Post subject: Reply with quote
Well, you need someone with a working DIR-615 C1 to dump his caldata (aka board_config) partition then flash it on your own.

There are several problems though:

- The person with the working router must find where his/her partition is. It could be different depending on what firmware is currently installed on his/her unit. Assuming he/she's running dd-wrt, they can find out the correct partition from the kernel log and dump from /dev/mtdXro (where X is the partition number). For example, the output of my kernel log contains:

Quote:
[ 3.530000] 0x000000000000-0x000000070000 : "RedBoot"
[ 3.540000] 0x000000070000-0x000000800000 : "linux"
[ 3.540000] 0x000000170000-0x000000760000 : "rootfs"
[ 3.550000] mtd: partition "rootfs" set to be root filesystem
[ 3.550000] 0x000000760000-0x0000007e0000 : "ddwrt"
[ 3.560000] 0x0000007e0000-0x0000007f0000 : "nvram"
[ 3.570000] 0x0000007f0000-0x000000800000 : "FIS directory"
[ 3.570000] 0x0000007f0000-0x000000800000 : "board_config"
[ 3.580000] 0x000000000000-0x000000800000 : "fullflash"


There are 8 partition in total numbered from 0 to 7 (redboot is 0, fullflash is 7). Therefore "board_config" is partition 6 and can be dumped from /dev/mtd6ro

- The person with the working router must have access to command line tools like dd to create the dump.

- The person receiving the dump will get his wifi MAC address changed to that of the sender's. If you want your original MAC back, you'll have to hex edit the dump before flashing.

- The person with the dead router has to go through the same process to determine destination partition and also have access to command line and dd tool.
The destination partition is /dev/mtdX (without "ro" this time).

I'm assuming you've read and understood the manual of dd, you know that you can read the kernel from dmesg, and that you know how to use an hex editor (that step can be skipped though).
jeisom
DD-WRT Novice


Joined: 04 Jul 2008
Posts: 27

PostPosted: Sun Mar 27, 2011 2:51    Post subject: Reply with quote
Here is a board_config that has the mac addresses set to 00:00:00:00:00:00. they are at the end of the file in plain text. first one is your LAN/Wireless MAC, Second WAN MAC.
mikeman191
DD-WRT Novice


Joined: 27 Mar 2011
Posts: 2

PostPosted: Sun Mar 27, 2011 21:30    Post subject: Reply with quote
Experiencing an identical problem on a 615 C1 this morning. No wireless functionality under any firmware, including factory.

Can anyone post more specific instructions for fixing missing board_config information? I have a functioning telnet connection to the router with DD-WRT installed and logging enabled, but am not sure how to identify the right partition or how to dump the contents of the file.

Any help is greatly appreciated..!
jeisom
DD-WRT Novice


Joined: 04 Jul 2008
Posts: 27

PostPosted: Mon Mar 28, 2011 2:07    Post subject: Reply with quote
The attachment I added has no mac addresses and needs the hexedited in(see above post). I believe it has it printed on the bottom of the router. Haven't looked at mine in a while, Just use it.

1. Telnet in.
2. # dmesg|less
2a. look for RedBoot. Redboot=0 so board_config should = 6
[ 0.410000] Creating 8 MTD partitions on "ar7100-nor0":
[ 0.410000] 0x000000000000-0x000000030000 : "RedBoot"
[ 0.420000] 0x000000030000-0x0000003e0000 : "linux"
[ 0.430000] 0x0000000fe000-0x0000003b0000 : "rootfs"
[ 0.430000] mtd: partition "rootfs" must either start or end on erase block boundary or be smaller than an erase block -- forcin
g read-only
[ 0.440000] mtd: partition "rootfs" set to be root filesystem
[ 0.450000] 0x0000003b0000-0x0000003e0000 : "ddwrt"
[ 0.460000] 0x0000003e0000-0x0000003f0000 : "nvram"
[ 0.460000] 0x0000003f0000-0x000000400000 : "FIS directory"
[ 0.470000] 0x0000003f0000-0x000000400000 : "board_config"
[ 0.480000] 0x000000000000-0x000000400000 : "fullflash"

3a. to dump to file named "board_config"
# dd if=/dev/mtd6ro of=board_config
3b. to write file "board_config"
# dd if=board_config of=/dev/mtd6

there are at least a couple of ways to get board_config onto router, wget and scp, are the 2 I know.
wget will connect to a webserver and retrieve a file.
scp will use secure-shell to copy the file.
cmobass
DD-WRT Novice


Joined: 08 Oct 2007
Posts: 7

PostPosted: Mon Apr 04, 2011 0:08    Post subject: No wireless Reply with quote
I flashed my Dir 615 c1 to DD-WRT and lost wireless I see your instructions above and I am a little confused where do you place the board_config file once you SCP into the router? Do you just copy it over the dump that you created?
Goto page 1, 2, 3  Next Display posts from previous:    Page 1 of 3
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum