TL-WR740N no wan IP after reboot

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Goto page Previous  1, 2
Author Message
brainbone
DD-WRT User


Joined: 25 Jun 2008
Posts: 87

PostPosted: Tue Sep 20, 2011 15:31    Post subject: Reply with quote
Does your WAN MAC address change after reboot? I'm wondering if it's related to the same issue I'm having. See my post here.

Basically, with DD-WRT on my router, on reboot all interfaces on the router have the same MAC address, including WAN. After clicking "apply settings" on any configuration page, the WAN MAC address changes to what it was on boot +1.

If you have an ISP that only hands out a single IP address to a single MAC (sometime rebooting your modem, then your router, will allow you get a new IP address on a different MAC address, sometimes you need to call your ISP to report your new MAC address -- depends on the ISP.) the MAC address changing will cause you to lose your WAN IP.
Sponsor
Rayrox
DD-WRT Novice


Joined: 06 Oct 2011
Posts: 1

PostPosted: Thu Oct 06, 2011 14:06    Post subject: This worked for me !!! Reply with quote
Code:

sleep 30
stopservice wan
sleep 30
startservice wan


It does what it says:

Line 1) After reboot the execution will be delayed by 30 seconds allowing the router to completely restart

Line 2) will STOP WAN

Line 3) will wait again

Line 4) will START WAN

To fine tune the delays, you can ping any website via the terminal or cmd and get the timing adjusted (minimize delays) accordingly.

To restart the router whenever the connection (ping) fails:

Setup "WDS/Connection Watchdog" to ping any reliable ip (8.8.8.8 or 208.67.222.222), delay of 180-300 seconds works fine.

DD-WRT Rocks, Thanks
brainbone
DD-WRT User


Joined: 25 Jun 2008
Posts: 87

PostPosted: Thu Oct 06, 2011 15:47    Post subject: Reply with quote
I understand that there are work-around, but they should not be needed. It's a bug that should be fixed.
cityismine
DD-WRT Novice


Joined: 09 Feb 2007
Posts: 25

PostPosted: Wed Dec 14, 2011 5:12    Post subject: Reply with quote
Check:

Setup > Connection Type

I found mines was set to disabled when I flashed dd-wrt for the first time. I changed it to automatic configuration-dhcp and wan started working.
Goto page Previous  1, 2 Display posts from previous:    Page 2 of 2
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum