WR1043ND ---> K3765 WAN Connection

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Author Message
FireBloodPhoeniX
DD-WRT Novice


Joined: 15 Mar 2012
Posts: 3

PostPosted: Thu Mar 15, 2012 6:10    Post subject: WR1043ND ---> K3765 WAN Connection Reply with quote
Hello
Its my first time here ,First time using DD-WRD ,total noob in linex
im trying to get internet using my 3g with the router
But it seems im doomed to fail
--------------------------------------------------------------------------------

Router: WR1043ND v1.8 , 8MB Flash, 32MB RAM, Atheros AR9132@400MHz
3G device: HUAWEI K3765
DD-WRD ver: DD-WRD v24-SP2 (08/07/10) std
--------------------------------------------------------------------------------

I read that using putty on your 3g's com port an shwitshing to modem only mode will help
Thare is 3 ports witsh one?(Windows 7 32bit)

Vodafone mobile broudband moudem (HUAWEI)-COM13-->connects but cant type anything
Vodafone mobile broudband diagnostics port (HUAWEI)-COM12-->connects but cant type anything
Vodafone mobile broudband Secondery port moudem (HUAWEI)-COM14-->connects gives some info

using putty on COM14:(CAPS/NOCAPS)
AT^U2DIAG=0-->COMMAND NOT SUPPORT
at^setport="A1,A2;1,2,3,7"-->COMMAND NOT SUPPORT
--------------------------------------------------------------------------------

DSMSG:
<5>[ 0.000000] Linux version 2.6.34.9-svn17089 (root@dd-wrt) (gcc version 4.5.2 (Linaro GCC 4.5-2011.02-0) ) #6044 Tue Jun 14 12:34:17 CEST 2011
<4>[ 0.000000] flash_size passed from bootloader = 8
<6>[ 0.000000] bootconsole [early0] enabled
<6>[ 0.000000] CPU revision is: 00019374 (MIPS 24Kc)
<6>[ 0.000000] booting platform Atheros AR9132 rev 2 (0xb9)
<6>[ 0.000000] Determined physical RAM map:
<6>[ 0.000000] memory: 02000000 @ 00000000 (usable)
<4>[ 0.000000] Zone PFN ranges:
<4>[ 0.000000] Normal 0x00000000 -> 0x00002000
<4>[ 0.000000] Movable zone start PFN for each node
<4>[ 0.000000] early_node_map[1] active PFN ranges
<4>[ 0.000000] 0: 0x00000000 -> 0x00002000
<7>[ 0.000000] On node 0 totalpages: 8192
<7>[ 0.000000] free_area_init_node: node 0, pgdat 802511a0, node_mem_map 81000000
<7>[ 0.000000] Normal zone: 64 pages used for memmap
<7>[ 0.000000] Normal zone: 0 pages reserved
<7>[ 0.000000] Normal zone: 8128 pages, LIFO batch:0
<4>[ 0.000000] Built 1 zonelists in Zone order, mobility grouping on. Total pages: 8128
<5>[ 0.000000] Kernel command line: console=ttyS0,115200 root=1f02 rootfstype=squashfs noinitrd init=/sbin/init
<6>[ 0.000000] PID hash table entries: 128 (order: -3, 512 bytes)
<6>[ 0.000000] Dentry cache hash table entries: 4096 (order: 2, 16384 bytes)
<6>[ 0.000000] Inode-cache hash table entries: 2048 (order: 1, 8192 bytes)
<4>[ 0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
<4>[ 0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
<6>[ 0.000000] Writing ErrCtl register=00000000
<6>[ 0.000000] Readback ErrCtl register=00000000
<6>[ 0.000000] Memory: 29680k/32768k available (2007k kernel code, 3088k reserved, 358k data, 140k init, 0k highmem)
<6>[ 0.000000] NR_IRQS:128
<0>[ 0.000000] irq init done
<4>[ 0.000000] plat_time_init: plat time init done
<6>[ 0.000000] Calibrating delay loop... 266.24 BogoMIPS (lpj=1331200)
<4>[ 0.240000] Mount-cache hash table entries: 512
<6>[ 0.240000] NET: Registered protocol family 16
<4>[ 0.260000] bio: create slab at 0
<6>[ 0.260000] Switching to clocksource MIPS
<6>[ 0.270000] NET: Registered protocol family 2
<6>[ 0.270000] IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
<6>[ 0.280000] TCP established hash table entries: 1024 (order: 1, 8192 bytes)
<6>[ 0.290000] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
<6>[ 0.290000] TCP: Hash tables configured (established 1024 bind 1024)
<6>[ 0.300000] TCP reno registered
<6>[ 0.300000] UDP hash table entries: 256 (order: 0, 4096 bytes)
<6>[ 0.310000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
<6>[ 0.310000] NET: Registered protocol family 1
<5>[ 0.320000] gpio_proc: module loaded and /proc/gpio/ created
<5>[ 0.320000] wl0gpio_proc: module loaded and /proc/wl0gpio/ created
<4>[ 0.330000] AR7100 GPIOC major 0
<5>[ 0.330000] init_vdso successfull
<6>[ 0.340000] squashfs: version 3.0 (2006/03/15) Phillip Lougher
<6>[ 0.340000] msgmni has been set to 57
<6>[ 0.350000] io scheduler noop registered
<6>[ 0.350000] io scheduler deadline registered (default)
<6>[ 0.360000] Serial: 8250/16550 driver, 1 ports, IRQ sharing disabled
<6>[ 0.370000] serial8250.0: ttyS0 at MMIO 0x18020000 (irq = 19) is a 16550A
<6>[ 0.370000] console [ttyS0] enabled, bootconsole disabled
<0>[ 0.390000] guessed flashsize = 8M
<0>[ 0.390000] scanning for root partition
<0>[ 0.390000] tplink uboot detected
<0>[ 0.400000] bootloader size = 20000
<0>[ 0.400000]
<0>[ 0.400000] found squashfs at 160000
<5>[ 0.410000] Creating 8 MTD partitions on "ar7100-nor0":
<5>[ 0.410000] 0x000000000000-0x000000020000 : "RedBoot"
<5>[ 0.420000] 0x000000020000-0x0000007e0000 : "linux"
<5>[ 0.430000] 0x000000160000-0x0000007d0000 : "rootfs"
<5>[ 0.430000] mtd: partition "rootfs" set to be root filesystem
<5>[ 0.440000] 0x0000007d0000-0x0000007e0000 : "ddwrt"
<5>[ 0.440000] 0x0000007e0000-0x0000007f0000 : "nvram"
<5>[ 0.450000] 0x0000007f0000-0x000000800000 : "FIS directory"
<5>[ 0.460000] 0x0000007f0000-0x000000800000 : "board_config"
<5>[ 0.460000] 0x000000000000-0x000000800000 : "fullflash"
<6>[ 0.470000] PPP generic driver version 2.4.2
<6>[ 0.470000] PPP Deflate Compression module registered
<6>[ 0.480000] PPP BSD Compression module registered
<6>[ 0.480000] PPP MPPE Compression module registered
<6>[ 0.490000] NET: Registered protocol family 24
<6>[ 0.490000] PPPoL2TP kernel driver, V1.0
<6>[ 0.500000] IMQ driver loaded successfully.
<6>[ 0.500000] Hooking IMQ before NAT on PREROUTING.
<6>[ 0.510000] Hooking IMQ after NAT on POSTROUTING.
<6>[ 0.510000] tun: Universal TUN/TAP device driver, 1.6
<6>[ 0.520000] tun: (C) 1999-2004 Max Krasnyansky
<6>[ 0.520000] Software Watchdog Timer: 0.07 initialized. soft_noboot=0 soft_margin=60 sec (nowayout= 0)
<4>[ 0.530000] u32 classifier
<4>[ 0.540000] input device check on
<4>[ 0.540000] Actions configured
<4>[ 0.540000] Netfilter messages via NETLINK v0.30.
<4>[ 0.550000] nf_conntrack version 0.5.0 (463 buckets, 1852 max)
<4>[ 0.550000] CONFIG_NF_CT_ACCT is deprecated and will be removed soon. Please use
<4>[ 0.560000] nf_conntrack.acct=1 kernel parameter, acct=1 nf_conntrack module option or
<4>[ 0.570000] sysctl net.netfilter.nf_conntrack_acct=1 to enable it.
<4>[ 0.580000] nf_conntrack_rtsp v0.6.21 loading
<4>[ 0.580000] nf_nat_rtsp v0.6.21 loading
<6>[ 0.590000] ip_tables: (C) 2000-2006 Netfilter Core Team
<6>[ 0.590000] IPP2P v0.8.2 loading
<6>[ 0.590000] TCP westwood registered
<6>[ 0.600000] TCP hybla registered
<6>[ 0.600000] TCP vegas registered
<6>[ 0.600000] NET: Registered protocol family 17
<6>[ 0.610000] 802.1Q VLAN Support v1.8 Ben Greear
<6>[ 0.620000] All bugs added by David S. Miller
<4>[ 0.650000] VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
<6>[ 0.660000] Freeing unused kernel memory: 140k freed
<5>[ 2.830000] Realtek RTL8366RB ethernet switch driver version 0.2.2
<6>[ 2.840000] rtl8366rb rtl8366rb: using GPIO pins 18 (SDA) and 19 (SCK)
<6>[ 2.840000] rtl8366rb rtl8366rb: RTL5937 ver. 3 chip found
<6>[ 2.870000] rtl8366rb: probed
<4>[ 2.890000] ag7100_mod: module license 'unspecified' taints kernel.
<4>[ 2.890000] Disabling lock debugging due to kernel taint
<6>[ 2.910000] ag7100_mii: probed
<0>[ 2.910000] phymap is null
<6>[ 3.340000] usbcore: registered new interface driver usbfs
<6>[ 3.340000] usbcore: registered new interface driver hub
<6>[ 3.350000] usbcore: registered new device driver usb
<6>[ 3.440000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
<6>[ 3.470000] ar71xx-ehci ar71xx-ehci.0: Atheros AR91xx built-in EHCI controller
<6>[ 3.480000] ar71xx-ehci ar71xx-ehci.0: new USB bus registered, assigned bus number 1
<6>[ 3.520000] ar71xx-ehci ar71xx-ehci.0: irq 3, io mem 0x1b000000
<6>[ 3.540000] ar71xx-ehci ar71xx-ehci.0: USB 2.0 started, EHCI 1.00
<6>[ 3.540000] hub 1-0:1.0: USB hub found
<6>[ 3.550000] hub 1-0:1.0: 1 port detected
<5>[ 3.860000] SCSI subsystem initialized
<6>[ 4.000000] usb 1-1: new high speed USB device using ar71xx-ehci and address 2
<6>[ 4.210000] Initializing USB Mass Storage driver...
<6>[ 4.220000] usbcore: registered new interface driver usb-storage
<6>[ 4.220000] USB Mass Storage support registered.
<6>[ 4.270000] scsi0 : usb-storage 1-1:1.0
<4>[ 4.370000] Writing 4
<6>[ 4.670000] ath_mimo_hal: 0.9.17.1 (AR5416, REGOPS_FUNC)
<6>[ 5.130000] ath_ahb: 0.9.4.5 (Atheros/multi-bss)
<6>[ 5.130000] wlan: 0.8.4.2 (Atheros/multi-bss)
<6>[ 5.140000] wlan: mac acl policy registered
<6>[ 5.140000] ath_rate_atheros: Version 2.0.1
<6>[ 5.140000] Copyright (c) 2001-2004 Atheros Communications, Inc, All Rights Reserved
<4>[ 5.150000] IRQ 2/wifi%d: IRQF_DISABLED is not guaranteed on shared IRQs
<6>[ 5.380000] ar5416CheckEepromDef: Read Magic = 0xFFFF
<6>[ 5.390000] EEPROM being read from flash @0xbfff1000
<6>[ 5.390000] need_swap = False.
<6>[ 5.400000] Howl Revision ID 0xb9
<4>[ 5.400000] DFS min filter rssiThresh = 18
<4>[ 5.410000] DFS max pulse dur = 131 ticks
<4>[ 5.410000] 1Mbps 2Mbps 5.5Mbps 11Mbps
<4>[ 5.420000] 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
<4>[ 5.430000] 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
<4>[ 5.440000] 0,1,2,3,4,5,6,7,8,9,10,11,12,13,14,15
<4>[ 5.440000] 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
<4>[ 5.450000] 0,1,2,3,4,5,6,7,8,9,10,11,12,13,14,15
<4>[ 5.450000] 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
<4>[ 5.460000] 0,1,2,3,4,5,6,7,8,9,10,11,12,13,14,15
<4>[ 5.470000] wifi0: mac 20.0 phy 10.2 radio 13.0
<4>[ 5.470000] wifi0: Use hw queue 1 for WME_AC_BE traffic
<4>[ 5.480000] wifi0: Use hw queue 0 for WME_AC_BK traffic
<4>[ 5.480000] wifi0: Use hw queue 2 for WME_AC_VI traffic
<4>[ 5.490000] wifi0: Use hw queue 3 for WME_AC_VO traffic
<4>[ 5.490000] wifi0: Use hw queue 8 for CAB traffic
<4>[ 5.500000] wifi0: Use hw queue 9 for beacons
<4>[ 5.500000] wifi0: Use hw queue 7 for UAPSD
<6>[ 5.510000] wifi0: Atheros AR9100 WiSoC: mem=0xb80c0000, irq=2
<5>[ 5.510000] scsi 0:0:0:0: CD-ROM Vodafone CD ROM (Huawei) 2.31 PQ: 0 ANSI: 2
<4>[ 5.530000] sr0: scsi-1 drive
<6>[ 5.530000] Uniform CD-ROM driver Revision: 3.20
<7>[ 5.540000] sr 0:0:0:0: Attached scsi CD-ROM sr0
<6>[ 5.820000] usbcore: registered new interface driver usblp
<6>[ 7.570000] device br0 entered promiscuous mode
<6>[ 7.630000] device vlan1 entered promiscuous mode
<6>[ 7.630000] device eth0 entered promiscuous mode
<6>[ 7.640000] br0: port 1(vlan1) entering learning state
<6>[ 7.640000] device br0 left promiscuous mode
<6>[ 7.650000] device br0 entered promiscuous mode
<6>[ 7.660000] device br0 left promiscuous mode
<6>[ 7.660000] device br0 entered promiscuous mode
<4>[ 7.800000]
<4>[ 7.800000] ath_numswbaperbc = 8(1)adj=76800
<6>[ 8.640000] br0: port 1(vlan1) entering forwarding state
<6>[ 11.250000] device ath0 entered promiscuous mode
<6>[ 11.260000] br0: port 2(ath0) entering learning state
<6>[ 11.440000] bonding: Ethernet Channel Bonding Driver: v3.6.0 (September 26, 2009)
<6>[ 11.450000] bonding: MII link monitoring set to 100 ms
<6>[ 12.260000] br0: port 2(ath0) entering forwarding state
<6>[ 12.930000] usbcore: registered new interface driver usbserial
<6>[ 12.940000] USB Serial support registered for generic
<6>[ 12.940000] usbcore: registered new interface driver usbserial_generic
<6>[ 12.950000] usbserial: USB Serial Driver core
<6>[ 13.220000] USB Serial support registered for GSM modem (1-port)
<6>[ 13.230000] usbcore: registered new interface driver option
<6>[ 13.240000] option: v0.7.2:USB Driver for GSM modems
<4>[ 14.870000] Freeing node: f4:ec:38:fc:0b:d4
<4>[ 14.880000] ic->ic_cwm.cw_width :0, ic->ic_cwm.cw_extoffset: 0
<6>[ 16.840000] etherip: Ethernet over IPv4 tunneling driver

lsusb -v:
/bin/sh: eval: line 1: lsusb: not found

cat /sys/kernel/debug/usb/devices:
(no report)

cat /proc/bus/usb/devices:
(no report)

comgt -d /dev/usb/tts/0 info output:
/bin/sh: can't open /dev/usb/tts/0: no such file
##### Wireless WAN Modem Configuration #####
Can't open device /dev/usb/tts/0.

--------------------------------------------------------------------------------
i alsow tryed :

1. Setup everything in the setup section and use auto on network selection and no pin code. Dial command #99

2. setup a startup script to include the following

echo "12d1 1506" > /sys/bus/usb-serial/drivers/option1/new_id
sleep 20
usb_modeswitch -v 12d1 -p 1505 -V 12d1 -P 1506 -M "55534243123456780000000000000011062000000100000000000000000000" -n 1 -W
sleep 30
nvram set 3gdata=/dev/usb/tts/0

Then it should get online when you restart the router given that the apn are set correctly.

3. cron (if you get disconnected)

* * * * * [ "`/usr/sbin/nvram get 3gdata`" == "/dev/usb/tts/2" ] && /usr/sbin/nvram set 3gdata=/dev/usb/tts/0


--------------------------------------------------------------------------------
please help!!
Sponsor
LOM
DD-WRT Guru


Joined: 28 Dec 2008
Posts: 7095

PostPosted: Thu Mar 15, 2012 7:07    Post subject: Reply with quote
You are running an old dd-wrt build, you will at least need version 18024 but it is likely that it won't work with that one either in which case you have to wait for next public build to be released.

The latest released build, 18687, would have worked for you but it has non-functioning lan/wan for WR1043 so don't try it!!

It is expected that a new build will be released within a few days so it may be an idea to wait for that one.

_________________
I'm on a whiskey diet, lost 3 days already
FireBloodPhoeniX
DD-WRT Novice


Joined: 15 Mar 2012
Posts: 3

PostPosted: Thu Mar 15, 2012 9:09    Post subject: Reply with quote
LOM wrote:
You are running an old dd-wrt build, you will at least need version 18024 but it is likely that it won't work with that one either in which case you have to wait for next public build to be released.

The latest released build, 18687, would have worked for you but it has non-functioning lan/wan for WR1043 so don't try it!!

It is expected that a new build will be released within a few days so it may be an idea to wait for that one.

Thank You For your Response
Where would i get the latest version if it comes out?
The home page states:

Latest development release v24 preSP2 (Build13064) -->but you cant click it

http://www.dd-wrt.com/site/support/router-database states:
tl-wr1043nd-webflash.bin 2010-08-09 --->this is a Very old ver

I don't even know where to get v18024 nor v18687 or to keep track of when it updates

i updated to :
http://www.dd-wrt.com/site/support/other-downloads?path=others%2Feko%2FBrainSlayer-V24-preSP2%2F2011%2F12-20-11-r18024%2Ftplink_tl-wr1043nd%2F
last night ,is this v18024 ?if it is you are rite it dose not work

Edit: Ok go to :
http://www.dd-wrt.com/site/support/other-downloads?path=others%2Feko%2FBrainSlayer-V24-preSP2%2F
Sash
DD-WRT Guru


Joined: 20 Sep 2006
Posts: 17473
Location: Hesse/Germany

PostPosted: Thu Mar 15, 2012 12:05    Post subject: Reply with quote
read:
_________________
Forum Guidelines...How to get help
&
Forum Rules
&
RTFM/STFW
&
Throw some buzzwords into the WIKI search Exclamation
_________________
I'm NOT rude, just offer pure facts!
_________________
Atheros (TP-Link & Clones, etc ) debrick service in EU
_________________
Guide on HowTo be Safe, Secure and Protect Your Online Anonymity!
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum