OLSR Mesh network ddwrt routers not connecting at all

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Advanced Networking
Author Message
royscharf
DD-WRT Novice


Joined: 20 Mar 2014
Posts: 1

PostPosted: Thu Mar 20, 2014 17:40    Post subject: OLSR Mesh network ddwrt routers not connecting at all Reply with quote
Hey Everyone. I am trying to setup a mesh system using new routers, specifically the TP-LINK WR741ND routers. Very nice specs, and they work perfectly on dd-wrt. I have seen people using OLSR on the Broadband Hamnet firmware for mesh networking, but that only works on old linksys routers with very poor specs. I wanted to use DD-WRT for mesh networking through the wifi antenna on new routers for better performance. The plan is to setup mesh nets to link towns in the county in an off-grid powered network where come of the nodes can also have internet access for the mesh.

I setup each router with the ddwrt firmware and these are the settings on them so far:

Both Routers:
Wireless is unbridged
Wireless Mode = Adhoc
Both routers have the wifi unsecured and matching SSID
I tried many combinations of interfaces added to the OLSR

Router 1:
Router LAN IP = 192.168.10.1
Router LAN Subnet = 255.255.255.0
Wireless IP = 10.1.1.1
Wireless Subnet = 255.255.255.0

Router 2:
Router LAN IP = 192.168.11.1
Router LAN Subnet = 255.255.255.0
Wireless IP = 10.1.1.2
Wireless Subnet = 255.255.255.0


The problem that I noticed later is that they are not connecting to each other in adhoc mode. I thought they would automatically connect to each other with matching SSID and wifi settings. Does anyone know how to fix this?

I have yet to find any real useful sources on DD-WRT OLSR mesh networking on this site or others, so help would be much appreciated.

Roy
Sponsor
willrc627
DD-WRT Novice


Joined: 22 Apr 2015
Posts: 18

PostPosted: Wed Apr 22, 2015 4:24    Post subject: Reply with quote
Did you ever get your configuration to work? I have the exact same routers in an almost exactly similar setup. My routers have all of the same settings and will both individually connect to my laptop running olsrd but neither router will connect to the other. I have both of mine set up as no-gateway nodes and plan to add a WRT54G2 as a gateway node when I can get the other two communicating. Any ideas/solutions?
cmobley7
DD-WRT Novice


Joined: 21 May 2017
Posts: 7

PostPosted: Fri May 26, 2017 3:27    Post subject: Reply with quote
Did you ever get this to work. I bought 3 ASUS RT-56Rs, set them up as outlined here, https://www.dd-wrt.com/phpBB2/viewtopic.php?t=309282&highlight=olsr+setup. However, while they see each other, I haven't been able to ping them through telenet and can't see the OLSR network from the wifi card on my laptop or desktop. I would appreciate any help you are able to give.
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Advanced Networking All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum