WRT310N unable to connect to modem, receive IP, etc.

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Author Message
bithaze
DD-WRT Novice


Joined: 25 Jun 2012
Posts: 1

PostPosted: Thu Jun 28, 2012 0:25    Post subject: WRT310N unable to connect to modem, receive IP, etc. Reply with quote
I have a Linksys WRT310N (version 1.0) running DD-WRT v24-sp2 (08/07/10) vpn 14896. A few days ago, though, I started experiencing some issues with it that I have been unable to resolve. I think it might be hardware but I really don't know at this point.

At first, the problem seemed to be just not receiving a WAN IP from the modem. I did what I could think of – power cycling, rebooting the modem, MAC cloning the Ethernet port of an old desktop (though I've never had to register MAC addresses with Comcast), swapping Ethernet cables, even factory resetting the router – but still no luck. Neither the Link light on the modem (an Arris TM502G) or the Internet light on the router will come on though. Directly connecting the modem to a computer via Ethernet works fine, which eliminates anything being wrong with our connection.

Other, possibly related, issues that I've come across while attempting to troubleshoot the above:
  • Sometimes, the “Internet” light on the router will come on even when no Ethernet cable is connected to the WAN port.
  • The laptop connected to LAN port 1 is only operating at 10/100, when both laptop and router LAN ports support 1000.
If everything were working normally, I would have the modem connected to the router via Ethernet, with one laptop connected to the router via Ethernet and a handful of wireless devices. When other people are home and I'm not actively trying to figure out what's wrong, though, I connect the laptop directly to the modem so at least that can be used to get online.

I'm not really sure where to go from here, but if there's a chance it's not a hardware problem or I can do anything to find out what is, I would appreciate the advice.
Sponsor
barryware
DD-WRT Guru


Joined: 26 Jan 2008
Posts: 12857
Location: Behind The Reset Button

PostPosted: Thu Jun 28, 2012 13:49    Post subject: Reply with quote
sounds like your router has failed.

if everything else seems to be working except your wan port, you can assign one of the lan ports to act as a wan port.

The info is in the wiki.

_________________
[Moderator Deleted] Shocked
madman999
DD-WRT Guru


Joined: 11 Jun 2012
Posts: 861

PostPosted: Thu Jun 28, 2012 15:51    Post subject: Reply with quote
is this a known working router that has been running dd-wrt flawlessly for years but has suddenly started to flake out?

off hand, if you are getting no link light from the router, it does sound like a hardware issue. i;d open it up and looked for popped caps or burnt chips or discoloration on the board first.

what build is it? is it standard or micro? make sure the wan mac address matches what is on the bottom label of your router.

try putting a switch between the modem and the dd-wrt router just to see if we can get a better idea of what is going on.

isn;t there a way to change the wan port to a different one using the vlan capibilities?

if all else fails but the lan ports work you could always just repurpose this as a repeater, bridge or wired ap.
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum