WRT54GS - Lan Port Problem

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Author Message
CoBrA2168
DD-WRT Novice


Joined: 02 May 2009
Posts: 18

PostPosted: Wed Jul 11, 2012 17:40    Post subject: WRT54GS - Lan Port Problem Reply with quote
Okay guys, hopefully someone can help me out with this one, because at this point, I'm absolutely confused!

I have a WRT54GSv7.2, WRT54GSv1, and a Buffalo WHR-HP-G300N. I have been using the v1 as a repeater for years, the v7.2 has been sitting in its box for about a year, and the Buffalo's wireless sucks and I finally called to get it replaced.

In the meantime for the replacement, I figured I would bust out the v7.2 to use. I was hoping to just plug it in, configure it exactly like the buffalo, and all would be good.

Well the first problem I ran into with the v7.2 is the LAN ports weren't working. So I tried holding the reset button (30/30/30 reset) but that didn't work. I thought it was bricked, but figured that couldn't happen from sitting in a box for about a year. I was curious, so I tried to find the wireless. Low and behold, it was there. I was able to connect, and access the internet fine. BUT - still no wired connections. This is kind of important because we use internet phone. So I reflashed DD-WRT (the same build it was on, Brainslayer 14929 micro). After the flash, the same issue was there - no LAN! I thought, hmm maybe the official Linksys firmware would fix the problem. Not thinking, I stupidly flashed the special "revert" firmware for the v7.2. Now it's stuck in the revert firmware (management mode?) but since the LAN ports aren't working, I assume I've bricked it Sad

Okay, so that sucks. Now let's take the v1 I have and use it as my main router just until the replacement comes. I plug in my LAN cable, ping it fine, and check out the settings. I decide to just do a 30/30/30 reset to restore it to factory settings, and then I'll re-configure it after. So I do a 30/30/30 reset and then guess what? NONE OF THE LAN PORTS WORK!!! So now it's just like the v7.2 was! (note I'm also on Brainslayer 14929 std on this router).

Please, someone enlighten me on what I'm doing wrong. I've tried multiple computers, tried DHCP and static IP addresses in Windows 7. I'm absolutely lost on this one.
Sponsor
mstombs
DD-WRT User


Joined: 31 Oct 2007
Posts: 147

PostPosted: Wed Jul 11, 2012 20:31    Post subject: Reply with quote
Do the connection led light up on PC or router?

The separation of wan and lan ports is done via nvram vars, so do check ALL the ports - its is possible for the WAN to become LAN etc. Reset to defaults should work, the reset_gpio is usually itself stored in the nvram!
CoBrA2168
DD-WRT Novice


Joined: 02 May 2009
Posts: 18

PostPosted: Thu Jul 12, 2012 5:15    Post subject: Reply with quote
So as I expected, this of course was not a hardware problem at all. But then again, it also wasn't a firmware problem either! Let me explain...

Last week, I was trying different firmwares with that POS Buffalo router that I have. In the process, I tried flashing regular dd-wrt firmware on it (instead of the official, encrypted buffalo firmware). Those weren't helping at all, so I decided I better go back to the Buffalo firmware for when I call for an exchange. To do so, you need to TFTP the firmware over using some special instructions (here: http://g300nh.blogspot.com/2010/06/firmware-flash-and-brick-recovery.html).

One of those steps is to do a netsh "add" command, corresponding to the MAC address of the router. Coincidentally, the two machines I tried with these WRT54GS routers, were the ones that I was attempting to TFTP the firmware over. I'm not quite sure what the netsh commands do (a little over my head), but I figured that was the cause. I tried another computer and viola - the LAN ports were magically working.

So I googled "netsh reset" and this is the first thing that came up: http://support.microsoft.com/kb/299357 And yes, it fixed my problem.

I highly doubt anyone will ever be in this exact situation, but in case anyone is, here's the solution Smile
dexterr1
DD-WRT Novice


Joined: 13 Jul 2012
Posts: 1

PostPosted: Fri Jul 13, 2012 13:35    Post subject: Reply with quote
Oh man! you just saved my life!

I have asked this question so many times and no one was able to answer me!

Finally I got the solution...

Many thanks from the depth of my heart...

_________________
Habanos cuban cigars
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum