/usr/sbin/ip not working in 18777

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Author Message
pjama
DD-WRT Novice


Joined: 07 Feb 2010
Posts: 20

PostPosted: Sun Oct 07, 2012 2:25    Post subject: /usr/sbin/ip not working in 18777 Reply with quote
Hi BBers,
I've finally bitten the bullet and decided to upgrade from my trusty asus wl500w to a Lynksys e4200.

I've installed 18777 as per recommendation from the wiki and most things seem ok BUT one thing I need is for /usr/sbin/ip to work because firewall scripts generated by Firewall Builder use this command.

I get normal output from "/usr/sbin/ip addr" on WL500L/r14929 but no output at all on the e4200/r18777.

Can anyone confirm if this works on their r18777 install? On later versions?

eg on the wl500w
root@router5:~# ip addr
1: lo: <LOOPBACK,MULTICAST,UP> mtu 16436 qdisc noqueue
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 brd 127.255.255.255 scope host lo
2: teql0: <NOARP> mtu 1500 qdisc noop
link/void
3: eth0: <BROADCAST,MULTICAST,PROMISC,UP> mtu 1500 qdisc pfifo_fast
link/ether 00:1b:fc:0c:24:d1 brd ff:ff:ff:ff:ff:ff
4: eth1: <BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast
link/ether 00:1b:fc:0c:24:d2 brd ff:ff:ff:ff:ff:ff
inet 111.222.111.222/24 brd 220.239.68.255 scope global eth1
5: eth2: <BROADCAST,MULTICAST,PROMISC,UP> mtu 1500 qdisc pfifo_fast
link/ether 00:1b:fc:0c:24:d3 brd ff:ff:ff:ff:ff:ff
6: br0: <BROADCAST,MULTICAST,PROMISC,UP> mtu 1500 qdisc noqueue
link/ether 00:1b:fc:0c:24:d1 brd ff:ff:ff:ff:ff:ff
inet 192.168.1.1/24 brd 192.168.1.255 scope global br0
7: etherip0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop
link/ether 4a:7c:d3:80:1d:c0 brd ff:ff:ff:ff:ff:ff
root@router5:~#

Yet on the e4200:
root@router8:/usr/sbin# ip addr
root@router8:/usr/sbin#

Any help appreciated
P
Sponsor
Vespian
DD-WRT User


Joined: 26 May 2009
Posts: 183
Location: N34 31.872 E69 10.821 for now.

PostPosted: Sun Oct 07, 2012 2:31    Post subject: Reply with quote
Works for me on my Asus RT-N16 running


DD-WRT v24-sp2 mega (c) 2012 NewMedia-NET GmbH
Release: 07/20/12 (SVN revision: 19519)
Enhanced with OTRW, Take 2

_________________
The Peacock Thread <-- New? READ THIS!
------

Current:
ASUS RT-N16 DD-WRT v24-sp2 mega(SVN revision 19519)Running OTRW - Take 2 on 8 GB Flash Disk. 128M swap + 7.5 GB ext2 on /opt
Past:
ASUS WL500GP v2 [DD-WRT v24-sp2 (06/17/09) mega-(SVN 12307M NEWD Eko)]

Registered Linux User #491768
pjama
DD-WRT Novice


Joined: 07 Feb 2010
Posts: 20

PostPosted: Sun Oct 07, 2012 22:13    Post subject: /usr/sbin/ip not working in 18777 Reply with quote
OK I've upgraded and downgraded and found that "ip" worked in 17990 but not in any (mini, big or mega) builds of 18777 or 20086 (mini).

I've eventually settled with a work around where I borrowed the "busybox" file from 17990, copied it to my e4200 (now running 20086), linked ip -> busybox and run that ip within the Firewall Builder script and it woks just fine.

Please note this as a bug that ip does not work in 18777 or 20086 and probably versions in between (I tried one but can't remember which).

Cheers
P




Joined: 01 Jan 1970
Posts:

PostPosted: Mon Jan 07, 2013 15:50    Post subject: Reply with quote
Eureka! Finally realized why ipv6 6to4 is broken for the recent BS builds I've tried; The startup scripts for ipv6 rely on the ip command, but the ip command has been broken since at least 18777 as you say.

Found the relevant tickets on trac:

http://svn.dd-wrt.com:8000/ticket/2590

and I guess a recent duplicate:
http://svn.dd-wrt.com:8000/ticket/2767
Mark Rose
DD-WRT Novice


Joined: 07 Nov 2013
Posts: 6

PostPosted: Thu Nov 07, 2013 4:17    Post subject: Reply with quote
SO FRUSTRATING!!!!


I've just spent 3 hours trying to figure why the ip command hasn't been working.

I'm astonished such a basic networking command would be busted on a routing device.

So it's still broken in build 21676 mega, which I'm running on an Asus RT-N66U.
Mark Rose
DD-WRT Novice


Joined: 07 Nov 2013
Posts: 6

PostPosted: Thu Nov 07, 2013 4:33    Post subject: Reply with quote
Ticket for my issue: http://svn.dd-wrt.com/ticket/3033
haraldh
DD-WRT Novice


Joined: 25 Nov 2011
Posts: 9

PostPosted: Wed Nov 20, 2013 7:39    Post subject: Reply with quote
This affects me as well. The command 'ip addr' doesn't return anything. Same goes for 'ip link'.

'ip route' and 'ip neigh show' works.
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum