Multiple SSIDs & Separate Subnets w/v24

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8
Author Message
orangeboy
DD-WRT Novice


Joined: 11 Feb 2009
Posts: 12

PostPosted: Fri Feb 13, 2009 1:22    Post subject: Reply with quote
orangeboy wrote:
It seems I've not had the problems some of the people here have had. I have successfully configured 3 SSIDs on a WRT54G v6 using DD-WRT v24 (05/24/08.) micro (SVN revision 9526)

wl0 is setup using 192.168.0.2 (Bridged & WPA)
wl0.1 is setup using 192.168.1.2 (Unbridged & open/guest)
wl0.2 is setup using 192.168.2.2 (Unbridged & WEP)

DNSMasq statements (some I found after reading this thread are not needed, but I won't change it):
Code:
interface=wl0.1
dhcp-option=wl0.1,3,192.168.1.2
dhcp-option=wl0.1,6,192.168.0.2
dhcp-range=wl0.1,192.168.1.200,192.168.1.249,255.255.255.0,1440m
interface=wl0.2
dhcp-option=wl0.2,3,192.168.2.2
dhcp-option=wl0.2,6,192.168.0.2
dhcp-range=wl0.2,192.168.2.200,192.168.2.249,255.255.255.0,1440m


Firewall rules are:
Code:
iptables -I INPUT -i wl0.1 -m state --state NEW -j logaccept
iptables -I INPUT -i wl0.2 -m state --state NEW -j logaccept
iptables -I FORWARD -i wl0.1 -o br0 -j logdrop
iptables -I FORWARD -i wl0.2 -o br0 -j logdrop
iptables -I FORWARD -i br0 -o wl0.1 -j logdrop
iptables -I FORWARD -i br0 -o wl0.2 -j logdrop
iptables -I FORWARD -i wl0.1 -o wl0.2 -j logdrop
iptables -I FORWARD -i wl0.2 -o wl0.1 -j logdrop


My question is: how do I access a device in wl0.2 from br0? I have a Tivo that I'd like to be able to communicate with from my PC using the Tivo Desktop application. I've tried using the following (or variants) as the first rules in the firewall:
Code:
iptables -I FORWARD -d 192.168.2.105 -i wl0.2 -j ACCEPT #Network to Tivo
iptables -I FORWARD -s 192.168.2.105 -i br0 -j ACCEPT #Tivo to Network


I obviously am not familiar with iptables syntax or logic yet, and would like some guidance please! Hopefully this is an easy question that just hasn't been asked before (or it has been, and I just hadn't found the answer).

Thanks!!!


bump

_________________
WRT54G v6 running DD-WRT v24 (05/24/08) micro (SVN revision 9526)
Sponsor
kisav
DD-WRT Novice


Joined: 07 Apr 2009
Posts: 1

PostPosted: Wed Apr 08, 2009 4:45    Post subject: Reply with quote
I just got Linksys WRT54G2. Flashed it with DD-WRT v24-sp2 (01/01/09) micro-plus - build 11296M NEWD Eko.
Now, I need to create an unsecure ‘Guest’ SSID, so anyone can browse the internet but they shouldn’t be able to connect to my network. When I enable it under Wireless-basic, the internet access is working fine but my home network is also visible. Not sure if this is a bug or am I doing something wrong. I’ve seen it working on DIR655 router. Can this be done with WRT54? TIA -Alex
Podolak
DD-WRT Novice


Joined: 28 Apr 2009
Posts: 1

PostPosted: Thu Apr 30, 2009 18:36    Post subject: Reply with quote
Bird333 wrote:
See if you can figure this out. I tried to use this setup on a second router in 'Repeater' mode. The virtual AP connection works but I can't reach the main router or the internet. The repeater receives a WAN IP from the main router so I know the repeater function is working.

Main AP local ip address: 192.168.1.1
Repeater local ip: 192.168.1.2 (I can also reach it with 192.168.2.1 with your setup)

When I try to ping the main ip I get 'Destination Host Unreachable'

Thoughts?


I need to do this but a little differently.

I have one WRT54GL setup with two SSIDs. It works perfectly. I now want to bridge a second WRT54GL to extend my range. I put the second one in "Repeater Bridge" mode and added the second SSID as unbridged. I can use the lan ports and primary SSID to connect to the network no problem. However, when I connect to the second SSID (which is restricted from network access but should have Internet access) I can't even pull an IP or gain access. Any thoughts on this?

I also tried making the second WRT54GL an AP and use WDS but that didn't seem to work either.

Thanks all!
spectracotter
DD-WRT Novice


Joined: 13 May 2009
Posts: 1

PostPosted: Wed May 13, 2009 0:57    Post subject: Reply with quote
BUMP....

I'm using a WRT54G2 and seem to have a similar issue. I'm currently using Firmware: DD-WRT v24-sp2 (04/08/09) micro-plus-ssh. I want to setup 2 SSIDs one being private RADIUS and the other public with no encryption. When I connect to the public address I get a DHCP lease but cannot connect to the internet. Some of the reading has been telling me not to set the bridge up in the GUI. Should I still set it up via start up commands?

Any help would be greatly appreciated!
AlanO
DD-WRT Novice


Joined: 21 Sep 2011
Posts: 1

PostPosted: Wed Sep 21, 2011 2:15    Post subject: External DNS not working? Reply with quote
Not sure what I'm doing wrong here, but maybe someone can offer some assistance. I followed this and things seem to work locally, but external name resolution doesn't seem to be working. I verified the all the DNSMasq are set as specified.

TIA!
Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8 Display posts from previous:    Page 8 of 8
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum