DD-WRT + Nighthawk R7000 + 4G Huawei E3372 modem w/HiLink

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Contributions Upload
Author Message
formation
DD-WRT Novice


Joined: 16 Nov 2016
Posts: 1

PostPosted: Wed Nov 16, 2016 7:31    Post subject: DD-WRT + Nighthawk R7000 + 4G Huawei E3372 modem w/HiLink Reply with quote
Hi,

First post here, I'd thought I would just share the correct operation of getting this 4g dongle to work through the USB ports on this particular router as this took me a LOT of googling and a lot of confusion as there seems to be a lot of variations of things that "worked" for people, I think my method would be the most robust.

First off here are the specs for everything:

Router: Netgear Nighthawk R7000 (appx 2 years old)
Firmware: DD-WRT v3.0-r30700M kongac (09/27/16)
Modem: Huawei E3372, Australian branded Optus model (I would assume any with HiLink are identical) I picked mine up for $14 with a free 4gb of 4g/lte data.

Most of the issues with getting this 4g modem to work is due to HiLink, the following tutorial will hopefully help at least 1 other person that might get into the same situation.

Step 1
Flash your router with the DD-WRT firmware (If not done already, plenty of tutorials out there to do this)

Step 2
Navigate to Setup -> Basic setup and make sure connection type is set to DHCP & then apply settings.

Step 3
Click services -> USB -> Enable "Core USB Support" apply settings

Step 4
Click Administration -> Commands & paste the following into the "Command Shell" input box:

Code:

insmod usbnet
insmod cdc_ether
usb_modeswitch -J -v 0x12d1 -p 0x1f01
sleep 20
udhcpc -i eth3


After the you paste in the above, click "Save Startup".

Step 5
Click Services -> Services & Scroll to the bottom of the page and click 'Reboot Router' wait for roughly 30 seconds.

Once the router has rebooted & your're back into the interface there will be another 20 second delay for the IP to be obtained from the 4g modem and you will see "WAN IP: 192.168.8.100" in the top right of the interface.

Step 6
What I call the magic step as it's the one thing not mentioned when getting this modem to work & its the only thing you will need to get it to work.

Finally:
Click on Setup -> Networking & Scroll down to "Port Setup" and under WAN Post Assignment change this to eth3 & then apply settings.

Now after changing the above you should have internet access through the router via the modem & the wan IP should be WAN IP: 192.168.8.101 unless you have a non-default range set in your router.

Troubleshooting:
Quote:
I've followed all your steps however I don't have any internet yet, HELP!


First rule of thumb, reboot your router & wait another minute after its loaded back up and then check your connection.

Check the status for the WAN inside of Status -> WAN, there should be a Gateway and DNS IP of 192.168.8.1(HiLink)

Check your modem, this may be faulty plug it into a PC in the same room as your router and check that you can get an internet connection through it.

If none of the above is working, reset your router to defaults either through the hardware reset switch or through the DD-WRT firmware.

Failing any of those you might just be very unlucky, or the hardware on the stick might not be matching 0x1f01, if you suspect this as an issue, turn on SSH, ssh directly into the router and run diagnostics(I can't be more specific here, sorry!).
Sponsor
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Contributions Upload All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum