WRT54G2: Wireless rate drops to 2 Mbps or 1 Mbps

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page Previous  1, 2, 3, ... 13, 14, 15  Next
Author Message
LLB
DD-WRT Guru


Joined: 05 Oct 2008
Posts: 521

PostPosted: Mon May 04, 2009 5:00    Post subject: Reply with quote
ThaCrip wrote:
(and i hard-reset both of them before manual configure with the 'erase nvram' stuff)


Do a proper 30/30/30 hard reset. I have found the erase nvram doesn't always work properly. You need to get a new password page on entry. If you didn't, it did not work.
Sponsor
ThaCrip
DD-WRT User


Joined: 05 May 2008
Posts: 265

PostPosted: Mon May 04, 2009 5:39    Post subject: Reply with quote
LLB wrote:
ThaCrip wrote:
(and i hard-reset both of them before manual configure with the 'erase nvram' stuff)


Do a proper 30/30/30 hard reset. I have found the erase nvram doesn't always work properly. You need to get a new password page on entry. If you didn't, it did not work.


i did get to the password page entry ;)

but on the last page... someone said to try another build... any suggestions? (because it seems like for the routers i have everyone claims 11296 is the best, which is what im running)

EDIT: looks like the speed etc just went out the window and now it's just real slow so i went back to my old setup. ill just wait until a fix comes out for these types of setup's before attempting to use repeater bridge etc again.

_________________
Linksys WRT54GS v6 Router /w DD-WRT v24-12548_NEWD_micro (not at my house any more (@ sisters house))

Belkin F5D7230-4 v1444 Router /w DD-WRT v24-12548_NEWD_micro-plus (used in 'client bridge' mode to connect to my primary router to stream video from PC to XBox1 running XBMC)

Asus WL-520gU Router /w Tomato Firmware v1.28.1815 (my primary router)

Linksys WRT54GS v1.1 /w Tomato Firmware v1.28.1815 (currently not in use)
meatbiscuit
DD-WRT Novice


Joined: 04 Mar 2009
Posts: 48

PostPosted: Mon May 04, 2009 21:32    Post subject: Reply with quote
What is your Wireless Channel set to?
tedhbrown
DD-WRT Novice


Joined: 26 Aug 2006
Posts: 16

PostPosted: Tue May 05, 2009 2:44    Post subject: Reply with quote
I have the same problem with two WRT150Ns. I've tried many many firmware revisions and they all have the same problem.
mac913
DD-WRT Guru


Joined: 02 May 2008
Posts: 729
Location: Canada

PostPosted: Tue May 05, 2009 3:44    Post subject: Reply with quote
beng wrote:
Hmm. I think I spoke too soon.

With the Tx power set to 45 mW, the problem came back again this morning as soon as my wireless client did an iTunes podcast download; the data rate dropped down to 2 Mbps and stuck there.

I've moved the Tx power down to 35 mW to see if that helps. But I'm seriously unimpressed with this hardware, and will be replacing it shortly.

(edit)

Same problem at 35 mW. Sad This hardware is going back.

I'm surprised -- is nobody else running into this problem?


I would try a different channel and also enble Bluetooth Coexistence Mode under Wireless -> Advanced Settings

_________________
Wired GigaBit Backbone
Netgear R7000 K3.x KONGAC 25090M | Gateway | OpenVPN Client
Netgear R7000 K3.x KONGAC 25580M | Gateway | AP+VAPs | OpenVPN Client
Netgear R7000 K3.x KONGAC 25090M | Spare
Linksys E3000 K2.6 KONG-VPN 22000++M | SSH | QoS | DDNS
Linksys E2000 (OC 500Mhz) Tomato Shibby 123 | OpenVPN Client
pako1144
DD-WRT Novice


Joined: 07 May 2009
Posts: 1

PostPosted: Thu May 07, 2009 16:16    Post subject: Reply with quote
I had a similar problem, but directly with wireless speed. I was unable to use the wireless at all, I had to get wired to be able to work! So after applying what redhawk suggested It worked perfect!.

redhawk0 wrote:
A few things to try.

On the Wireless>>Advanced tab
Change your Tx power from the default of 70 down to something in the 35-50mW range.

Disable CTS protection, FrameBurst, and Afterburner

Set the Preamble to Auto instead of Long.



Next....change the IP filter settings on the Administration tab to

Max Ports = 4096
TCP/UDP timeouts = 120 each.

The ports shouldn't effect the quality of your Wireless but it can reduce the router crash problem that we also see so often.

redhawk


I have my wireless fully working as if I'm wired connected.

Thanks a lot Redhawk
scion
DD-WRT Novice


Joined: 07 Jun 2009
Posts: 1

PostPosted: Sun Jun 07, 2009 8:24    Post subject: Reply with quote
redhawk0 wrote:

On the Wireless>>Advanced tab
Change your Tx power from the default of 70 down to something in the 35-50mW range.

Disable CTS protection, FrameBurst, and Afterburner

Set the Preamble to Auto instead of Long.
redhawk


router regain its speed. thanks, redhawk!
Lkr
DD-WRT User


Joined: 04 Jun 2009
Posts: 54

PostPosted: Sun Jun 07, 2009 19:56    Post subject: Reply with quote
redhawk0 wrote:
A few things to try.

On the Wireless>>Advanced tab
Change your Tx power from the default of 70 down to something in the 35-50mW range.

Disable CTS protection, FrameBurst, and Afterburner

Set the Preamble to Auto instead of Long.



Next....change the IP filter settings on the Administration tab to

Max Ports = 4096
TCP/UDP timeouts = 120 each.

The ports shouldn't effect the quality of your Wireless but it can reduce the router crash problem that we also see so often.

redhawk

WOAH, thank you so much. I am up to 54mbps now Smile
Lkr
DD-WRT User


Joined: 04 Jun 2009
Posts: 54

PostPosted: Mon Jun 08, 2009 0:21    Post subject: Reply with quote
I think the 1mbps is just a bug right now. Compared to turning down the antenna to 28 and getting 54mbps compared 70 and 1mbps, the 70 and 1mbps is MUCH faster. I honestly believe that this is just a bug with the WRT54G2 hardware and DD-WRT.
liverpoolatnight
DD-WRT User


Joined: 29 May 2008
Posts: 174
Location: United Kingdom

PostPosted: Fri Jun 26, 2009 11:25    Post subject: Reply with quote
Lkr wrote:
I think the 1mbps is just a bug right now. Compared to turning down the antenna to 28 and getting 54mbps compared 70 and 1mbps, the 70 and 1mbps is MUCH faster. I honestly believe that this is just a bug with the WRT54G2 hardware and DD-WRT.


In my WRT54G2 on 70nW i get around 5.5mpbs and drops to 2mpbs and goes up to 5.5mpbs but dosnt happen all the time now and again im running windows 7 build 7100 with the netgear wpn111 and the router is quite abit fair away, Signal quality is around 9%/18% in the status. Been though the channel numbers and the best channel is 6

-------

If i changed the 70 mW into say 80mW Would this give me a higher signal? As the router is fair away?

Or the low i go the higher?

_________________
TP-Link TL-WDR3600v1 DD-WRT v24-sp2 (06/23/14) std (SVN revision 24461) Main AP
D-Link DIR-615 D2: DD-WRT v24-sp2 (04/18/14) std (SVN revision 23919) Second AP
ISP: Virgin Media, Cable/Fibre Optic, Upto 152Mb/12Mb
adamcb
DD-WRT Novice


Joined: 26 Jul 2006
Posts: 26

PostPosted: Fri Jun 26, 2009 13:30    Post subject: Reply with quote
I am experiencing a similar problem on my WRT54GS. I'll try the recommendations and see if it helps!
redhawk0
DD-WRT Guru


Joined: 04 Jan 2007
Posts: 10961
Location: Wherever the wind blows- North America

PostPosted: Fri Jun 26, 2009 13:36    Post subject: Reply with quote
No...higher on the G2v1 won't help. it introduces too much noise with those crappy internal antennas. These units have very limited range.

As for the GS...totally different animal (hardware)...you can take the GS up in Tx power (keeping it below 100mW) to get a bit more range....but the configuration settings should help you.

redhawk

_________________
I currently test dd-wrt on Asus, Buffalo, Linksys, and Netgear. Too many to list.

Looking for more test units (newer models) for the project...got a brick?...PM me to make a hardware donation. (USA) A donation is not a debricking service....it is a way to "Give back" to the dd-wrt project.

I do NOT provide personal assistance through chat or phone....so please don't ask.
anoriega
DD-WRT Novice


Joined: 02 Oct 2009
Posts: 1

PostPosted: Fri Oct 02, 2009 7:23    Post subject: FIX for this problem here Reply with quote
I'm a longtime lurker and dd-wrt user, first time poster.

I have the solution that works great for me on this problem, I want to share it so someone else can hopefully benefit.

I just got a couple of WRT54G2 v1 routers to use as a wireless bridge to my home's basement. The only internet-enabled cable ports are on the 2nd floor of the house, and there's a basement desktop that needs internet, so I figured this would be a good route.

I had the same problem as others posting here, that when I started a large transfer, the rate would drop to 1, 2, or 5.5 Mbps. I've set up many bridges before and never had this problem until I was using _TWO_ WRT54G2's (I've had G2s on one end before with no problem).

I tried everything everyone mentioned here, including turning off CTS Protection, Frame Burst, Afterburner (of course), changing the Preamble, lowering the transmit power, using different channels, turning on Bluetooth coexistence, turning off WMM, using no auth vs using WPA2, different builds ranging from SP1 to pre-SP2 12966, 30/30/30 resets... EVERYTHING. While some combinations worked better than others, the rate would still drop on large transfers.

****THE SOLUTION**** Under Wireless > Advanced, on the AP set the Fixed Rate to Auto if it isn't already. On the BRIDGE, set a fixed rate of the highest that you can still keep a responsive and full-speed connection, for me it was 18Mbps. This is fine because my internet is 12Mbps Comcast with 15-18Mbps Powerboost, so I'll never need more than that.

I would just start with the next step up from your internet connection speed, and see how high you can take it while still getting a fast connection. When I set mine to 24Mbps, it still worked but was slower. Here's what I found from setting different rates on both ends:

AP Auto / Client 18Mbps - Tests at 17Mbps download, 4Mbps upload
AP 18 / Client 18 - 11 down, 3 up
AP Auto / Client 24 - 6 down, 1 up
AP 24 / Client 24 - Can barely get the speed test page loaded
AP Auto/36/48/54, Client 36/48/54 - Doesn't work
AP Auto / Client Auto - works initially at 54 and tests at 16-17, but then drops to 1, 2, or 5.5Mbps

Obviously the top line is what I'm using now - this is also nice because other wireless clients can still get 54Mbps. The connection is always responsive and always tests at 16-17Mbps download.

Something else of note for me is that I tried tons of different TX power values on both sides, ranging from 28 to 71mW. I ended up with 71 because I get 50% signal with an SNR of 39. Other values ended up giving anywhere from 30-45% signal with an SNR of 25-35. Also, the SNR gets larger and the signal better about 20 seconds after the routers connect, so don't judge your TX power effectiveness immediately after changing it.

Channel - as others said, do a site survey to find a channel far away from other used channels in your neighborhood - I would guess most neighbors would be using 6 since that's the default for a lot of routers, so probably 1 or 11 - I ended up using Auto and it changes between 1 and 11.

My settings are:

AP:
---
IP 192.168.1.1
Channel: Auto
Fixed Rate: Auto

Bridge:
-------
IP 192.168.1.2
Gateway+DNS: 192.168.1.1
Fixed Rate: 18Mbps

BOTH sides:
-----------
G-Only
WPA2 AES
CTS Protection: disabled
Frame Burst: disabled
Beacon interval: 100ms
Preamble: Long
TX Power: 71
Afterburner: off
BT Coexist: off
WMM: off

Okay, this post is long, sorry. I hope someone in my situation can get something out of it.

PS: I wish there was a brick-and-mortar store in the Minneapolis / St Paul area that sold original WRT54G v1 or v2's.
amigasger
DD-WRT Novice


Joined: 19 Aug 2009
Posts: 15
Location: Denmark

PostPosted: Sat Nov 07, 2009 18:05    Post subject: Reply with quote
redhawk0 wrote:
No...higher on the G2v1 won't help. it introduces too much noise with those crappy internal antennas. These units have very limited range.

As for the GS...totally different animal (hardware)...you can take the GS up in Tx power (keeping it below 100mW) to get a bit more range....but the configuration settings should help you.

redhawk


I got the WRT54G2v1 as well - I had only problems when using SP2 firmware. When I downgraded to v24 SP1 [Stable] Build 10020 - micro. Then the speed issues was gone - and transfer rate went straight to 54 mbps - no 2 mbps or shit like that.. Something must have been implemented wrong in the SP2 builds of dd-wrt firmware.
creaky
DD-WRT User


Joined: 22 Jan 2008
Posts: 190

PostPosted: Sat Nov 07, 2009 18:10    Post subject: Reply with quote
After leaving my WRT54G2 v1 running permamently i've noticed the Wireless rate drops right off frequently. None of my other routers do this. Whenever i notice the rate is so low, i just set the TX power to another figure then set it back to 28mW. 28 is just the figure i've always used on all my routers so i leave this one at 28 out of habit.

edit- the main reason i know it's dropped off is when G/F tries to watch internet TV via wifi and the stream grinds to a halt.

_________________
2 node (v23 sp2) WDS network over WPA2/AES comprising 2x Buffalo WHR-G54S's.

3 node setup ~ WPA2 AES comprising WRT54GS v6 (inc. WEP BSSID), WRT54G v2, WRT54G2 v1 (EKO 12548)


Last edited by creaky on Sat Nov 07, 2009 18:26; edited 1 time in total
Goto page Previous  1, 2, 3, ... 13, 14, 15  Next Display posts from previous:    Page 2 of 15
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum