WRT54G2 v1.5

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page Previous  1, 2
Author Message
DHC_DarkShadow
DD-WRT Guru


Joined: 22 Jun 2008
Posts: 2440
Location: Am now Dark_Shadow

PostPosted: Sat Feb 06, 2010 3:15    Post subject: Reply with quote
Router DBase lists it as "Not possible"
_________________
The New Me
Sponsor
Turboloader
DD-WRT Novice


Joined: 29 Dec 2009
Posts: 14

PostPosted: Mon Feb 08, 2010 13:05    Post subject: Reply with quote
Is it because the router has "only" 2MB of flash space?
In one post he (Brainslayer) says that he could port if the router has 16MB of RAM but another one says, that it's just not possible.
And why need vxWorks less space than DD-WRT?
Greetz
ZackaruS
DD-WRT Novice


Joined: 19 Jun 2007
Posts: 5

PostPosted: Tue Feb 09, 2010 15:49    Post subject: Reply with quote
I agree with Turboloader.

davidgrudek wrote:
Is there any possibility of v1.5 being supported?

I have returned it and bought it from 3 different stores and keep getting 1.5.

Now we are stuck with this one.

As davidgrudek, I have a v1.5. I couldn't choose it because the version number isn't written on the box.
I'm obliged to keep it because the seller doesn't take a device with an opened box.

A very very minimal version of the DD-WRT firmware would be enough of the moment we have the opportunity to reserve IP addresses with DHCP (the official firmware doesn't). Please Brainslayer.
DHC_DarkShadow
DD-WRT Guru


Joined: 22 Jun 2008
Posts: 2440
Location: Am now Dark_Shadow

PostPosted: Tue Feb 09, 2010 18:32    Post subject: Reply with quote
Turboloader wrote:
Is it because the router has "only" 2MB of flash space?
In one post he (Brainslayer) says that he could port if the router has 16MB of RAM but another one says, that it's just not possible.
And why need vxWorks less space than DD-WRT?
Greetz
Yes, as I recall the Atheros drivers are much larger than broadcom, so micro would be too larger to fit.
_________________
The New Me
Turboloader
DD-WRT Novice


Joined: 29 Dec 2009
Posts: 14

PostPosted: Tue Feb 09, 2010 19:30    Post subject: Reply with quote
Could you delete the entry in the Supported Devices List? -> http://www.dd-wrt.com/wiki/index.php/Supported_Devices#Linksys
Or Just "Not enough Space for driver/No support!".

That no more Threads for this Router will be opened and no more hope for other people.
Greetz
Turboloader
DD-WRT Novice


Joined: 29 Dec 2009
Posts: 14

PostPosted: Sun Apr 04, 2010 16:14    Post subject: Reply with quote
Sorry for doublepost.
1 question.
If I would find a way to make a "SD mod" for the WRT54G2. (No currently I haven't.)
Would one of you make a Firmware for this?
Mount the SD card as / would make no problems, wouldn't it?

As I read about SD mods for the old WRT54G I thought this would be a solution.
Greetz
chipwizme
DD-WRT Novice


Joined: 19 Jun 2009
Posts: 2

PostPosted: Mon Apr 19, 2010 7:00    Post subject: Reply with quote
Here is a boot log I obtained over serial:

Code:
VxWorks System Boot
CPU: WRT54G2       
Creation date: Apr 16 2009, 14:56:12




Press any key to stop auto-boot...
 0                               
auto-booting...                   


boot device          : tffs:
unit number          : 0   
processor number     : 0   
host name            : host
file name            : /fl/vxWorks.bin
inet on ethernet (e) : 192.168.1.1:ffffff00
host inet (h)        : 192.168.1.100       
user (u)             : target             
flags (f)            : 0x8                 
target name (tn)     : targetname         

Attaching to TFFS... done.
Loading /fl/vxWorks.bin...1169376
Starting at 0x80501a24...       

dddusrNetDevNameGet: no network device
Attaching interface lo0... done       
ATHRS26: resetting s26               
ATHRS26: s26 reset done               

Adding 8772 symbols for standalone.
                                   

 ]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]
 ]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]
 ]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]] 
      ]]]]]]]]]]]  ]]]]     ]]]]]]]]]]       ]]              ]]]]         (R)
 ]     ]]]]]]]]]  ]]]]]]     ]]]]]]]]       ]]               ]]]]           
 ]]     ]]]]]]]  ]]]]]]]]     ]]]]]] ]     ]]                ]]]]           
 ]]]     ]]]]] ]    ]]]  ]     ]]]] ]]]   ]]]]]]]]]  ]]]] ]] ]]]]  ]]   ]]]]]
 ]]]]     ]]]  ]]    ]  ]]]     ]] ]]]]] ]]]]]]   ]] ]]]]]]] ]]]] ]]   ]]]] 
 ]]]]]     ]  ]]]]     ]]]]]      ]]]]]]]] ]]]]   ]] ]]]]    ]]]]]]]    ]]]]
 ]]]]]]      ]]]]]     ]]]]]]    ]  ]]]]]  ]]]]   ]] ]]]]    ]]]]]]]]    ]]]]
 ]]]]]]]    ]]]]]  ]    ]]]]]]  ]    ]]]   ]]]]   ]] ]]]]    ]]]] ]]]]    ]]]]
 ]]]]]]]]  ]]]]]  ]]]    ]]]]]]]      ]     ]]]]]]]  ]]]]    ]]]]  ]]]] ]]]]]
 ]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]                                               
 ]]]]]]]]]]]]]]]]]]]]]]]]]]]]]       Development System                       
 ]]]]]]]]]]]]]]]]]]]]]]]]]]]]                                                 
 ]]]]]]]]]]]]]]]]]]]]]]]]]]]       VxWorks version 5.5                       
 ]]]]]]]]]]]]]]]]]]]]]]]]]]       KERNEL: WIND version 2.6                   
 ]]]]]]]]]]]]]]]]]]]]]]]]]       Copyright Wind River Systems, Inc., 1984-2002

                               CPU: WRT54G2.  Processor #0.
                              Memory Size: 0x1000000.  BSP version 1.0.

/fl/  - Volume is OK                                   
Detect: eth wan(ae0) has been loaded to MUX layer       
Detect: eth lan(ae1) has been loaded to MUX layer       
pingLog.txt exist.                                     
tracertLog.txt exist.                                   
-> Http Server Start!                                   
DHCP server started.                                   
Dhcps_IpStart=192.168.101.100                           
Dhcps_IpEnd=192.168.101.149                             
temp =snmk=255.255.255.0:rout=192.168.101.6:dnsv=192.168.101.6:maxl=3600:dfll=86400
can't get ifpWAN | ifpLAN                                                         
DMZ disable                                                                       
remote management disable                                                         
Filter Internet NAT Redirection  disabled!!!                                       
FTP ALG registered with NAT                                                       
RTSP ALG registered with NAT                                                       
H323 ALG registered with NAT                                                       
Msn ALG registered with NAT                                                       
SNMP ALG registered with NAT                                                       
NAT configuration and initialization complete!                                     
PPPOE init......seccess                                                           
L2TP init......seccess                                                             
PPTP init......seccess                                                             
APCFG task id 80c3a350                                                             
[system is runing for 5 seconds] MSG_WAN_SHOULD_START                             
WAN TYPE:DHCP                                                                     

usrDhcpcStart Start...

usrDhcpcStart End
sysWlanInit ... 
wlan: mac acl policy registered
ag7240MemInit: allocated, dmabuf=0x80a7dda0, buffend = 80be99a4
wifi0: Atheros 9285: irq=66 hw_base=0x0xb0000000               
check PIN ...                                                 
get pin from broaddata...                                     
Reading Flash                                                 
Setting the IP address                                         
AP_IPADDR=192.168.101.6                                       
Bridge IP Address: 192.168.101.6                               
Entering Task Loop                                             
LLTD: wireless interface argument is ath0.                     
Start Create MEM Drv to LLTD ico                               
AP_AUTOSTART=1                                                 
Automatic WLAN start!                                         
sending message 80a50f70,10                                   
Starting WLAN !!!!                                             
AP_ENABLE=1                                                   
ATH_COUNTRYCODE=840                                           
ieee80211_end_load: load done                                 
ath0 end flag = 0x00028802                                     
default                                                       
default                                                       
default                                                       
IEE80211-FREQ IOCTL 0,0,0                                     

WLAN IOCTL AP_CHMODE=11G=11G=11G=1003
IEE80211-MODE IOCTL 1,11G,4         
set mode 3,65535,6                   
set mode consistency pass 196608     
set mode retv 0                     

WLAN IOCTL AP_PRIMARY_CH=6=6=6=1002
IEE80211-FREQ IOCTL 0,6,3         

WLAN IOCTL AP_SSID=AR7240SOC=linksys=AR7240SOC=1001
IEE80211-ESSID IOCTL 1,AR7240SOC,10               
VAP ESSID AR7240SOC                               

WLAN IOCTL PUREG=1=0=1=1004
IEEE80211-SETPURGE IOCTL 1

WLAN IOCTL AP_HIDE_SSID=0=0=0=1005
IEEE80211-SETHIDESSIDIOCTL 0     

WLAN IOCTL AP_ISOLATION=0=0=0=1033
IEE80211-setparam-nobridge 0     

WLAN IOCTL AP_TXRATE=0=0=0=1039
set auto rate                 

WLAN IOCTL AP_11G_PROTECTION=0=0=0=1040

WLAN IOCTL AP_BEACON_INTERVAL=100=100=100=1041

WLAN IOCTL AP_FRAGMENT_THRESHOLD=2346=2346=2346=1042

WLAN IOCTL AP_RTS_THRESHOLD=2347=2347=2347=1044

WLAN IOCTL AP_DTIM_PERIOD=1=1=1=1043

WLAN IOCTL AP_WMM_ENABLE=0=0=0=1049
IOCTL set wmm 0                   

WLAN IOCTL AP_WMM_NOACK=0=0=0=1050
IOCTL set wmm noack 0             
AP_SECMODE=WPA2                   
WPS_ENABLE=1                     
AP_MACFILTER_MODE=0               
Setting the ACL command 0         

WLAN IOCTL AP_BASICRATES=0=0=0=1038
SET Basic rates 0                 
AP_SSID=AR7240SOC                 
AP_IPADDR=192.168.101.6           
WPS BSS init                       
WPS_ENABLE=1                       
WPS_PIN=79862189                   
WPS_STATE=2                       
AP_SECMODE=WPA2                   
WPA2 BSS init                     
WPA BSS init                       
PSK_KEY=KeyRemoved                 
AP_CYPHER=CCMP                     
AP_WPA_GROUP_REKEY=3600           
starting hostapd ...               
Hostapd task Created 80a3cf40     
Task details [80a3cf40,,64,80c3a150]
Adding ath0 in bridge ...           
default                             
Set EIOCGMIB2                       
default                             
Entering Hostapd Main               
default                             
Set EIOCGMIB2                       
attached backend socket .           
Attached backend socket for ae0     
Attached backend socket for ae1     
**** [2,1,0,0192.168.101.6,]****   
Just before eloop_run()
 *** setup interface1 started ****
 Eapol sockfd=18
Get EIOCGADDR
MAC address 0,25,ffffff9c,61,44,ffffff9e
IEE80211-IWMODE IOCTL  3
madwifi_set_privacy: enabled=0
IEE80211-setparam-privacy 0
madwifi_set_f_dropunenc: enabled=0
IEE80211-setparam_f_dropunenc 0
madwifi_set_wps_ie buflen = 16
ieee80211_ioctl_setappiebuf
madwifi_set_wps_ie buflen = 118
ieee80211_ioctl_setappiebuf
madwifi_set_wps_ie buflen = 0
ieee80211_ioctl_setappiebuf
ieee80211_ioctl_filterframe
 Madwifi init completed
1009152004.660000: ath0: IEEE 802.11 Fetching hardware channel/rate support not supported.
 *** setup interface1 completed ****
 *** setup interface2 started ****
madwifi_sta_deauth: addr=ff:ff:ff:ff:ff:ff reason_code=3
ieee80211_ioctl_setmlme
madwifi_set_privacy: enabled=0
IEE80211-setparam-privacy 0
madwifi_del_key: addr=00:00:00:00:00:00 key_idx=0
ieee80211_ioctl_delkey
madwifi_del_key: addr=00:00:00:00:00:00 key_idx=1
ieee80211_ioctl_delkey
madwifi_del_key: addr=00:00:00:00:00:00 key_idx=2
ieee80211_ioctl_delkey
madwifi_del_key: addr=00:00:00:00:00:00 key_idx=3
ieee80211_ioctl_delkey
Using interface ath0 with hwaddr 00:25:9c:61:44:9e and ssid 'AR7240SOC'
IEE80211-ESSID IOCTL 1,AR7240SOC,10
VAP ESSID AR7240SOC
madwifi_configure_wpa: group key cipher=3
IEE80211-setparam-mcastcipher 3
madwifi_configure_wpa: pairwise key ciphers=0x8
IEE80211-setparam-unicipher 8
madwifi_configure_wpa: key management algorithms=0x2
IEE80211-setparam-keymgmtalgs 2
madwifi_configure_wpa: rsn capabilities=0x0
ieee80211_rsncaps
madwifi_configure_wpa: enable WPA=0x2
IEE80211-setparam-wpa 2
IEE8022 init 0
IEE80211-setparam-authmode 5
IEE8022 init 0
madwifi_set_key: alg=CCMP addr=00:00:00:00:00:00 key_idx=1
ieee80211_ioctl_setkey
madwifi_set_privacy: enabled=1
IEE80211-setparam-privacy 1
hostapd_ctrl_iface_init
 ****setup interface2 completed****
 ****setup interface finalized ****

 !!! Create Trap Monitor Task !!!



Here is a list of running processes:

Code:
  NAME        ENTRY       TID    PRI   STATUS      PC       SP     ERRNO  DELAY
---------- ------------ -------- --- ---------- -------- -------- ------- -----
tExcTask   excTask      80ff0e60   0 PEND       80312044 80ff0d40       0     0
tLogTask   logTask      80fee1e0   0 PEND       80312044 80fee0c8       0     0
tTrapMon   routerTrapMo 80a29b00   1 DELAY      802c044c 80a299a8       0    55
tShell     shell        80d84380   1 READY      802c16d4 80d83fa0       0     0
tNetTask   netTask      80fe9ff0  50 PEND       80257938 80fe9f78       0     0
thttpd     HTTPD_LOOP   80c121a0  55 PEND       80257938 80c12058       0     0
thttpsd    HTTPD_LOOP_S 80c10900  55 PEND       80257938 80c10788       0     0
tDhcpsTask dhcpsStart   80c970c0  56 PEND       80257938 80c96e98  3d0002     0
tDhcpcState80158830     80c71900  56 PEND       80257938 80c71858      31     0
tDhcpcReadTdhcpcRead    80c701a0  56 PEND       80257938 80c6ff80  3d0002     0
Time_Task  Timer_Task   80d539f0  58 DELAY      802c044c 80d53958       0    51
tTftpd     802e368c     80c3de30  58 PEND       80257938 80c3d800       0     0
tWebAcc0   80232dc0     80c27d20  58 PEND       80312044 80c27c30       0     0
tWebAcc1   80232dc0     80c251c0  58 PEND       80312044 80c250d0       0     0
tWebAcc2   80232dc0     80c22660  58 PEND       80312044 80c22570       0     0
tWebAcc3   80232dc0     80c1fb00  58 PEND       80312044 80c1fa10       0     0
tWebAcc4   80232dc0     80c1cfa0  58 PEND       80312044 80c1ceb0       0     0
tWebAcc5   80232dc0     80c1a440  58 PEND       80312044 80c1a350       0     0
tWebAcc6   80232dc0     80c178e0  58 PEND       80312044 80c177f0       0     0
tWebAcc7   80232dc0     80c14d80  58 PEND       80312044 80c14c90       0     0
tNAT       80179e44     80c84560  60 PEND+T     80312044 80c84470  3d0004    44
tModule    usrModuleMai 80c6ea40  65 PEND       80312044 80c6e908      16     0
tL2tpRece  801e0728     80c4d040  75 SUSPEND    802befc4 80c4ce90       0     0
tL2tpSend  801e4790     80c4a4e0  75 SUSPEND    802befc4 80c4a448       0     0
tPptpRece  801e73dc     80c44d90  75 SUSPEND    802befc4 80c44bd0       0     0
tPptpSend  801e88a8     80c40e30  75 SUSPEND    802befc4 80c40d80       0     0
SYS_PPP_C_1801a6388     80c67f90  80 PEND       80257938 80c67ed0       0     0
tTffsPTask flPollTask   80fec750 100 READY      802c044c 80fec6b0       0     0
tAPCfg     8001b854     80c3a350 100 PEND       80312044 80c3a178       4     0
tHostapd   HostapdMain  80a3cf40 100 PEND+T     80257938 80a3cb10  3d0002    13
tUpnp      UpnpStart    80c7de10 110 PEND+T     80257938 80c7dbc0  3d0002    56
lltd2d     lltd2d       80c3c6b0 230 PEND+T     80257938 80c3c488  3d0002   552
tDcacheUpd dcacheUpd    80d5eca0 250 DELAY      802c044c 80d5ebe8       0    15
tBridgeAger80159cb0     80d4b500 250 DELAY      802c044c 80d4b468       0   550
value = 0 = 0x0



[/quote][/code]
chipwizme
DD-WRT Novice


Joined: 19 Jun 2009
Posts: 2

PostPosted: Mon May 03, 2010 14:42    Post subject: Reply with quote
I have it loading openwrt via tftp boot.
I'm using this image (it's not mine): http://wifi.ozo.com/airo/openwrt/firmware/kamikaze/2.6/ar71xx/16889-rev-reloc/openwrt-ar71xx-vmlinux-initramfs.elf

Quote:
VxWorks System Boot
CPU: WRT54G2
Creation date: Apr 16 2009, 14:56:12




Press any key to stop auto-boot...
5

[VxWorks Boot]: @

boot device : ae
unit number : 0
processor number : 0
host name : host
file name : /fl/vxWorks.bin
inet on ethernet (e) : 192.168.101.6:ffffff00
host inet (h) : 192.168.101.111
user (u) : target
flags (f) : 0x80
target name (tn) : targetname
other (o) : dp

Attaching interface lo0... done
ATHRS26: resetting s26
ATHRS26: s26 reset done
Attached IPv4 interface to ae unit 0
Loading... 4820352
Starting at 0x80064550...

Linux version 2.6.30.1 (alex@aifnis) (gcc version 4.3.3 (GCC) ) #2 Sat Jul 18 13:21:48 EEST 2009
console [early0] enabled
CPU revision is: 00019374 (MIPS 24Kc)
Atheros AR7240 rev 2, CPU:350.000 MHz, AHB:175.000 MHz, DDR:350.000 MHz
Determined physical RAM map:
memory: 01000000 @ 00000000 (usable)
Initrd not found or empty - disabling initrd
Zone PFN ranges:
Normal 0x00000000 -> 0x00001000
Movable zone start PFN for each node
early_node_map[1] active PFN ranges
0: 0x00000000 -> 0x00001000
Built 1 zonelists in Zone order, mobility grouping off. Total pages: 4064
Kernel command line: rootfstype=squashfs,yaffs,jffs2 noinitrd console=ttyS0,115200
Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
Writing ErrCtl register=00000000
Readback ErrCtl register=00000000
NR_IRQS:56
PID hash table entries: 64 (order: 6, 256 bytes)
Dentry cache hash table entries: 2048 (order: 1, 8192 bytes)
Inode-cache hash table entries: 1024 (order: 0, 4096 bytes)
Memory: 11144k/16384k available (1863k kernel code, 5240k reserved, 411k data, 2348k init, 0k highmem)
SLUB: Genslabs=7, HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
Calibrating delay loop... 232.65 BogoMIPS (lpj=1163264)
Mount-cache hash table entries: 512
net_namespace: 528 bytes
NET: Registered protocol family 16
MIPS: machine is Generic AR71xx board
bio: create slab <bio-0> at 0
NET: Registered protocol family 2
IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
TCP established hash table entries: 512 (order: 0, 4096 bytes)
TCP bind hash table entries: 512 (order: -1, 2048 bytes)
TCP: Hash tables configured (established 512 bind 512)
TCP reno registered
NET: Registered protocol family 1
squashfs: version 4.0 (2009/01/31) Phillip Lougher
Registering mini_fo version $Id$
JFFS2 version 2.2. (NAND) (SUMMARY) © 2001-2006 Red Hat, Inc.
yaffs Jul 18 2009 12:50:11 Installing.
msgmni has been set to 21
alg: No test for lzma (lzma-generic)
alg: No test for stdrng (krng)
io scheduler noop registered
io scheduler deadline registered (default)
Serial: 8250/16550 driver, 1 ports, IRQ sharing disabled
serial8250.0: ttyS0 at MMIO 0x18020000 (irq = 11) is a 16550A
console handover: boot [early0] -> real [ttyS0]
Atheros AR71xx SPI Controller driver version 0.2.3
Atheros AR71xx hardware watchdog driver version 0.1.0
TCP westwood registered
NET: Registered protocol family 17
Freeing unused kernel memory: 2348k freed
- preinit -
Press CTRL-C for failsafe

Please press Enter to activate this console. gpio-buttons driver version 0.1.1



BusyBox v1.13.4 (2009-07-18 12:30:44 EEST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

_______ ________ __
| |.-----.-----.-----.| | | |.----.| |_
| - || _ | -__| || | | || _|| _|
|_______|| __|_____|__|__||________||__| |____|
|__| W I R E L E S S F R E E D O M
KAMIKAZE (bleeding edge, r16889) -------------------
* 10 oz Vodka Shake well with ice and strain
* 10 oz Triple sec mixture into 10 shot glasses.
* 10 oz lime juice Salute!
---------------------------------------------------
root@OpenWrt:/# ls
bin etc init lib proc root sys usr www
dev home jffs mnt rom sbin tmp var
root@OpenWrt:/# ifconfig
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

root@OpenWrt:/# ifconfig -a
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
[/url]
moto
DD-WRT Novice


Joined: 29 Sep 2010
Posts: 7

PostPosted: Mon Dec 20, 2010 18:44    Post subject: jtag Reply with quote
Does anyone know if it is possible to jtag into these routers? I have tried but haven't had any luck. From what i can tell the Atheros AR7240 chip isn't supported in any of the jtag revisions. I have several of the 1.5 units that have various issues. I know they dont support dd-wrt, but i would like to fix them if possible. Thanks in advance.

M0T0
Goto page Previous  1, 2 Display posts from previous:    Page 2 of 2
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum