old httpd 100% bug back again?

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page Previous  1, 2, 3, 4, 5, 6
Author Message
redhawk0
DD-WRT Guru


Joined: 04 Jan 2007
Posts: 10882
Location: Wherever the wind blows- North America

PostPosted: Tue Nov 24, 2009 17:34    Post subject: Reply with quote
I have ssh enabled and UPnP enabled...but I only see this issue once every 4-8 weeks....so it's really hard for me to troubleshoot the problem.

I just don't know.

redhawk

_________________
I currently test dd-wrt on Asus, Buffalo, Linksys, and Netgear. Too many to list.

Looking for more test units (newer models) for the project...got a brick?...PM me to make a donation. (USA) A donation is not a debricking service....it is a way to "Give back" to the dd-wrt project.

I do NOT provide personal assistance through chat or phone....so please don't ask.
Sponsor
cybermcm
DD-WRT Novice


Joined: 18 Jun 2006
Posts: 46

PostPosted: Tue Nov 24, 2009 19:03    Post subject: Reply with quote
redhawk0 wrote:
My suspicion is that UPnP is causing this problem.

My tests showed that the httpd -S bug occurs even if the UPnP service is disabled (I don't use it).
Maybe UPnP is causing more troubles but the problem is still the bug in the HTTPS webservice with standard port 8080...
fernandodelvalle
DD-WRT Novice


Joined: 13 Dec 2009
Posts: 6

PostPosted: Thu Dec 24, 2009 13:11    Post subject: Reply with quote
I bought a DIR-600 dlink router, and used dd-wrt for 3 weeks with no trouble at all. When I configured remote access and enabled https (8080), cpu utilization went to 100%. After killing httpd -S, it came back to normal (10%). Restarting httpd -S, with standard port seems to help. I'm using DD-WRT v24-sp2 (10/10/09) std (13064)
cybermcm
DD-WRT Novice


Joined: 18 Jun 2006
Posts: 46

PostPosted: Thu Dec 24, 2009 14:29    Post subject: Reply with quote
fernandodelvalle wrote:
Restarting httpd -S, with standard port seems to help. I'm using DD-WRT v24-sp2 (10/10/09) std (13064)

I tried build 13401M with https and port 443 -> same behavior, after some time the 100% bug
cybermcm
DD-WRT Novice


Joined: 18 Jun 2006
Posts: 46

PostPosted: Sat Jan 16, 2010 8:20    Post subject: Reply with quote
follow up:
due to the fact that this issue is still unresolved I recently switched to OpenWRT.
I used DD-WRT over years but this issue is driving me nuts...
I'll come back if there is any progress because I like the web interface Wink
spadefoot
DD-WRT Novice


Joined: 16 Jan 2010
Posts: 11

PostPosted: Wed Jan 20, 2010 22:53    Post subject: Changed from port 8080 Reply with quote
Changed from port 8080 to 443 last night, so far no problems at all. Normally, it would have pegged @ 100% by now. So, the next question is, why in the heck does the port number cause a problem?
cybermcm
DD-WRT Novice


Joined: 18 Jun 2006
Posts: 46

PostPosted: Thu Jan 21, 2010 5:19    Post subject: Re: Changed from port 8080 Reply with quote
spadefoot wrote:
Changed from port 8080 to 443

I don't want to disappoint you but this helps only to make things a little bit better. I experienced the bug although I switched to 443. But the occurrence decreases after switching the port.
cybermcm
DD-WRT Novice


Joined: 18 Jun 2006
Posts: 46

PostPosted: Thu Jan 21, 2010 14:59    Post subject: Reply with quote
Magister wrote:
same problem here

I'm not sure that this is the same problem as you wrote "https disabled".
The problem I'm facing is high CPU load due to the fact that https is enabled!
Try to telnet to your router when the web interface is dead and then run "top". You will get a list of all running processes and the CPU load of each process.
cybermcm
DD-WRT Novice


Joined: 18 Jun 2006
Posts: 46

PostPosted: Thu Jan 21, 2010 16:56    Post subject: Reply with quote
Magister wrote:
can not telnet to it

This seems to be another issue because if "my https bug" hits you telnet is still available
spadefoot
DD-WRT Novice


Joined: 16 Jan 2010
Posts: 11

PostPosted: Sun Jan 24, 2010 1:24    Post subject: Re: Changed from port 8080 Reply with quote
spadefoot wrote:
Changed from port 8080 to 443 last night, so far no problems at all. Normally, it would have pegged @ 100% by now. So, the next question is, why in the heck does the port number cause a problem?


Up over 4 days without a reboot. Don't know if it's solved, or just vastly improved, but one of the two is true.

[Edit] Just checked top, looks like httpd is using about 5.4% of CPU right now, which is a little elevated. I'll keep an eye on it over the next few days and see what happens.
lightman
DD-WRT Novice


Joined: 17 Dec 2006
Posts: 29

PostPosted: Thu Jun 10, 2010 19:56    Post subject: Reply with quote
is this issue fixed in the newer build, because i want to run https on another port than 443 without causing 100% cpu load
Goto page Previous  1, 2, 3, 4, 5, 6 Display posts from previous:    Page 6 of 6
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum