My_Page

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page Previous  1, 2, 3 ... 22, 23, 24, 25  Next
Author Message
jack_90125
DD-WRT Novice


Joined: 13 Apr 2011
Posts: 21

PostPosted: Mon Apr 23, 2012 19:24    Post subject: Reply with quote
hello
well went thru everything and followed the details on this page . when I go to status and select mypage. get the blanks screen.
if I go to the address bar and enter the following:
http://192.168.1.1/MyPage.asp?12

it shows the info and I have 4 rectangles on the top of the page for mp1-4 and can click and see info but no others. If I go back to mypage it is just blank.
what did I miss or do wrong?
did the plus x chmod and chown and links and made sure all the dirs and files where there. went thru the wiki several times and read and followed page 22 here and cannot figure out what I did not do to get this to work. all files have the first line modified like was pointed out.
should it really be this difficult ?
thanks for any help.
Sponsor
rocky13
DD-WRT User


Joined: 25 Apr 2008
Posts: 124

PostPosted: Mon Apr 23, 2012 23:24    Post subject: Reply with quote
Make sure that all your mp*.sh have all #!/bin/sh at the beginning of script and also check your wrtbwmon.sh file.

Let me know, if not i'll walk you through what worked for me.
jack_90125
DD-WRT Novice


Joined: 13 Apr 2011
Posts: 21

PostPosted: Tue Apr 24, 2012 0:12    Post subject: Reply with quote
yes did all hte stuff that was specified. all *.sh files have that as the first line. they have the correct permissions,right placements links etc. on page 22 there is a walk through that I followed ,also what was in the wiki and it all looks right but no displays.
rocky13
DD-WRT User


Joined: 25 Apr 2008
Posts: 124

PostPosted: Tue Apr 24, 2012 0:57    Post subject: Reply with quote
to uninstall run this
Code:
rm -rf /tmp/www
rm -rf /opt/www/*
nvram unset mypage_scripts
nvram commit

to download and install run this
Code:
mkdir -p /opt/www/
cd /opt/www/
wget http://www.dd-wrt.com/phpBB2/files/mypage_working_v172_462.tar
tar -xvf mypage_working_v172_462.tar -C /opt/www/
dos2unix mp* my* w*
dos2unix setup/m* setup/t* setup/lang/* setup/libs/* js/* libs/* style/*
chmod -R 644 /opt/www/*
chmod -R 755 /opt/www/*.sh /opt/www/*.asp /opt/www/libs/*.sh /opt/www/js/*.js /opt/www/wrt*
chmod -R 755 /opt/www/setup/*.sh /opt/www/setup/libs/*.sh /opt/www/setup/lang/*.sh
chown root.root *
ln -s /opt/www /tmp/www
cp S85wrtbwmon /opt/etc/init.d/S85wrtbwmon
chmod 755 /opt/etc/init.d/S85wrtbwmon
ls -l /opt/etc/init.d/S85wrtbwmon
cd setup
/bin/sh mypage_setup.sh /opt/www y y y y y y y y y

reboot

wait for 6 mins

If you get a blank screen when accessing MyPage and you are running a late version of dd-wrt then you need to make the following changes.

1/ Edit /opt/www/S85wrtbwmon
Change the first line from #/bin/sh to #!/bin/sh
Create the directory /opt/etc/init.d/ if does not already exist and then copy /opt/www/S85wrtbwmon to /opt/etc/init.d/S85wrtbwmon.

2/ Edit all /opt/www/mp*.sh files and ensure that the first line of the file is #!/bin/sh. If not then add #!/bin/sh as the first line of the file.

These changes should resolve the MyPage blank screen.
reboot and wait for 6 mins.

Start-up Script: input in router gui
Code:
sleep 15
/opt/www/mypageup.sh /opt/www 10


Additional Cron Jobs (to reset counter at begining of month):
Code:
0 0 1 * * root rm /tmp/www/usage.db
0 0 1 * * root rm /tmp/usage.db

give this a shot and this is what worked for me. no problems.
jack_90125
DD-WRT Novice


Joined: 13 Apr 2011
Posts: 21

PostPosted: Tue Apr 24, 2012 14:03    Post subject: Reply with quote
hello
thanks! somehow I missed the startup script add.
sleep 15
/opt/www/mypageup.sh /opt/www 10
threw that in and all is well.
thanks for your help
jack
jokerper
DD-WRT Novice


Joined: 24 Apr 2012
Posts: 4

PostPosted: Tue Apr 24, 2012 20:42    Post subject: Some wired behavior Reply with quote
Hi, I am brand new to this forum.

But I have tried to get the files work prob. But I got a strange prob.

The MyPage site is show up under the status link and not besides it and nothing come up on the page.

Are there someone whos will help me out a little bit further.[img][/img]



router.jpg
 Description:
overview
 Filesize:  70.38 KB
 Viewed:  8799 Time(s)

router.jpg


rocky13
DD-WRT User


Joined: 25 Apr 2008
Posts: 124

PostPosted: Tue Apr 24, 2012 21:20    Post subject: Reply with quote
Follow my steps in my previous post and you should have no problems.
dragon042
DD-WRT Novice


Joined: 24 Feb 2010
Posts: 4

PostPosted: Mon Jun 04, 2012 5:58    Post subject: Reply with quote
rocky13 wrote:
to uninstall run this
Code:
rm -rf /tmp/www
rm -rf /opt/www/*
nvram unset mypage_scripts
nvram commit

to download and install run this
Code:
mkdir -p /opt/www/
cd /opt/www/
wget http://www.dd-wrt.com/phpBB2/files/mypage_working_v172_462.tar
tar -xvf mypage_working_v172_462.tar -C /opt/www/
dos2unix mp* my* w*
dos2unix setup/m* setup/t* setup/lang/* setup/libs/* js/* libs/* style/*
chmod -R 644 /opt/www/*
chmod -R 755 /opt/www/*.sh /opt/www/*.asp /opt/www/libs/*.sh /opt/www/js/*.js /opt/www/wrt*
chmod -R 755 /opt/www/setup/*.sh /opt/www/setup/libs/*.sh /opt/www/setup/lang/*.sh
chown root.root *
ln -s /opt/www /tmp/www
cp S85wrtbwmon /opt/etc/init.d/S85wrtbwmon
chmod 755 /opt/etc/init.d/S85wrtbwmon
ls -l /opt/etc/init.d/S85wrtbwmon
cd setup
/bin/sh mypage_setup.sh /opt/www y y y y y y y y y

reboot

wait for 6 mins

give this a shot and this is what worked for me. no problems.


This worked perfectly for me on my E3000!

Thank you very much!
zzeuss
DD-WRT Novice


Joined: 20 Sep 2011
Posts: 5

PostPosted: Tue Jul 31, 2012 17:36    Post subject: Reply with quote
jokerper wrote:

But I have tried to get the files work prob. But I got a strange prob.

The MyPage site is show up under the status link and not besides it and nothing come up on the page.

Are there someone whos will help me out a little bit further.[img][/img]


The fix to your issue is one page back Smile it worked for me on a E3200 build 19519

kingsmill wrote:
If you get a blank screen when accessing MyPage and you are running a late version of dd-wrt then you need to make the following changes.

1/ Edit /opt/www/S85wrtbwmon
Change the first line from #/bin/sh to #!/bin/sh
Create the directory /opt/etc/init.d/ if does not already exist and then copy /opt/www/S85wrtbwmon to /opt/etc/init.d/S85wrtbwmon.

2/ Edit all /opt/www/mp*.sh files and ensure that the first line of the file is #!/bin/sh. If not then add #!/bin/sh as the first line of the file.

These changes should resolve the MyPage blank screen.

Geoff..
luis84
DD-WRT Novice


Joined: 02 Feb 2011
Posts: 24

PostPosted: Fri Aug 10, 2012 1:25    Post subject: Reply with quote
Hello,

I run into an issue. 18xxx dd-wrt on buffalo router.

When I try to expand files to /opt/www i get, "Error: read only file system".

Same error for everything, only can write to /tmp/www but it seems those get deleted at reboot.

Any suggestions?
slobodan
DD-WRT Guru


Joined: 03 Nov 2011
Posts: 1256
Location: Zwolle

PostPosted: Fri Aug 10, 2012 14:27    Post subject: Reply with quote
luis84 wrote:
Hello,

I run into an issue. 18xxx dd-wrt on buffalo router.

When I try to expand files to /opt/www i get, "Error: read only file system".

Same error for everything, only can write to /tmp/www but it seems those get deleted at reboot.

Any suggestions?

Well, make the /opt writeable. Sometimes if you make the partitions under Linux (e.g. Ubuntu), it protects them so that only your Linux installation root user may write on them. Try reformatting the partition with PartedMagic or similar software. It has to be ext2 for USB sticks and SSDs and ext3 for real hard disks (no SSDs).

_________________
Asus RT-N16 running Merlin (latest), formerly used Kong 22000++ kingkong-nv32k-broadcom with OTRW2

E4200 V1 running Kong 22000++ kingkong-nv60k-broadcom with OTRW2

2 times Linksys WRT610N V2 converted to E3000 running Kong 22000++ usb-ftp-samba3-dlna-nv60k-broadcom with OTRW2 (bridged with LAN cable)


luis84
DD-WRT Novice


Joined: 02 Feb 2011
Posts: 24

PostPosted: Sun Aug 12, 2012 4:07    Post subject: Reply with quote
Hello,

I do not have /opt for anything, I just want to store these on my routers default internal memory.

I know it's possible because companies with VPN applets write custom my pages to my router from the web via wgetting an sh file no problem.

Where do they store them to make it work?

What path on the routers internal memory is available to store the file....

The normal paths all seem ready only
crashfly
DD-WRT Guru


Joined: 24 Feb 2009
Posts: 2025
Location: Sol System > Earth > USA > Arkansas

PostPosted: Sun Aug 12, 2012 5:44    Post subject: Reply with quote
luis84 wrote:
Hello,

I do not have /opt for anything, I just want to store these on my routers default internal memory.

I know it's possible because companies with VPN applets write custom my pages to my router from the web via wgetting an sh file no problem.

Where do they store them to make it work?

What path on the routers internal memory is available to store the file....

The normal paths all seem ready only

If that is done at every startup, then it would be stored in the "temp" directory. Most of those 'unwritable' locations have a file or directory that links back to a file or directory in the "temp" location. Certain things can be written, but when the router reboots, they are not saved. Likely those custom "my pages" are loaded with the startup script when the router boots.

_________________
E3000 22200M KongVPN K26
WRT600n v1.1 refirb mega 18767 BS K24 NEWD2 [not used]
WRT54G v2 16214 BS K24 [access point]

Try Dropbox for syncing files - get 2.5gb online for free by signing up.

Read! Peacock thread
*PLEASE* upgrade PAST v24SP1 or no support.
luis84
DD-WRT Novice


Joined: 02 Feb 2011
Posts: 24

PostPosted: Sun Aug 12, 2012 21:15    Post subject: Reply with quote
Crashfly, thank you. You gave me a brilliant idea actually.

I will just write them at every startup by throwing data into the startup command in nvram. Brilliant.
eric512
DD-WRT Novice


Joined: 19 Jun 2010
Posts: 14

PostPosted: Sun Aug 26, 2012 7:55    Post subject: blank pages Reply with quote
I have blank pages. I think its a chown problem.

I'm mounted on another drive with this startup script:
#!/bin/sh

mount --bind /tmp/smbshare/jffs /jffs
nvram set sys_enable_jffs2=1
mount --bind /tmp/smbshare/opt /opt

The permissions on my /opt are all "nobody 1000".

I can't chown the scripts, I get permission denied.

My /tmp/smbshare dir is "root 1000". I think thats the root of the problem. Everything beyond that is "noboby 1000".
Goto page Previous  1, 2, 3 ... 22, 23, 24, 25  Next Display posts from previous:    Page 23 of 25
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum