On Networks (aka Netgear) N150R /WNR612 supported?

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Author Message
DD-WRT Novice

Joined: 09 Jun 2013
Posts: 1

PostPosted: Thu Jun 13, 2013 2:04    Post subject: On Networks (aka Netgear) N150R /WNR612 supported? Reply with quote
Hi all,

I had no luck to find any previous posts regarding On Networks model N150R.

After some web reseach it seems that this is a Netgear spinoff and it is based on the WNR612 model using the chipset Atheros AR9285

Is there any current research done on the dd-wrt compatibility?
DD-WRT Novice

Joined: 18 Aug 2014
Posts: 1

PostPosted: Wed Jun 15, 2016 0:33    Post subject: On Networks N150R Firmware Reply with quote
the On Networks N150R is really re-branded a Netgear WNR612v2. However Netgear WNR2000v3 DD-WRT firmware works with it mostly since it basically the same router with only 2 LANports.

In order to see saved and applied settings I had to reboot router, but other than that its perfect. I have it working in client bridged mode A-OK.

Joined: 22 Oct 2006
Posts: 185

PostPosted: Sat Jul 02, 2016 21:55    Post subject: firmware size limitation Reply with quote
I could not get the latest one (either the .bin or .img) out of the directory for Netgear WNR2000v3 to upload. Perhaps, the filesize is now a bit larger than it was on version from June 6, 2016?
WRT54GL v1.1 - DD-WRT v24-sp2 (04/07/12) vpn-small (SVN revision 18946M NEWD Eko)
WZR-HP-AG300H - DD-WRT v3.0-r30082 std (07/01/16)

Joined: 08 Jun 2006
Posts: 124
Location: PA, USA

PostPosted: Mon Jul 04, 2016 21:44    Post subject: Reply with quote
Picked up a few of these to tinker around with. Haven't attempted flashing but hopefully will have notes to share here since this is the only N150R labeled thread I found.

In the meantime, here are the pictures of a unit I opened. My pictures are pretty near identical to what is in the PDF attachment pretzell shared except higher resolution. So I don't stretch out the forum display I've put these together in a ZIP archive. All images in this archive are licensed under the Creative Commons Attribution-Share Alike 4.0 International License.

WiFi - Atheros AR9285-AL1A
RAM - ESMT M13S2561616A-5T (32MB DDR SDRAM)
Flash - MXIC 25L3206E (4MB)

Regarding opening, in addition to the Torx screw on the bottom of the case there are two plastic clips on the bottom, two on the LED front, and three on the top seam that hold this pretty forcibly together. Once you can get the bottom two unclipped (they are towards the edges) the rest will separate without much problem. Note that you may be able to see through the vents clips holding in the board to the case, these are not related to holding the case together. Hopefully this case info saves someone from sending the board flying as I did. Sorry, I didn't grab pictures of the case and its clips.

Also interesting, the inside of the On Networks case has the "NETGEAR" name molded right into it. No question as to where this actually came from.

I assume like I've read on the WNR2000v3 that the first flash needs to be the region specific firmware (NA or WW) done via TFTP, later followed by the desired webflash firmware? I'm guessing this unit also suffers the same Netgear flash tomfoolery that limits the flash space on the WNR2000v3 to 3648KB? This would explain onix's reported issue with firmwares later than 2016-06-06.

Joined: 22 Oct 2006
Posts: 185

PostPosted: Mon Jul 04, 2016 22:10    Post subject: from a newegg review Reply with quote
This comes via Eric R, who posted on newegg.com in a review from June 16, 2016:


This review is from: On Networks N150 Wireless Router, Open Source Ready - N150R

Pros: good hardware see below instruction for software upgrade

Cons: bad stock firmware. it took a lot of research to flash this with a good firmware so that I can use a a wireless bridge repeater with wireless security.

Other Thoughts: Step 1 Read this http://kb.netgear.com/app/answers/detail/a_id/22688/~/how-to-upload-firmware-to-a-netgear-router-using-tftp

Step 2 download compatible firmwares and tftp server (windows) zip file: https://dl.dropboxusercontent.com/u/36071421/firmwares.zip

Step 3 depends on the firmware you chose. 3a id the netgear firmware, 3b is the DD-WRT firmware, and 3c is the OpenWRT and Gargoyle firmwares, not suggested unless you use openwrt-ar71xx-generic-n150r-squashfs-factory.img file for version 14 as the other versions lose their settings on reboot Sad

Step 3 a
For most people the netgear firmware is fine and easy to flash with the above tftp instructions in step 1(wnr612v2-V1.0.0.3_1.0.2.img) then you are done! ignore the rest of the steps unless you need a better firmware.

Step 3 b for DD-WRT (best firmware for this router)- I chose OnNetworksFactorytoDDwrt.img and it worked fine via TFTP server. You could probabally use web interface and use OnNetworksUpgradetoDDwrt.bin but I have not tried. Worked the first time. Remember to reboot router to see saved and applied settings.

Step 3 c OpenWRT or Gargolye: for me I had to first go to OpenWRT [Barrier Breaker (14.07)] first (openwrt-ar71xx-generic-n150r-squashfs-factory.img)
Step 4 a then you can go to OpenWRT [Chaos Calmer (15.05.01)] or(openwrt-15.05.1-ar71xx-generic-n150r-squashfs-sysupgrade.bin)
Step 4 b then you can go to gargoyle (great for repeater bridge) (gargoyle_1.9.0-ar71xx-generic-n150r-squashfs-sysupgrade.bin) I went to OpenWRT [Chaos Calmer (15.05.01)] before gargoyle but not sure if it's necessary

-----update -----
The most compatible opensource firmware that works with this router is DD-wrt for the Netgear WNR2000v3. I used version DD-WRT v3.0-r29837 std (06/06/16) which is now included in the dropbox zip above. Also version 15 of openwrt and gargoyle lose their setting on reboot. With dd-wrt I had to manually reboot the router after applying settings to see the changes (under administration tab at the bottom) but was able to successfully create a bridge in client mode that allows broadcast traffic without using wds which would be messy with mixed atheros/broadcom hardware.

WRT54GL v1.1 - DD-WRT v24-sp2 (04/07/12) vpn-small (SVN revision 18946M NEWD Eko)
WZR-HP-AG300H - DD-WRT v3.0-r30082 std (07/01/16)
DD-WRT Novice

Joined: 21 Jul 2016
Posts: 2

PostPosted: Thu Jul 21, 2016 18:19    Post subject: Hope someone can help me Reply with quote
I followed the instructions that were copy and pasted from the newegg review. I chose the dd-wrt std because I thought it was the best and I needed to set it up as a repeater at House B.

Because this was my first time doing this, I tested the setup at House A. I was successful and got it set up as a repeater at House A, went online, everything worked good.

The problem is I need to set it up at House B with a different primary router...

When I took it to House B it would not work AT ALL. I couldn't even log into it no matter how I tried. Via Ethernet cable I don't think I ever got an IP address from the DHCP (I say this because no matter how many "ipconfig /all" or "ipconfig /renew" or "ipconfig /release" It would never give me an IP address. And wirelessly, well I couldn't connect to it wirelessly because the SSID wouldn't even show up.

So I brought it back to House A, turned it on, and voila it worked flawlessly and connected online like it was never broken. I could even log into the router again!

But now, let me tell you my question/problem.

When I took it to House B (where it wouldn't even let me login) I had tried resetting it. After a while I gave up because I had other things to do. So I brought it back to House A, where it works just fine, I tried resetting it there too, like seriously 4 or 5 30-30-30 resets. THIS ROUTER WILL NOT RESET. Even when I click the button to do a factory reset under the administration tab, and click save, nothing changes. It's stuck the way I set it up to be a repeater.

I did not do the 30-30-30 reset at the very beginning before I did the flash to dd-wrt, but I didn't think it mattered once dd-wrt was up and running perfectly.

I have tried flashing it to the netgear firmware provided in the zip using the same method I used to flash it to dd-wrt, but whenever I try, I don't think the router is resetting right. By that I mean, my computer never gets an IP so it can't possibly flash right?

I read on a different thread/wiki something about flashing through windows by changing the mac to aa-bb-cc-dd--ee ... but I decided I better post here first. I really don't want to brick brick my router.

Look forward to all your questions and answers! Very Happy

Last edited by longliveddwrt on Sun Jul 24, 2016 14:25; edited 1 time in total
DD-WRT Novice

Joined: 21 Jul 2016
Posts: 2

PostPosted: Sun Jul 24, 2016 14:19    Post subject: THANKS FOR ALL YOUR QUESTIONS, IDEAS, ANSWERS ... Reply with quote
but I figured it out myself (no thanks to all the invisible replies to my question)

I've (SOLVED) my problem but I'm taking the time to write this because, before I forget about it and move on, I want to do the right thing and post the solution to my problem in case any experienced techs or noobs out there have the same problem I had with no one else to turn to, and has to google it for themselves and find this thread.

It was the DHCP all along.

I believe the reason I could never log into the repeater through Ethernet or even see the wireless SSID at House B was because, while following the instructions, DHCP had to be disabled on the repeater.

All of the resets and changes I made amounted to nothing, it was only after re-enabling DHCP at House A that I was able to log into the repeater at House B and then set it up as a repeater with the intended primary router.

And as for the multiple unsuccessful attempts at 30-30-30 resets, don't quote me on this (it may be true for all dd-wrt installs or just MINE with THIS router) but from my experience the 30-30-30 reset did not work because I didn't do the 30-30-30 reset BEFORE flashing AND I didn't save and reboot right AFTER flashing. I believe I started making changes right after and didn't save and reboot until a lot of changes were already made (which could also explain why every time I tried a 30-30-30 reset I was still stuck with the changes??)

I genuinely hope this information helps someone or a lot of someones. I would not have taken the time to write it otherwise.

ALSO (last note)
I tried the netgear firmware in hope of having less headaches. It was the s_ittiest firmware I've ever seen and I've seen some crappy firmware. The menus are not as clear/well defined as dd-wrt and worse, if you use the netgear firmware, you CANNOT configure the repeater with WPA2 AES, that is not my opinion, it is a fact.

Needless to say, I flashed back to dd-wrt and I'm happy and will not be trying any other firmware on this router.
DD-WRT Novice

Joined: 28 Jul 2016
Posts: 1

PostPosted: Thu Jul 28, 2016 14:58    Post subject: on networks n150r Reply with quote
So i got 4 of these things for free from mail in rebate program from the best parts dealer. and i am not very savy in the telnet, ssh, tftp. ect... area i know that there is better firmmware that is linked here and i will give it a try later but i am wondering if i can do what i am hoping with these. i need 2 repeaters that act in a chain or conductivly to enhance signal in my apt. i have a top of the line asus router but i have dead spots here and there. is this possible?
DD-WRT Novice

Joined: 10 May 2010
Posts: 13

PostPosted: Tue Aug 09, 2016 11:38    Post subject: Reply with quote
Is it stable?
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT


Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum