DD-WRT r29974 can't use transmission

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Author Message
Stremon
DD-WRT Novice


Joined: 25 Jun 2016
Posts: 3

PostPosted: Sat Jun 25, 2016 5:21    Post subject: DD-WRT r29974 can't use transmission Reply with quote
Hello everyone!

Recently I tried to put a bit more power in my japanese Buffalo WZR-HP-G302H, which has a very crappy japanese only firmware.

I successfully installed the r29974 build on it, and everything is working perfectly, including the USB port, the NAS, and the SSH connection. Everything is pretty working a lot better than with the default firmware Laughing

But I am unable to make transmission work. I believe I did the right configuration process in my router settings, but when I try to access to the transmission web interface (192.168.11.1:9091 for me), it just keeps giving me a "403: Forbidden" error Sad
I first searched on internet, but couldn't find any good information concerning the last builds.

I also tried to install optoware and entware, but they both give me a "read only file system" error.

Can someone give me a hand on that? Embarassed

Thanks Wink
Sponsor
jwoods
DD-WRT User


Joined: 13 Mar 2016
Posts: 403

PostPosted: Sat Jun 25, 2016 5:30    Post subject: Reply with quote
You might find some useful info in this article...

http://www.howtogeek.com/100142/how-to-install-the-transmission-bitorrent-client-on-your-router-dd-wrt/
Stremon
DD-WRT Novice


Joined: 25 Jun 2016
Posts: 3

PostPosted: Sat Jun 25, 2016 6:22    Post subject: Reply with quote
jwoods wrote:
You might find some useful info in this article...

http://www.howtogeek.com/100142/how-to-install-the-transmission-bitorrent-client-on-your-router-dd-wrt/

Thanks for your answer, I indeed already read this post, but it's outdated, the new DD-WRT already has transmission preinstalled.
And as I was stating, I can't install optoware (read only file system error).
opkg commands don't work
and transmission daemon command doesn't work either...
also I can't find the transmission config file anywhere.

I guess the transmission daemon is still working anyway since it gives me the 403 error (if it wasn't working it would give another error), I just can't access it because it's blocking me out.


Edit: I found the config.json file, when I changed the transmission directory from /mnt/sda1 to /tmp/mnt/sda1, it created the file on the root of my disk.
I was able to change the white list settings (and of course rebooted everytime to be sure to restart the daemon), but still getting the 403: Forbidden error Sad

I tried with either
"rpc-whitelist": "127.0.0.*,192.168.11.*,192.168.11.10",
"rpc-whitelist-enabled": true,
or
"rpc-whitelist": "*.*.*.*",
"rpc-whitelist-enabled": true,

And nothing seems to work.


Edit2: apparently transmission doesn't care about the config file, and keeps resetting it, putting back the default settings...
js1662
DD-WRT Guru


Joined: 23 Jul 2014
Posts: 1154
Location: BC, CA

PostPosted: Sat Jun 25, 2016 7:05    Post subject: Reply with quote
Entware is for Broadcom based routers if I am not wrong so it is not suitable for your router. As for Optware, there is a very good guide for Atheros routers: http://www.dd-wrt.com/phpBB2/viewtopic.php?t=177532

I have never used transmission so I can't give you much suggestion on that but you should be able to find some information on transmission including setup on the above guide. May be you can use it as a reference for your transmission setup.
Stremon
DD-WRT Novice


Joined: 25 Jun 2016
Posts: 3

PostPosted: Sat Jun 25, 2016 12:17    Post subject: Reply with quote
js1662 wrote:
Entware is for Broadcom based routers if I am not wrong so it is not suitable for your router. As for Optware, there is a very good guide for Atheros routers: http://www.dd-wrt.com/phpBB2/viewtopic.php?t=177532

I have never used transmission so I can't give you much suggestion on that but you should be able to find some information on transmission including setup on the above guide. May be you can use it as a reference for your transmission setup.

Ah that seems to be a very nice and well explained tutorial, I will give it a try, thanks! Wink
nemoti
DD-WRT Novice


Joined: 02 Aug 2016
Posts: 3

PostPosted: Tue Aug 02, 2016 13:53    Post subject: same problem - no solution Reply with quote
Stremon wrote:
jwoods wrote:
You might find some useful info in this article...

http://www.howtogeek.com/100142/how-to-install-the-transmission-bitorrent-client-on-your-router-dd-wrt/

Thanks for your answer, I indeed already read this post, but it's outdated, the new DD-WRT already has transmission preinstalled.
And as I was stating, I can't install optoware (read only file system error).
opkg commands don't work
and transmission daemon command doesn't work either...
also I can't find the transmission config file anywhere.

I guess the transmission daemon is still working anyway since it gives me the 403 error (if it wasn't working it would give another error), I just can't access it because it's blocking me out.


Edit: I found the config.json file, when I changed the transmission directory from /mnt/sda1 to /tmp/mnt/sda1, it created the file on the root of my disk.
I was able to change the white list settings (and of course rebooted everytime to be sure to restart the daemon), but still getting the 403: Forbidden error Sad

I tried with either
"rpc-whitelist": "127.0.0.*,192.168.11.*,192.168.11.10",
"rpc-whitelist-enabled": true,
or
"rpc-whitelist": "*.*.*.*",
"rpc-whitelist-enabled": true,

And nothing seems to work.


Edit2: apparently transmission doesn't care about the config file, and keeps resetting it, putting back the default settings...


Have NetGear WNDR4300 v1 with DD-WRT r29974. Same problem with transmission: 403 error (Unauthorized IP Address) on web page, can't find solution.
Transmission is enabled in my attached usb hdd. DD-WRT created there 'settings.json' file too. I modified this file with correct settings (rpc-whitelist, download dir, etc), but in case transmission would take them, I need restart this app. I make router reboot, and after that goes default settings in config file and 403 error remains. Maybe there is command to reload settings without router rebouting? Is there better solution?
nemoti
DD-WRT Novice


Joined: 02 Aug 2016
Posts: 3

PostPosted: Wed Jan 25, 2017 9:57    Post subject: Found solution Reply with quote
In my router transmission now works. Solution was upgrade to newer firmware version, where it works.
My steps:
1. Upgraded to version r30731
2. Enabled transmission with written full directory to attached usb device
3. ddwrt created 'settings.json' file there. Modified with correct setting and everything works now Smile
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum