IPv6 updated instructions and scripts for v24

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8  Next
Author Message
Diosbejgli
DD-WRT Novice


Joined: 23 Aug 2008
Posts: 30

PostPosted: Sun Apr 04, 2010 15:55    Post subject: Reply with quote
fastest963, could you please compile the ip6tables and its related kernel modules for version 2.4.37 ?
please refer to http://www.dd-wrt.com/phpBB2/viewtopic.php?t=61183
Sponsor
Deckard_9732
DD-WRT User


Joined: 17 Jun 2009
Posts: 56
Location: Redding, CA.

PostPosted: Sun Apr 04, 2010 18:59    Post subject: IPv6 6to4 Tunnel not working with PPPoE connection? (UPDATE) Reply with quote
I just switched providers to a PPPoE from a Static DHCP due to cost cutting. My IPv6 was working with 13577. I am using 13972 NEWD std_nokaid_usb and here are my scripts.

This is the error that I am getting which is not allowing the 6to4 tunnel to set up.

[Apr 04 11:49:15] radvd: ioctl(SIOCGIFADDR) failed for vlan2: Cannot assign requested address
[Apr 04 11:49:15] radvd: interface vlan2 has no IPv4 addresses, disabling 6to4 prefix.

Radvd

interface br0 {
MinRtrAdvInterval 3;
MaxRtrAdvInterval 10;
AdvLinkMTU 1492;
AdvSendAdvert on;
prefix 0:0:0:1::/64 {
AdvOnLink on;
AdvAutonomous on;
AdvValidLifetime 86400;
AdvPreferredLifetime 86400;
Base6to4Interface vlan2;
AdvRouterAddr on;
};
};

Startup

insmod /lib/modules/2.4.37/ipv6.o
sleep 5
radvd -C /tmp/radvd.conf start
sleep 5
WANIP=$(ip -4 addr show dev vlan2 | grep 'inet' | awk '{print $2}' | cut -d/ -f1)
if [ -n "$WANIP" ]
then
V6PREFIX=$(printf '2002:%02x%02x:%02x%02x' $(echo $WANIP | tr . ' '))
ip tunnel add tun6to4 mode sit ttl 64 remote any local $WANIP
ip link set dev tun6to4 up
ip link set mtu 1492 dev tun6to4
ip -6 addr add $V6PREFIX:0::1/16 dev tun6to4
ip -6 route add 2000::/3 via ::192.88.99.1 dev tun6to4
ip -6 addr add $V6PREFIX:1::1/64 dev br0
kill -HUP $(cat /var/run/radvd.pid)
fi
radvd -C /tmp/radvd.conf start

_________________
DD-WRT is Awesome!

bs 15962 K2.6 NEWD2 Mega on E2000 v1.0 (5 GHz AP)
bs 15962 K2.6 NEWD2 Std on E2000 v1.0 (5 GHz CB)
bs 15962 K2.6 NEWD2 Std on E2000 v1.0 (2.4 GHz WAP)
Diosbejgli
DD-WRT Novice


Joined: 23 Aug 2008
Posts: 30

PostPosted: Sun Apr 04, 2010 19:06    Post subject: Reply with quote
Deckard_9732, if you haven't touched your vlan configurations, the WAN interface is vlan1 instead of vlan2. Probably this causes the problem. You can check it by telnetting/ssh-ing to the router and issue "ifconfig" to see which vlan interface has your internet IP address. Modify your IPv6 script and radvd config according to this.
Deckard_9732
DD-WRT User


Joined: 17 Jun 2009
Posts: 56
Location: Redding, CA.

PostPosted: Sun Apr 04, 2010 20:48    Post subject: IPv6 6to4 Tunnel not working with PPPoE? (UPDATE #2) Reply with quote
Diosbejgli wrote:
Deckard_9732, if you haven't touched your vlan configurations, the WAN interface is vlan1 instead of vlan2. Probably this causes the problem. You can check it by telnetting/ssh-ing to the router and issue "ifconfig" to see which vlan interface has your internet IP address. Modify your IPv6 script and radvd config according to this.


I ssh'd the router with 'ifconfig' and determined that "ppp0" was the ipv4 address. I changed it in the radvd config script and it is now loading:

RADVD

interface br0 {
MinRtrAdvInterval 3;
MaxRtrAdvInterval 10;
AdvLinkMTU 1492;
AdvSendAdvert on;
prefix 0:0:0:1::/64 {
AdvOnLink on;
AdvAutonomous on;
AdvValidLifetime 86400;
AdvPreferredLifetime 86400;
Base6to4Interface ppp0;
AdvRouterAddr on;
};
};

My startup script still will not load with any interface - vlan1, vlan2 or ppp0

_________________
DD-WRT is Awesome!

bs 15962 K2.6 NEWD2 Mega on E2000 v1.0 (5 GHz AP)
bs 15962 K2.6 NEWD2 Std on E2000 v1.0 (5 GHz CB)
bs 15962 K2.6 NEWD2 Std on E2000 v1.0 (2.4 GHz WAP)
Diosbejgli
DD-WRT Novice


Joined: 23 Aug 2008
Posts: 30

PostPosted: Sun Apr 04, 2010 20:57    Post subject: Reply with quote
Also change the "vlan2" to "ppp0" in your 6to4 tunnel config you mentioned in your previous post.
"WANIP=$(ip -4 addr show dev vlan2 ..."
Deckard_9732
DD-WRT User


Joined: 17 Jun 2009
Posts: 56
Location: Redding, CA.

PostPosted: Sun Apr 04, 2010 21:51    Post subject: Reply with quote
Diosbejgli wrote:
Also change the "vlan2" to "ppp0" in your 6to4 tunnel config you mentioned in your previous post.
"WANIP=$(ip -4 addr show dev vlan2 ..."


I tried ppp0, vlan1 & vlan2 with no success Question

Something is causing the startup script to fail?

Thanks for your help and maybe someone has the solution.....

_________________
DD-WRT is Awesome!

bs 15962 K2.6 NEWD2 Mega on E2000 v1.0 (5 GHz AP)
bs 15962 K2.6 NEWD2 Std on E2000 v1.0 (5 GHz CB)
bs 15962 K2.6 NEWD2 Std on E2000 v1.0 (2.4 GHz WAP)
Diosbejgli
DD-WRT Novice


Joined: 23 Aug 2008
Posts: 30

PostPosted: Sun Apr 04, 2010 22:10    Post subject: Reply with quote
you could try logging in to the router through telnet or ssh and issue those commands line by line to see where it fails to proceed.
fastest963
DD-WRT Novice


Joined: 02 Mar 2008
Posts: 28

PostPosted: Sun Apr 04, 2010 23:30    Post subject: Reply with quote
Diosbejgli wrote:
you could try logging in to the router through telnet or ssh and issue those commands line by line to see where it fails to proceed.


You might want to just copy line by line from the startup script into your SSH terminal and see what fails where. If you could paste the output from the following commands:

Code:
ip -4 addr show

Code:
ifconfig

Code:
ip -6 route show

Code:
ip -6 addr show


I also want you to try to comment out the Base6to4Interface line. The routes should do the work for you.

Thanks,
fastest963
fastest963
DD-WRT Novice


Joined: 02 Mar 2008
Posts: 28

PostPosted: Sun Apr 04, 2010 23:35    Post subject: Reply with quote
Diosbejgli wrote:
fastest963, could you please compile the ip6tables and its related kernel modules for version 2.4.37 ?
please refer to http://www.dd-wrt.com/phpBB2/viewtopic.php?t=61183


I'll try to get those built tonight. Before doing so, I will test out forcing insmod to load the ones from http://downloads.openwrt.org/kamikaze/8.09.2/brcm-2.4/packages/ as there shouldn't be that much of a difference.

If you want to test it out as well:

insmod -f /jffs/lib/modules/2.4.35.4/ip6_tables.o
insmod -f /jffs/lib/modules/2.4.35.4/ip6table_filter.o
insmod -f /jffs/lib/modules/2.4.35.4/ip6t_multiport.o

I know that force doesn't work in K26 but it might in 2.4.

Thanks,
fastest963
fastest963
DD-WRT Novice


Joined: 02 Mar 2008
Posts: 28

PostPosted: Mon Apr 05, 2010 0:22    Post subject: Reply with quote
I just tested and the 2.4.35.4 modules worked fine in 2.4.37.
Diosbejgli
DD-WRT Novice


Joined: 23 Aug 2008
Posts: 30

PostPosted: Mon Apr 05, 2010 0:36    Post subject: Reply with quote
Thank you, I will try them.
Diosbejgli
DD-WRT Novice


Joined: 23 Aug 2008
Posts: 30

PostPosted: Fri Apr 09, 2010 22:08    Post subject: Reply with quote
I've tried installing the ip6tables and its modules using ipkg packages from downloads.openwrt.org.

Firstly I tried with http://downloads.openwrt.org/kamikaze/8.09.2/brcm-2.4/packages/ but after successfully installing both kmod and ip6tables packages the ip6tables command was not found.

Unpacking ip6tables...Done.
Configuring ip6tables...Done.
# ip6tables
-sh: ip6tables: not found

I cleared the jffs partition and tried with http://downloads.openwrt.org/backfire/10.03-rc3/brcm-2.4/packages/ but now it says a lib is missing.

# ip6tables
ip6tables: can't load library 'libip6tc.so.0'

Loading the ip6_tables and ip6table_filter modules did not help in either cases.

If someone have any ideas please share. Thanks.
fastest963
DD-WRT Novice


Joined: 02 Mar 2008
Posts: 28

PostPosted: Fri Apr 09, 2010 22:28    Post subject: Reply with quote
Diosbejgli wrote:

-sh: ip6tables: not found


Be sure you set your PATH correctly. See the original post.
Diosbejgli
DD-WRT Novice


Joined: 23 Aug 2008
Posts: 30

PostPosted: Fri Apr 09, 2010 22:32    Post subject: Reply with quote
of course I know about PATH and I also did a find / -name '*ip6tables*' and it couldn't find any executables anywhere.
there wasn't even a /jffs/usr/sbin folder with the first version.
fastest963
DD-WRT Novice


Joined: 02 Mar 2008
Posts: 28

PostPosted: Fri Apr 09, 2010 22:45    Post subject: Reply with quote
Diosbejgli wrote:
of course I know about PATH and I also did a find / -name '*ip6tables*' and it couldn't find any executables anywhere.
there wasn't even a /jffs/usr/sbin folder with the first version.


Are you using the "-d root" in ipkg when installing? What kernel do you have?
Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8  Next Display posts from previous:    Page 2 of 8
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum