LAN port troubles on WHR-HP-G300N

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Author Message
blackeye1
DD-WRT Novice


Joined: 30 Jan 2015
Posts: 1

PostPosted: Fri Jan 30, 2015 16:50    Post subject: LAN port troubles on WHR-HP-G300N Reply with quote
I have a WHR-HP-G300N that I'm just using as a basic switch and wireless access point. I've been running the vendor supplied firmware (r19154) for a few years without issue. The wireless switch is connected via a LAN port to another gigabit switch and I never had issues communicating on machines between switches. The gigabit switch is then connected to a firewall that is a DHCP server and internet gateway.

Now I wanted to update to the latest firmware on the wireless router to see if it would fix the issue with the latest versions of Firefox not being able to connect via HTTPS to the web interface. I downloaded the latest firmware I could find (ftp://ftp.dd-wrt.com/betas/2015/01-29-2015-r26081/buffalo_whr_hp_g300n/whr-hp-g300n-firmware-MULTI.bin) and flashed it onto the wireless router without issue. I did a factory reset of the settings and setup the basics like router IP and wireless info. All other settings were intially left alone.

At first, everything seemed fine. Wireless devices could connect and get out to the internet and connect to other wired machines on the gigabit switch. Wired machines on the gigabit switch can connect to wireless devices. What isn't working is communication between the wired LAN ports on the wireless router. If I plug a machine into one of the ports, it will not receive a DHCP address. If I try to statically assign an address, then ping from another machine on the gigabit switch I receive "Destination host unreachable." Now what's weird is if I reboot the router, there are a few seconds were the ping will actually respond. I guess there's some service that is being stopped then that is was previously causing the failure.

I've reset to factory defaults several times, and I've tried to enable/disable various settings like the Gateway/Router mode, SPI, and STP, but nothing I've tried has gotten the LAN ports to work correctly. I also tried the firmware released a few days prior to the one I downloaded. That didn't work either.

I just want the LAN ports to behave as a basic switch. It was working fine with older firmware. How do I accomplish this with the latest firmware?

edit
Apparently this is a known issue that hasn't been resolved in the firmware yet. I ran the following commands and added them to startup, and the LAN ports seem to work as expected now.

swconfig dev eth1 set enable_vlan 1
swconfig dev eth1 set apply
Sponsor
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum