TP Link WR841ND v8 webrevert brick and some questions

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Author Message
DD-WRT Novice

Joined: 13 Nov 2014
Posts: 1

PostPosted: Thu Nov 13, 2014 13:58    Post subject: TP Link WR841ND v8 webrevert brick and some questions Reply with quote
note: this got a little long, read the tldrs and the questions pls Smile

The story :

(tldr: 2 year old router fails to get address via DHCP and random connectivity loses)

I had my router for about 2 years and it worked fine except the fact that most of the time it failed to get the internet settings via DHCP from my ISP so i had to enter them manually which wasn't a problem (Note: plugging the cable directly into pc always worked instantly, even with DHCP).

Starting with a few months ago the router would ocassionally lose connectivity to the internet (as in, no pings were working, even to the ISP gateway) but it would solve itself after a brief shutdown (sometimes 5 mins, sometimes over night), again, plugging the cable directly into the PC didn't have any problems.

A few weeks ago I switched to DD-WRT firmware, and it worked flawless for a week, then I had to use manual settings again, because DHCP won't get my IP, it just showed on WAN (mac cloning was enabled, as my ip is tied to my mac).

What happened?

(tldr: put dd wrt, same problems, tried to get back to stock)

Last week my ISP plugged my internet cable because, they said, my router blocked their network, then they changed my cable (it was melted a bit as there was some renovation going on the top of the building) and they told me to reset and/or upgrade my router firmware.

So I checked the TP-Link website and there was a new version released so I tried to update it with the web interface, it installed, but after refresh it was still the DD WRT version.

The bricking:

(tldr: currently: all leds - except power - blink every 2-3 s)

After a bit of googleing i found the webrevert file and put it into the firmware update, it installed, then it said rebooting, and it started to countdown from 300 seconds (i don't remember exactly if i waited the full 300) and I unplugged the ethernet cable connecting my pc to my router and plugged the internet one into the pc to google for solutions, at this point i realised that the leds were all blinking (every 2-3s) except the first one, which stayed up, so i unplugged the power cable hopeing a restart will help (silly me) and nothing changed, still leds blinking.

So I'm guessing the blinking leds mean that the router is bricked and it restarts itself every 2 seconds, in the windows's Adapter settings view, i see that the network's icon changes every 2-3 seconds from Cable unplugged to Cable Connected, but it stays like that for too little time to even click it.

The questions:

(tldr: ha!, read them!)

1. Is there any way to recover from this without a special cable? - maybe via the ethernet one via telnet or something?
My sister wants to have internet asap so ordering a new cable from ebay is kind of out of the question, I'll probably buy a new router if I can't fix it by tomorrow or something. - If it isn't and I need a nokia ca42 data cable, can someone link a good tutorial for unbricking (i don't just want to throw the router away, even if i get a new one)

2. What did i do wrong? should i have waited 30 mins or so without touching the router in any way? Or was i not supposed to go back to stock firmware?

3. Any ideea why the DHCP didn't get the settings? faulty hardware?

4. What router do you recommend me i should get? Is there any real difference between, let's say WR841nd and WR743nd, I can't find any difference in the product specifications. The only things (i think) i need are 2x100mbps ports and decent wifi signal (this router had enough power for my needs, i only connect phone/tablet on wifi, laptop stayed on wired 90% of the time - as it mostly stayes on a table in another room).
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT


Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum