stop-dns-rebind

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> General Questions
Goto page 1, 2  Next
Author Message
ddfs
DD-WRT Novice


Joined: 17 Aug 2010
Posts: 5

PostPosted: Sun Sep 05, 2010 16:54    Post subject: stop-dns-rebind Reply with quote
Currently I can't access any xxxxx.LAN in my local ISP network. (IP's are: 10.x.x.x)
I know this happens because of that annoying option in the dnsmasq.conf.
Is there any way to disable stop-dns-rebind ?
Sponsor
Sash
DD-WRT Guru


Joined: 20 Sep 2006
Posts: 17627
Location: Hesse/Germany

PostPosted: Tue Sep 07, 2010 10:01    Post subject: Reply with quote
install the latest beta and disable it from the gui!
_________________
Forum Guidelines...How to get help
&
Forum Rules
&
RTFM/STFW
&
Throw some buzzwords into the WIKI search Exclamation
_________________
I'm NOT rude, just offer pure facts!
_________________
Atheros (TP-Link & Clones, etc ) debrick service in EU
_________________
Guide on HowTo be Safe, Secure and Protect Your Online Anonymity!
buddee
DD-WRT Guru


Joined: 06 Feb 2010
Posts: 7396
Location: Little Rock

PostPosted: Tue Sep 07, 2010 11:21    Post subject: Reply with quote
The latest beta on the ftp is 14929, The latest beta on the web site is 14896, neither of which have a GUI entry to disable this option.
_________________
Wireless N Config | Linking Routers | DD-WRT Wiki | DD-WRT Builds | Peacock - Broadcom FAQ

Having problems with port forwarding? Check out Port Forward Troubleshooting for more info.
ptruman
DD-WRT User


Joined: 14 May 2008
Posts: 155

PostPosted: Tue Sep 07, 2010 12:57    Post subject: Reply with quote
As a temp solution, try shelling into the router and edit /tmp/dnsmasq.conf - remove the stop-dns-rebind lines, and kill/restart the dnsmasq process. It won't survive a reboot though.
Sash
DD-WRT Guru


Joined: 20 Sep 2006
Posts: 17627
Location: Hesse/Germany

PostPosted: Tue Sep 07, 2010 15:58    Post subject: Reply with quote
then the next release will have it.
_________________
Forum Guidelines...How to get help
&
Forum Rules
&
RTFM/STFW
&
Throw some buzzwords into the WIKI search Exclamation
_________________
I'm NOT rude, just offer pure facts!
_________________
Atheros (TP-Link & Clones, etc ) debrick service in EU
_________________
Guide on HowTo be Safe, Secure and Protect Your Online Anonymity!
buddee
DD-WRT Guru


Joined: 06 Feb 2010
Posts: 7396
Location: Little Rock

PostPosted: Tue Sep 07, 2010 22:26    Post subject: Reply with quote
That or just roll back to an older build that doesn't have that in there.
_________________
Wireless N Config | Linking Routers | DD-WRT Wiki | DD-WRT Builds | Peacock - Broadcom FAQ

Having problems with port forwarding? Check out Port Forward Troubleshooting for more info.
Brian Cunnie
DD-WRT Novice


Joined: 27 Sep 2010
Posts: 3

PostPosted: Tue Oct 05, 2010 18:38    Post subject: Reply with quote
Yes, this has caused a bit of a problem for me, too; the employees here connect to an open dd-wrt wireless router, and then use OpenVPN to connect to our internal network (10.22.0.0/22). And none of the names resolve because stop-dns-rebind is silently omitting those DNS entries.

I vote for not making stop-dns-rebind the default option.

--Brian
buddee
DD-WRT Guru


Joined: 06 Feb 2010
Posts: 7396
Location: Little Rock

PostPosted: Wed Oct 06, 2010 1:33    Post subject: Reply with quote
Brian Cunnie wrote:
Yes, this has caused a bit of a problem for me, too; the employees here connect to an open dd-wrt wireless router, and then use OpenVPN to connect to our internal network (10.22.0.0/22). And none of the names resolve because stop-dns-rebind is silently omitting those DNS entries.

I vote for not making stop-dns-rebind the default option.

--Brian


By now, a few different builds have been released, which allow you to turn it off or on. I would suggest upgrading to a newer one and just disable it if you do not need it.

_________________
Wireless N Config | Linking Routers | DD-WRT Wiki | DD-WRT Builds | Peacock - Broadcom FAQ

Having problems with port forwarding? Check out Port Forward Troubleshooting for more info.
mac_7
DD-WRT Novice


Joined: 15 Dec 2006
Posts: 8

PostPosted: Sun Nov 07, 2010 8:59    Post subject: Reply with quote
change the default to stop-dns-rebind is not a good idea
it cost me an hour to figure out whats wrong
many people use internal names for proxy,tv,test.etc
there may be a security issue but loosing internal names sucks
I'm voting to disable this as default as well
melaraj
DD-WRT Novice


Joined: 11 Nov 2010
Posts: 7

PostPosted: Thu Nov 11, 2010 18:27    Post subject: Reply with quote
you can fix this issue in a very simple way.

place this script snippet in any of your .wanup scripts
Code:

sed -i 's/stop-dns-rebind//g' /tmp/dnsmasq.conf
killall dnsmasq
dnsmasq --conf-file=/tmp/dnsmasq.conf
Luniz2k1
DD-WRT Guru


Joined: 04 Oct 2007
Posts: 1255
Location: Ohio USA

PostPosted: Thu Nov 11, 2010 19:04    Post subject: Reply with quote
Or go to the Services -> Services tab and disable the "No DNS Rebind" option.
_________________
(05/02/17) std - 31924
Linksys WRT400N
Buffalo WHR-G300N

Got OpenDNS?
melaraj
DD-WRT Novice


Joined: 11 Nov 2010
Posts: 7

PostPosted: Fri Nov 12, 2010 0:13    Post subject: Reply with quote
I don't have such option. I have a buffalo router and came with build number 14998. Which build do you have?
buddee
DD-WRT Guru


Joined: 06 Feb 2010
Posts: 7396
Location: Little Rock

PostPosted: Fri Nov 12, 2010 1:51    Post subject: Reply with quote
melaraj wrote:
I don't have such option. I have a buffalo router and came with build number 14998. Which build do you have?


Does it not say in Luniz signature?

_________________
Wireless N Config | Linking Routers | DD-WRT Wiki | DD-WRT Builds | Peacock - Broadcom FAQ

Having problems with port forwarding? Check out Port Forward Troubleshooting for more info.
epaulsen5
DD-WRT Novice


Joined: 25 Nov 2010
Posts: 3

PostPosted: Thu Nov 25, 2010 15:09    Post subject: Buffalo WZR-HP-G300NH Build 14998 Reverted to 14896 Reply with quote
I think this thread has my issue but I'm unclear on the solution. I have a Buffalo WZR-HP-G300NH that I flashed with Buffalo's branded version of DD-WRT to 14998. I was having issues with the PPTP client and DNSMasq for my remote LAN. I then flashed with the DD-WRT std version for Buffalo (14896). Still the same problem. The PPTP connection is up, IP connections to remote LAN work, but not FQDN. My LAN is 192.x.x.x and the remote is 10.x.x.x.

To test this, I've removed the stop-dns-rebind from /tmp/dnsmasq.conf and tried killall dnsmasq and then launched it again. It works fine now, so this is definitely the issue.

I'd like to switch to a build with the option to disable this, but I can no longer flash the router. I tried to use the Buffalo 1.76 build and that failed. I tried the Buffalo branded DD-WRT and that failed. Any other builds I could try?
buddee
DD-WRT Guru


Joined: 06 Feb 2010
Posts: 7396
Location: Little Rock

PostPosted: Thu Nov 25, 2010 20:02    Post subject: Reply with quote
I would have to ask this though, if your saying you can no longer flash the router, how would you try any other builds if you can no longer flash the router?
_________________
Wireless N Config | Linking Routers | DD-WRT Wiki | DD-WRT Builds | Peacock - Broadcom FAQ

Having problems with port forwarding? Check out Port Forward Troubleshooting for more info.
Goto page 1, 2  Next Display posts from previous:    Page 1 of 2
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> General Questions All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum