TP-Link WR-1043ND DD-WRT going in unsaved mode

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Author Message
pitti17
DD-WRT Novice


Joined: 20 Sep 2010
Posts: 16

PostPosted: Mon Sep 20, 2010 8:25    Post subject: TP-Link WR-1043ND DD-WRT going in unsaved mode Reply with quote
Hello board,

i got two TP-Link WR-1043ND.
I flash it with DD-WRT V24 pre SP2 Build 14896.
Then with telnet mtd -r erase nvram.
Everything was working well.

Then I configured the tl-wr1043nd to work with radius server in setting /wlan/wlan-Sevurity for security-modus "WPA2 Enterprise"
wpa-algorithmus "AES"
with correct radius server port ip
with correct radius auth shared secret.

Then i do a save setting and apply setting immidiately.

Radius server setup with same security parameter.

The import on my Windows 7 laptop tof the ca.der in was ok. After connection to the wlan-network the radius server accepted my logon and working was ok.

But now the problem:

After power off/on of the tl-wr1043nd the connection to the wlan was going to unsave mode (no wpa2-enterprise mode).
That means, the tl-wr1043nd save-setting mode is not working ok.

I tried this very often.

More infomation: 11:25
after power off/on there is no ath0_hostap.conf in /tmp.
Only when i do a apply setting the atho_hostap.conf is visible and the save mode (wpa2-enterprise mode) is running.!!

More information: 11:44
after power off/onthere is no file ath0_hostap.pid in /tmp/var/run
that means there is no deamon "hostapd" running.


Please help

pitti17
Sponsor
pitti17
DD-WRT Novice


Joined: 20 Sep 2010
Posts: 16

PostPosted: Wed Sep 22, 2010 11:11    Post subject: Reply with quote
Hello,

it seems that the "hostapd" deamon is only working, after i pressed the "apply setting immidiately".

Is there any temporäre possiblity to start the deamon per script after logoff/logon, whithout firmware update in the future?
It should be permanent, probably in the nvram, until this error is fixed in the firmware.

In administration/diagnose "hostapd -B /tmp/ath0_hostap.conf" command is not working correctly, that means the deamon will not start.

Thanks in advance pitti17
pitti17
DD-WRT Novice


Joined: 20 Sep 2010
Posts: 16

PostPosted: Mon Sep 27, 2010 9:07    Post subject: Reply with quote
Because of our unsaved dd-wrt TL-wr1043nd situation,
i tried this today:

1. PowerOn TL-WR1043ND
2. Go in DD-WRT Webinterface
3. Wlan/Wlan-Security
Security WPA2 Enterprise/AES/Radius was configured
Pressed "apply setting immediately"
only then is wpa2 on wr1043nd enabled
(not after power on, because the hostapd was not running)
4. enable in dd-wrt administration/management "jffs2" support
5. mkdir /jffs/etc/config
6. cp /tmp/ath0_hostap.conf /jffs/etc/config/ath0_hoatap.conf
7. make rc_startup /jffs/etc/config/startup.if
8. new File /jffs/etc/config/startup.if
#/bin/sh
/usr/sbin/hostapd -B /jffs/etc/config/ath0_hostap.conf
9. make the file executable chmod 700 startup.if

After power off/on this file should be executed, but it will not, why?

When i do execute the script manually, i got error: socket[PF_INET6,SOCK_DGRAM]: Address family not supported by protocol", but the dd-wrt is going in save mode.

How can i set the ath0 with power on accurat?

Thanks in advance
Pitti17
pitti17
DD-WRT Novice


Joined: 20 Sep 2010
Posts: 16

PostPosted: Tue Sep 28, 2010 10:04    Post subject: Reply with quote
I inserted in Pos 8. the sleep 30

8. new File /jffs/etc/config/startup.if
#/bin/sh
sleep 30
/usr/sbin/hostapd -B /jffs/etc/config/ath0_hostap.conf

After this change the WR1043ND is going first in "unsave mode" and after 30 sec in wpa2 Mode.

That should be a circumvention for a short time.

But the "hostapd" should be start permanent at power on after the button "save" and "apply setting immediatly" is pressed. Thats my opinion.

I think it must be change in the firmware

Tkanks in advance
pitti17
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum