dd-wrt - Bandwidth Usage Monitor

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page Previous  1, 2, 3 ... 29, 30, 31 ... 40, 41, 42  Next
Author Message
ArnelCousins
DD-WRT Novice


Joined: 02 Feb 2012
Posts: 1

PostPosted: Thu Feb 02, 2012 2:11    Post subject: Reply with quote
better use v1.2 html.

---------------
now showing movies
Sponsor
MrMan606
DD-WRT Novice


Joined: 29 Feb 2012
Posts: 6

PostPosted: Wed Feb 29, 2012 5:15    Post subject: Reply with quote
Thanks .. Very nice tool .. worked very well and easy setup. Just have a quick question about the html display .. I have a different display than what appear in the first page of this post .. e.g. Daily breakdown .. I have DAYS(COLUMNS) and USERS(ROWS)not like the picture posted which is the other way around .. also no totals .. any advise as why?

Thanks a lot!

Using DD-wrt v24-sp2 MEGA and diplaying on IE v9
MrMan606
DD-WRT Novice


Joined: 29 Feb 2012
Posts: 6

PostPosted: Tue Mar 06, 2012 18:31    Post subject: Reply with quote
Oh .. will answer my own question .. I see you changing this layout in 1.2 version of the html .. nice.

have another issue though .. script is working very well and all things in order .. however, i had couple of incidents that the script is reporting a big download for one user/ip .. but when compared with the total daily bandwidth usage on the router web page and also on my internet provider usage .. these big download values do not match. For example, today one user/ip reported 4.5GB download in the script while daily usage on router/provider is 3.1GB

any ideas ??

Thanks a lot
ltek
DD-WRT Novice


Joined: 26 May 2011
Posts: 16

PostPosted: Tue Mar 06, 2012 22:17    Post subject: Is there a "setup for dummies"? Reply with quote
Is there a step-by-step setup for thos eos us not well acquainted with Linux and/or DD-WRT inter-workings?

thanks
MrMan606
DD-WRT Novice


Joined: 29 Feb 2012
Posts: 6

PostPosted: Wed Mar 07, 2012 4:32    Post subject: Reply with quote
not the owner of the thread .. just a user .. but here is the link to wiki page with the setup
http://code.google.com/p/lal-projects/w/list

Regards,,
basmaf
DD-WRT Guru


Joined: 24 Feb 2011
Posts: 1043

PostPosted: Tue Mar 13, 2012 14:43    Post subject: Reply with quote
barryware wrote:
All the files exist.. All are being populated. The only problem is that the html page is not reading the data. The .js file is in the same folder as the html file and has fresh data in it..


Guys could you please give me some pointers.
have the same issue as barryware has/had?

page is is shown in mypage but no data...

E4200 with OTRW/Mypage installed .
S99bwmon & K99bwmon as startup/shutdown scripts in /opt/etc/init.d/
monitor.html & user_details in /www/user/ symlinked to /opt/www

Script is running, data is updated in mac_usage.
user_details.js has data about mac add i have in my config file.

But still the there is no data shown in webpage.

What am i missing?
MrMan606
DD-WRT Novice


Joined: 29 Feb 2012
Posts: 6

PostPosted: Tue Mar 13, 2012 22:39    Post subject: Reply with quote
I have it working ok on mine .. both monitor.html and user_details.js are located in /tmp/www

Then access it from here (change ip to your router) http://192.168.1.1/user/monitor.html

Try it and see it it helps
basmaf
DD-WRT Guru


Joined: 24 Feb 2011
Posts: 1043

PostPosted: Wed Mar 14, 2012 5:17    Post subject: Reply with quote
MrMan606 wrote:
I have it working ok on mine .. both monitor.html and user_details.js are located in /tmp/www

Then access it from here (change ip to your router) http://192.168.1.1/user/monitor.html

Try it and see it it helps


/tmp/www/ is also symlinked to /www/user/ Sad
but still http://192.168.1.1/user/monitor.html is blank..

Do you mind sharing your complete setup in a tar or zip?
I've downloaded the latest v1.2 script and the mypage version Jumran posted in mypage part deux.

Im trying to piece the 2 treads "mypage part deux" and this on together but there must be something im doing wrong

thanks
jumran
DD-WRT User


Joined: 31 Jul 2009
Posts: 492
Location: Toronto, ON, CA

PostPosted: Wed Mar 14, 2012 6:02    Post subject: Reply with quote
basmaf wrote:
MrMan606 wrote:
I have it working ok on mine .. both monitor.html and user_details.js are located in /tmp/www

Then access it from here (change ip to your router) http://192.168.1.1/user/monitor.html

Try it and see it it helps


/tmp/www/ is also symlinked to /www/user/ Sad
but still http://192.168.1.1/user/monitor.html is blank..

Do you mind sharing your complete setup in a tar or zip?
I've downloaded the latest v1.2 script and the mypage version Jumran posted in mypage part deux.

Im trying to piece the 2 treads "mypage part deux" and this on together but there must be something im doing wrong

thanks


The version of bandwidth script used in MyPage revision I posted is not from this thread.

See the following.

http://www.dd-wrt.com/phpBB2/viewtopic.php?t=75275

_________________
Asus RT-N16 [Build King Kong 18050M NEWD-2 K2.6 + Optware + My Page] Mr. Green
basmaf
DD-WRT Guru


Joined: 24 Feb 2011
Posts: 1043

PostPosted: Wed Mar 14, 2012 6:58    Post subject: Reply with quote
Thank you Jumran.

I guess that is the thread i'm looking for Very Happy
Will start from scratch using that as reference.
basmaf
DD-WRT Guru


Joined: 24 Feb 2011
Posts: 1043

PostPosted: Wed Mar 14, 2012 9:54    Post subject: Reply with quote
basmaf wrote:
Thank you Jumran.

I guess that is the thread i'm looking for Very Happy
Will start from scratch using that as reference.


It's working Very Happy
Problem was between shoes and the keyboard Embarassed
wooly
DD-WRT Novice


Joined: 06 May 2009
Posts: 29

PostPosted: Fri May 11, 2012 3:20    Post subject: Remove Users Reply with quote
Back home after a few months down south. Amazing how much I can forget in that time! but finally have BW_MON up and working again.


I need to take away a group of users who no longer live with us, I tried making the changes by editing the users.file and restarting bw_monitor but the deleted group remain on the display, what am I missing?

Thanks

Wooly
sle118
DD-WRT Novice


Joined: 30 Nov 2010
Posts: 5

PostPosted: Tue Jul 10, 2012 12:24    Post subject: Works for me, JFFS on USB Reply with quote
I'd like to thank everyone who contributed to this great tool.

Just wanted to share my own experience. With both my kids now on holiday, I saw a surge in internet bandwidth (>10Gb/day) usage that I wanted to understand better before pointing fingers. Twisted Evil

Because I am running a router that has limited nvram (RT-N16), I did the following:
    Enable JFFS2
    Move jffs on an external USB stick
    Instal bc (using the link to bc_1.06.94-1_mipsel.ipk found in the install instructions)
    Setup a cron job to jffs mounted on the USB stick


The cron job is an ugly hack because I could not figure out how to call the startup script only after the jffs partition was mounted and ready, a requirement for bc to work.

The only think that I have left to figure out is the error I get from this line
Code:
 nextDay=`date --date='next day' +"%d"`


If anyone has a solution for the broadcom chip, let me know.

On a side note, is there any way to get a breakdown of traffic per user/web site? This would add a tremendous degree of precision!
JohnyR
DD-WRT Novice


Joined: 08 Jul 2012
Posts: 6

PostPosted: Fri Jul 13, 2012 3:48    Post subject: Reply with quote
^

What I did was remove those lines completely. Here is what mine looks like:

Code:

#Determine next day number and force to num
  nextDay=`TZ=MST-24 date +"%d"`
   if [ $? -ne 0 ]; then
      #Attempt another way to determine the next day
      nextDay=`TZ=MST-24 date +"%d"`
   fi
   nextDay=`expr $nextDay '*' 1`



The problem that I'm having is that once I close my telnet client, the script stops logging. Any ideas?
JohnyR
DD-WRT Novice


Joined: 08 Jul 2012
Posts: 6

PostPosted: Sat Jul 14, 2012 18:59    Post subject: Reply with quote
scratch that. problem that I'm having now is the javascript file isnt getting written properly. it loads the first users details fine, but then after the next run, it just erases everything and only

"_todaysDay=14; var users=[]; _supportBit32=0;"

is left

ideas?
Goto page Previous  1, 2, 3 ... 29, 30, 31 ... 40, 41, 42  Next Display posts from previous:    Page 30 of 42
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum