[Fixed] Possibly bricked DIR-868L

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Author Message
DD-WRT Novice

Joined: 05 Jul 2016
Posts: 3

PostPosted: Tue Jul 05, 2016 3:33    Post subject: [Fixed] Possibly bricked DIR-868L Reply with quote

I believe I may have bricked my DIR-868L, HW:B1. After reading through the peacock thread and following the wiki instructions for my router, I attempted to flash the firmware given on the wiki page (dlink-dir868l, build 25974, 20150120). The D-Link page displayed an "install failed" error, which I realized was because the wiki was referring to HW A1 and I have B1 (it is a refurbished router). I found what I believe is the correct version (dir868l-revb, build 27147, 20150601), listed on the "Supported Devices" page, as the wiki page for the router does not reference version B at all.

I successfully flashed factory-to-ddwrt.bin. The router rebooted and I set a DD-WRT username and password. As per the wiki, the router does not support hard resets, and the wiki page says to use the "erase nvram" command instead. This is where I think I made a mistake - I did not erase nvram, and instead flashed dir-868-webflash.bin (with the reset to factory settings option enabled) Embarassed. The flash finished, and the router rebooted, but the webpage did not load again. The router is stuck booting. I have two cables connected: power, and ethernet in port 1 to my computer. The power LED is blinking orange (2 sec on / 1 sec off). After waiting around 5 minutes to see if it would finish booting, I tried pinging the router. I set up a static connection (IP, Mask, Gateway and ran "ping", which continually responded "From Destination Host Unreachable". I do not see any TTL messages, and ping has a 100% packet loss.

I have tried a hard reset (30-30-30), as well as power cycling my router (30 sec off) with ping running, and received no responses at all. My router has now been plugged in and powered on for over 25 minutes, and the power LED is repeating the same pattern with no ping response. I believe my router is bricked, but I am not knowledgeable enough to confirm this. I purchased the router very recently from a retail store, and they have kindly confirmed they will return the router as defective and exchange it for a new one. Should I pursue this, or are there any other steps I could take first?

One last question, if I exchange the router for a new one, are there any special steps I missed in flashing DD-WRT to this model (HW: B1, Refurbished DIR-868L) or was my mistake not waiting long enough/erasing nvram before flashing again? I would like to avoid the same issue occurring again if I try again with a new router but erase nvram in between flashes.

D-Link DIR-868L, HW Version A1 (on original label).
D-Link DIR-868L/RE, HW Version B1 (on sticker on top of label).

Version of DD-WRT:
dir868l-revb, build 27147, 20150601
Flashed factory-to-ddwrt.bin, successful.
Flashed dir-868-webflash.bin, failed.

Thank you!

Edit: Added [Fixed] tag to subject

Last edited by artifice57 on Wed Jul 06, 2016 21:13; edited 1 time in total

Joined: 23 Jul 2014
Posts: 1062
Location: BC, CA

PostPosted: Tue Jul 05, 2016 8:19    Post subject: Reply with quote
The DIR-868L wiki: http://www.dd-wrt.com/wiki/index.php/D-Link_DIR-868L doesn't specify the version so I suppose it is applicable to versions A1, B1 and C1 that dd-wrt supports. However, you have to use the correct version that match your router. So if your router is B1, you have to use B1 version dd-wrt firmware but not A1 or C1.

The Note as given on the wiki "Note: The router doesn't support Hard Reset (aka 30/30/30 reset), use the Erasing NVRAM method instead." means you shouldn't use 30/30/30 reset as it won't work in the same way as other Broadcom routers. Actually, as far as I know, 30/30/30 won't work on most if not all modern Broadcom routers.

The default router IP for dd-wrt is and the default router IP for router with stock D-Link firmware is

The router has a recovery mode which can be initiated during power up when you press and hold the reset button and plug in the power. Continue holding the reset button until the power LED blinks in amber (orange) and it should be in recovery mode. This mode allows you to flash back the stock firmware to the router in case it is bricked due to corrupted firmware upgrade.

If you are still with me, the next thing is to check and confirm if your router is indeed bricked. Without pressing the reset button, power up the router and see if the power LED is in solid green or blinking in amber.

If the power LED is in solid green, that means it is in good condition and boot up normally. Next is to confirm if it is running in stock firmware or dd-wrt firmware. Set your PC IP to automatic, i.e. it will get IP from the router. Connect your PC to the LAN port of the router. Start up command prompt and enter "ipconfig /all". If the PC's IP is 192.168.0.x that mean the router is running the stock firmware. On the other hand, if the IP is 192.168.1.x that mean the router is running the dd-wrt firmware.

If the power LED is blinking amber, then apparently the router is bricked. Power down the router and then follow the instructions as per this: http://forums.dlink.com/index.php?PHPSESSID=bsv59auamg75cv8ghfso2ets44&topic=44909.msg163599#msg163599 to recover your router to the stock firmware.

Good luck!
DD-WRT Novice

Joined: 05 Jul 2016
Posts: 3

PostPosted: Wed Jul 06, 2016 3:26    Post subject: Reply with quote
Thank you for your response! I will give those steps a try tomorrow, and post an update with my results Smile
DD-WRT Novice

Joined: 05 Jul 2016
Posts: 3

PostPosted: Wed Jul 06, 2016 21:12    Post subject: Router is working again, DD-WRT works Reply with quote
First off: it worked!

I attempted to boot the router into recovery mode, but did not notice any difference between the amber LED blinking after a normal boot and after the recovery boot. I changed my Ethernet settings to static again, just to double check, and the page ( would not load. After about 5 minutes, I checked again and saw the recovery screen. I downloaded the original firmware file for Rev B from http://tsd.dlink.com.tw/downloads2008.asp, which is the page I found by searching online for "DIR-868L Rev B Firmware" and looking through a post on a D-Link forum I found. The official D-Link support site only has firmware for Rev A listed, not B or C. It may be worth adding that link to the 868L Wiki page, since it is not obvious to find.

Flashing the original firmware worked, and the router booted normally. At this point, I was feeling more confident with restoring the router if the same thing happened again, so I retried flashing DD-WRT (dir868l-revb, build 27147, 20150601), this time with a "erase nvram; reboot" command in between flashes. Once again, factory-to-ddwrt.bin worked, but "dir868b-webflash.bin" made my router unable to boot. I recovered successfully, again using your instructions, and realized the router was actually booting itself into recovery mode without having to hold the reset button during boot.

I also noticed the wiki was updated since my original post, and now specifies the given instructions are only for rev a. Thank you to whoever updated it!

I then disregarded the advice of the peacock thread, fully aware I might actually brick my router, and tried the absolute newest version of DD-WRT (dir868l-revb, build 30082, 20160701) instead of the one listed on the wiki. I flashed factory-to-ddwrt.bin, let it boot, and ran "erase nvram; reboot" in the DD-WRT web interface. Then I applied a factory reset from the web interface. I flashed "dir868l-webflash.bin", waited, and it booted properly. I erased nvram and factory reset once more for good measure, and it is now working properly (with the exception of the power and network status LEDs being always amber).

I am not sure what the oldest version is that works, but I am very willing to experiment if it would help complete the wiki page for Rev B of this router for other people to use. If anyone wants to me try specific builds or detail the process I took further, please message me. For now, I can confirm build 30082 worked for me.

Thank you so much for your help js1662!
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT


Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum