Openwrt K on la Fonera without serial console...when DD-WRT?

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8, 9  Next
Author Message
..:Dude:..
DD-WRT Novice


Joined: 27 Jul 2007
Posts: 26

PostPosted: Fri Jul 27, 2007 15:48    Post subject: Reply with quote
Same Problem here.

Done this as a precaution if something go wrong with the freewlan.info patches:

root@OpenWRT:~# wget http://ipkg.k1k2.de/hack/openwrt-ar531x-2.4-vmlinux-CAMICIA.lzma
root@OpenWRT:~# mtd -e vmlinux.bin.l7 write openwrt-ar531x-2.4-vmlinux-CAMICIA.lzma vmlinux.bin.l7
root@OpenWRT:~# reboot

and then this.

root@OpenWRT:~# wget http://ipkg.k1k2.de/hack/out.hex
root@OpenWRT:~# mtd -e "RedBoot config" write out.hex "RedBoot config"
root@OpenWRT:~# reboot

Now after 10 seconds, i still can login to 192.168.1.254 and see the RedBoot Prompt. The Fonera is not booting normaly after the 10 seconds. Whats wrong ?

How can i fix this, or delete this RedBoot thing, so the Fonera is starting normaly, like bevor this RedBoot changes ?

Quote:
There I can reflash the whole device again or just do
Code:
RedBoot> fis load -l vmlinux.bin.l7
Image loaded from 0x80041000-0x80283085
RedBoot> exec

And after a while I can reconnect to 192.168.1.1...


This does not work for me...
Sponsor
Drake008
DD-WRT Novice


Joined: 03 Nov 2007
Posts: 9

PostPosted: Sat Nov 03, 2007 12:59    Post subject: Reply with quote
Well I'm standing here after the first three steps.

I did this:
Code:
cd /tmp
wget http://fonera.info/camicia/openwrt-ar531x-2.4-vmlinux-CAMICIA.lzma
mtd -e vmlinux.bin.l7 write openwrt-ar531x-2.4-vmlinux-CAMICIA.lzma vmlinux.bin.l7
reboot


But after that I cannot connect to the Fonera anymore. I tried the all of the recovering tips but I cannot get an answer.

Can someone help here?

I cannot on 192.168.1.10 anymore because there is no wireless connection.
ubergamer
DD-WRT Novice


Joined: 05 Dec 2007
Posts: 1

PostPosted: Wed Dec 05, 2007 20:24    Post subject: Reply with quote
Drake008 wrote:
Well I'm standing here after the first three steps.

I did this:
Code:
cd /tmp
wget http://fonera.info/camicia/openwrt-ar531x-2.4-vmlinux-CAMICIA.lzma
mtd -e vmlinux.bin.l7 write openwrt-ar531x-2.4-vmlinux-CAMICIA.lzma vmlinux.bin.l7
reboot


But after that I cannot connect to the Fonera anymore. I tried the all of the recovering tips but I cannot get an answer.

Can someone help here?

I cannot on 192.168.1.10 anymore because there is no wireless connection.


I am having the exact same problem.
I can only access the fonera through a max232 interface, no other recovery tips have worked.
How do you install dd-wrt using a serial console (hyperterminal) only?
Thanks for your help.
-Ubergamer
y000gy
DD-WRT Novice


Joined: 18 Mar 2007
Posts: 11

PostPosted: Wed Jan 16, 2008 17:25    Post subject: Reply with quote
everythinn went good till i typed
fis load -l vmlinux.bin.l7

redboot said something with cant load...free space...
coldtobi
DD-WRT Novice


Joined: 23 Jan 2008
Posts: 1

PostPosted: Wed Jan 23, 2008 16:14    Post subject: Reply with quote
I made a small howto for updating the redboot-configuration without making it unbootable.

http://blog.coldtobi.de ( under Category La Fonera)
Sash
DD-WRT Guru


Joined: 20 Sep 2006
Posts: 17494
Location: Hesse/Germany

PostPosted: Mon Jun 23, 2008 17:05    Post subject: Reply with quote
hej fonera guys

i have massive probs with debricking a fon 2100 after a bad ddwrt flash.

i connect to the bricked device at startup with

Code:
telnet 192.168.1.254 9000


and i see redboot comming up

Code:
== Executing boot script in 9.000 seconds - enter ^C to abort

but if i sent "strg+c" (^C) the redboot countdown wouldnt stop and the device tries to but.

is there something i forgot Question Exclamation

_________________
Forum Guidelines...How to get help
&
Forum Rules
&
RTFM/STFW
&
Throw some buzzwords into the WIKI search Exclamation
_________________
I'm NOT rude, just offer pure facts!
_________________
Atheros (TP-Link & Clones, etc ) debrick service in EU
_________________
Guide on HowTo be Safe, Secure and Protect Your Online Anonymity!
wikking
DD-WRT User


Joined: 23 Jun 2006
Posts: 243
Location: Dresden

PostPosted: Mon Jun 23, 2008 17:19    Post subject: Reply with quote
if i remember correctly it is telnet that's the problem. use putty or some other client and it should work. there is a faq in the german section...should also solve your problem.

cheers
Sash
DD-WRT Guru


Joined: 20 Sep 2006
Posts: 17494
Location: Hesse/Germany

PostPosted: Mon Jun 23, 2008 18:50    Post subject: Reply with quote
ok got it. it is realy a telnet problem but the funni thing is that my main system is opensuse and there its also not working. this had confused me Cool so i sthink its a redboot problem. my other redboot devices are woking with linux telnet.

so the second thing is. does sombody has a state of the art and ready to flash redboot + config for me

i have a fon2100 the old one with the heatsink on the soc.

btw: this topic should be moved Exclamation

_________________
Forum Guidelines...How to get help
&
Forum Rules
&
RTFM/STFW
&
Throw some buzzwords into the WIKI search Exclamation
_________________
I'm NOT rude, just offer pure facts!
_________________
Atheros (TP-Link & Clones, etc ) debrick service in EU
_________________
Guide on HowTo be Safe, Secure and Protect Your Online Anonymity!
darthboy
DD-WRT User


Joined: 14 Jan 2008
Posts: 237

PostPosted: Mon Jun 23, 2008 22:24    Post subject: Reply with quote
http://www.fonerahacks.com has the relevant guides and links to needed files.
_________________
RT-AC66U (asuswrt-merlin 374.43)
WHR-HP-G54 (dd-wrt v24 sp1 vpn-9994)
Sash
DD-WRT Guru


Joined: 20 Sep 2006
Posts: 17494
Location: Hesse/Germany

PostPosted: Tue Jun 24, 2008 16:40    Post subject: Reply with quote
cant find it there...
_________________
Forum Guidelines...How to get help
&
Forum Rules
&
RTFM/STFW
&
Throw some buzzwords into the WIKI search Exclamation
_________________
I'm NOT rude, just offer pure facts!
_________________
Atheros (TP-Link & Clones, etc ) debrick service in EU
_________________
Guide on HowTo be Safe, Secure and Protect Your Online Anonymity!
darthboy
DD-WRT User


Joined: 14 Jan 2008
Posts: 237

PostPosted: Wed Jun 25, 2008 5:23    Post subject: Reply with quote
Sash wrote:
cant find it there...


oops. I read your post wrongly. Is the 196kb Redboot.bin what you need?

http://www.dd-wrt.com/phpBB2/viewtopic.php?t=30305&postdays=0&postorder=asc&start=60

_________________
RT-AC66U (asuswrt-merlin 374.43)
WHR-HP-G54 (dd-wrt v24 sp1 vpn-9994)
killedfon
DD-WRT Novice


Joined: 18 Jul 2008
Posts: 2

PostPosted: Fri Jul 18, 2008 20:49    Post subject: killed fon with redboot-step :-( Reply with quote
Hi guys,

I fear that I killed my fon. I tried hacking it, and it worked, until step 4 of the tutorial http://www.dd-wrt.com/wiki/index.php/La_Fonera_Flashing

I was a fool, I connected via SSH, which worked perfectly. Afterwards, I copied the following lines to my SSH shell:
Code:

cd /tmp
wget http://fonera.info/camicia/out.hex
mtd -e "RedBoot config" write out.hex "RedBoot config"
reboot


Unfortunately, I had no network connection at this time and so there was no out.hex. I am not sure what happens without the out.hex, but it is definitely not good Sad
Any possibility to save my fon?

At the moment, only the power led is on. If I connect a lan cable, the Internet-led is on and blinking alternately. Resetting doesn't work anymore.
Any ideas except connecting a serial cable which I don't have? I tried several addresses (192.168.10.*,192.168.1.*,169.254.255.*) on my laptop, tried pinging the fon, but no response Sad

thanks
peda
Sash
DD-WRT Guru


Joined: 20 Sep 2006
Posts: 17494
Location: Hesse/Germany

PostPosted: Fri Jul 18, 2008 22:33    Post subject: Reply with quote
if you didnt have a ethernet connection the wget command was interrupted by a error message.
the hex file wont exist locally so ther were also a error message. so from my point of few the fon should be alive

_________________
Forum Guidelines...How to get help
&
Forum Rules
&
RTFM/STFW
&
Throw some buzzwords into the WIKI search Exclamation
_________________
I'm NOT rude, just offer pure facts!
_________________
Atheros (TP-Link & Clones, etc ) debrick service in EU
_________________
Guide on HowTo be Safe, Secure and Protect Your Online Anonymity!
killedfon
DD-WRT Novice


Joined: 18 Jul 2008
Posts: 2

PostPosted: Sat Jul 19, 2008 13:49    Post subject: redboot Reply with quote
Hm, ok, maybe I didn't explain myself clearly enough.

I had a ethernet cable plugin in, but I had no working DNS settings, so the fon could resolve the url with the out.hex-file and the wget command failed. What happened was, that the following command was executed without any out.hex:

mtd -e "RedBoot config" write out.hex "RedBoot config"

Unfortunately, I don't remember if there was an error message after this command. The reboot command was executed directly after the above command and now I have no idea about the state of my fon.
blackman
DD-WRT Novice


Joined: 08 Dec 2008
Posts: 1

PostPosted: Mon Dec 08, 2008 22:25    Post subject: Reply with quote
After the first ssh step I think my fonera is briked. I had a classic 0.7.1r1 firmware, ssh with the method of step1 and step2 and then I have uploaded the camicia file to the fonera, applied and rebooted

Code:

cd /tmp
wget http://fonera.info/camicia/openwrt-ar531x-2.4-vmlinux-CAMICIA.lzma
mtd -e vmlinux.bin.l7 write openwrt-ar531x-2.4-vmlinux-CAMICIA.lzma vmlinux.bin.l7
reboot


And stop.
Never booted again.

What can I do ?
Why this stopped (to other users too, as I can read)
The only method to have my fonera again is the cable? (I have tested software methods but nothing)

Thanks, Federico
Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8, 9  Next Display posts from previous:    Page 8 of 9
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum