NEWD or VINT

From DD-WRT Wiki

Jump to: navigation, search


More recent wireless drivers are not compatible with older radio chipsets, so dd-wrt builds are made available in two different flavors for backwards compatibility with older routers.

[edit] Which Build, NEWD or VINT?

If you have an older router, you might need to run a VINT build. VINT builds use an older wireless driver which is more compatible with the radio chipsets of Broadcom 4710 and 4712 CPUs. More recent routers using 4704, 4785, 5354 or 5365 CPUs should run the standard builds, sometimes labeled NEWD (NEW Driver)

To be sure of which version to install, check your router's wireless core revision. To view this, telnet into your router and run the following command. The value returned after wl0_corerev is the number you're looking for.

nvram get wl0_corerev
  • wl0_corerev is Eight and higher
Flash with standard NEWD builds
  • wl0_corerev is Five through Seven
Flash with either build. VINT typically works better and is required to create virtual interfaces in AP mode.
  • wl0_corerev is Four and lower
Flash with VINT builds

[edit] Notes

DO NOT run NEWD on WRT54G v1.0 routers! Only install VINT builds. If you flash a NEWD build onto a v1.0 you will brick the router.

The command nvram get wl0_corerev can also be run from dd-wrt's GUI on the Administration->Commands tab.

[edit] Related Topics

Which V24 build do I flash onto my Broadcom router?