Talk:LaFonera Software Flashing

From DD-WRT Wiki

Jump to: navigation, search

[edit] Feb 18, 2007 - My edits

I found this HowTo very helpful, but also in dire need of clarification and editing. So, after I successfully flashed mine, I made the changes that I felt would make this far easier to follow, and better organized. Nothing has been removed, only a slight reordering, and the addition of the list of "ingredients" at the beginning, and some formatting. As I look at it again, I need to do some tweaks for consistency. Thanks all. :)

[edit] Apr 10, 2007 - Helpful info

I found this to be a useful how to, however, I either missed a step, or had something corrupted in my initial patch to gain full time SSH access, because afterward La Fonera would not completely boot. I searched high and low for what to do. I reflashed several times. I tried the reset NVRAM step multiple times. Nothing allowed the unit to completely reboot. It always aborted the RedBoot process and left me sitting there. Believe me, I waited and waited on the unit to completely boot, and it never did. As I searched for some answer to this problem, I found that I was not alone. Many others had posted similar problems. I broadened my scope and searched deeper.

So, as part of my quest to find the problem, I decided to search for RedBoot configuration information. In my quest, I came across the information with command syntax for the RedBoot process.

I found this page first: Can I change 'RedBoot Config' using MTD driver.?

It didn't help me, but, it did clue me to look further. Next came this page: RedBoot Commands and Examples

Again, this came closer, but, not close enough.

Lastly, came this page: Persistent State Flash-based Configuration and Control

Couple the information here for fconfig, I saw that there was no boot script for my RedBoot. So, I pasted in the load and exec commands from the Reset NVRAM section of this how to, and set my boot timer to 10 seconds to give me ample time to catch the RedBoot if I needed to get low level access and all was right as rain.

To sum up, if you're experiencing problems getting RedBoot to completely boot the firmware, spend some time at the home of RedBoot and you may learn what you need to get things back in order again. RedBoot

[edit] Apr 24, 2007 - Some Critique

This did not work for me, so I cannot edit this page. But here are some suggestions to the original author(s):

"Standard gateway to:" is nonsense: the standard gateway must be inside the local subnet (otherwise there would be no route to it!), and because we are only contacting an ip adress inside the local subnet (, we don't need a gateway anyway.

"DNS:" is nonsense, too (it already says that it's "optional"). DNS is not needed here, and is outside our subnet, and we don't have a route there.

What do you mean by "When your computer gets an ipadress press the "Open" button in Putty"? What means "gets an ipadress" here? I really don't know what that should mean.

-- mintar