about IPv6 config on Wiki

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Advanced Networking
Author Message
timenetworks
DD-WRT Novice


Joined: 23 Apr 2011
Posts: 2

PostPosted: Sat Apr 23, 2011 16:18    Post subject: about IPv6 config on Wiki Reply with quote
First time to post here, hope I am posting in the correct area.

I have found that some of the configuration in the post of DD-WRT's wiki which talk about IPv6 with HE tunnel broker (http://www.dd-wrt.com/wiki/index.php/IPv6#6to4_Setup). I would like to edit it, but I can't, so I am posting here.

It seems that the route configuration is incorrect and that cause only one host under the HE provided network can access the network.

I am suggesting a "correct" configuration here which is now working for me.

the original configuration :



Code:
# These commands aren't on HE's website, but they're necessary for the tunnel to work
ip -6 addr add $MY_ROUTED_ADDR/64 dev he-ipv6
ip -6 addr add $MY_ROUTED_ADDR/64 dev br0
ip route add 2000::/3 dev he-ipv6


it should be replace with
Code:
ip -6 addr add $MY_ROUTED_ADDR/64 dev br0


the original version will cause a loop because it try to send packet back to the tunnel but not to host



sorry for my poor English, and I will try to edit this post if I found any problem. Thank You.
Sponsor
fnord42
DD-WRT Novice


Joined: 12 Jan 2011
Posts: 12

PostPosted: Mon Apr 25, 2011 9:05    Post subject: Reply with quote
There's a spam problem, you've to request an account (if you don't have one) http://www.dd-wrt.com/phpBB2/viewtopic.php?t=89976

I lately cleaned up parts of the that page myself for SixXS (that's what I'm using). It's a bit harder to clean up other parts when you did not try it out yourself.
I'm pretty sure that the 'insmod ipv6' and following 'sleep' command are superflous aswell for recent IPv6 enabled builds.

After all adding the same address, $MY_ROUTED_ADDR, on two interfaces can't be right. I'm not sure what the intention was. Do you get a subnet assigned and you've to add one IP out of it to your internal interface (that would be br0 then) to do stateless autoconfiguration with radvd?

Anyway I've added a warning with a link to this thread, maybe we can sort that out.
timenetworks
DD-WRT Novice


Joined: 23 Apr 2011
Posts: 2

PostPosted: Mon Apr 25, 2011 11:37    Post subject: Reply with quote
Thank you for your hints.

actually, I have already applied the correct setting in my dd-wrt router. I have assigned the routed address to my br0 interface ONLY. And a default IPv6 route to the tunnel. There are no additional route added to the route table.

I haven't test for removing insmod ipv6 or other module.

I have also found that some of the module are missing and I need to manually install them.
fnord42
DD-WRT Novice


Joined: 12 Jan 2011
Posts: 12

PostPosted: Mon Apr 25, 2011 13:17    Post subject: Reply with quote
Well I won't edit it any further but my guess is that it's intended to by something like
Code:

2001:DB8::0/64 for the HEnet interface
2001:DB8::1/64 for the internal br0


It's listed in a similar way in the 'another approach' example. At least that makes sense to me.

Fun fact: You should really start to number your network at the :0000 address because otherwise you might run into funny race conditions when someone else places a bogus or even malicious router in your network and announces itself as a router with the :0000 IP - some IPv6 stacks prefer the lowest IP in those cases (vanHauser mentioned that in one of his talk at the CCC).
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Advanced Networking All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum