TP-Link Archer C9 v3? (EU)

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page Previous  1, 2, 3, 4, 5, 6, 7  Next
Author Message
tmash2
DD-WRT Novice


Joined: 13 Oct 2017
Posts: 6

PostPosted: Fri Oct 13, 2017 7:58    Post subject: Reply with quote
Hello,

Thanks alot Brainslayer for the firmware, for some reason after enabling jffs2 and rebooting by poweroff/poweron, my router seems to be bricked with wps led on.
Tftp via reset button at 192.168.0.66 works, and I can upload firmware but I guess I need stripped fw for it to work. Im not sure how enabling jffs2 bricked the device, just fyi I powercycled without issues before enabling this option.
I'm also unsure if I should return it (still covered by warranty) or connect serial port to diagnose further.

Thanks
Sponsor
Paris17
DD-WRT Novice


Joined: 29 Jun 2015
Posts: 4

PostPosted: Fri Oct 13, 2017 10:49    Post subject: Reply with quote
tmash2 wrote:
Hello,

Tftp via reset button at 192.168.0.66 works, and I can upload firmware but I guess I need stripped fw for it to work.


The Archer C9 V3 supports webpage firmware recovery method:
http://www.tp-link.com/us/faq-1482.html
tmash2
DD-WRT Novice


Joined: 13 Oct 2017
Posts: 6

PostPosted: Sat Oct 14, 2017 6:32    Post subject: Reply with quote
Paris17 wrote:
tmash2 wrote:
Hello,

Tftp via reset button at 192.168.0.66 works, and I can upload firmware but I guess I need stripped fw for it to work.


The Archer C9 V3 supports webpage firmware recovery method:
http://www.tp-link.com/us/faq-1482.html


Thanks alot, didn't know this.
Now whenever I upload the proper firmware (hw is 3.0/eu) I get Firmware upgrade failed.
In the screenshot, I changed the filename as a last attempt so I tried without renaming anything first.
BrainSlayer
Site Admin


Joined: 06 Jun 2006
Posts: 6784
Location: Dresden, Germany

PostPosted: Sun Oct 15, 2017 9:18    Post subject: Reply with quote
wrong file. use factory-to-ddwrt.bin


edit: sorry just have seen that you try to recover. mmh hard to say whats wrong here. need to look on the serial console

_________________
one cigarette costs 2 minutes of your life.
one bottle of beer costs 4 minutes of your life.
one working day costs 8 hours of your life.

Yummee:
Linux DD-WRT 4.14.8 #42 SMP PREEMPT Thu Dec 21 18:11:16 CET 2017 armv7l DD-WRT
root@DD-WRT:/sys# nvram get DD_BOARD
Netgear R7800


Last edited by BrainSlayer on Sun Oct 15, 2017 9:22; edited 1 time in total
BrainSlayer
Site Admin


Joined: 06 Jun 2006
Posts: 6784
Location: Dresden, Germany

PostPosted: Sun Oct 15, 2017 9:19    Post subject: Reply with quote
tmash2 wrote:
Hello,

Thanks alot Brainslayer for the firmware, for some reason after enabling jffs2 and rebooting by poweroff/poweron, my router seems to be bricked with wps led on.
Tftp via reset button at 192.168.0.66 works, and I can upload firmware but I guess I need stripped fw for it to work. Im not sure how enabling jffs2 bricked the device, just fyi I powercycled without issues before enabling this option.
I'm also unsure if I should return it (still covered by warranty) or connect serial port to diagnose further.

Thanks



cannot check it much its a blind port since i dont have the device. send me a dmesg output please

_________________
one cigarette costs 2 minutes of your life.
one bottle of beer costs 4 minutes of your life.
one working day costs 8 hours of your life.

Yummee:
Linux DD-WRT 4.14.8 #42 SMP PREEMPT Thu Dec 21 18:11:16 CET 2017 armv7l DD-WRT
root@DD-WRT:/sys# nvram get DD_BOARD
Netgear R7800
tmash2
DD-WRT Novice


Joined: 13 Oct 2017
Posts: 6

PostPosted: Sun Oct 15, 2017 21:17    Post subject: Reply with quote
BrainSlayer wrote:
tmash2 wrote:
Hello,

Thanks alot Brainslayer for the firmware, for some reason after enabling jffs2 and rebooting by poweroff/poweron, my router seems to be bricked with wps led on.
Tftp via reset button at 192.168.0.66 works, and I can upload firmware but I guess I need stripped fw for it to work. Im not sure how enabling jffs2 bricked the device, just fyi I powercycled without issues before enabling this option.
I'm also unsure if I should return it (still covered by warranty) or connect serial port to diagnose further.

Thanks



cannot check it much its a blind port since i dont have the device. send me a dmesg output please


Not a dmesg as it does not boot, only boots to recovery (apparently corrupted partition table thus auto reboot to recovery?)

*** command status = -1
CFE> ifconfig
Device eth0: hwaddr 50-C7-BF-0
CFE>
CFE>
CFE>
CFE> Reading Partition Table from NVRAM ... OK
Parsing Partition Table ... [NM_Error](nm_lib_parsePtnIndexFile) 00545: invalid partition-index-file para id.
FAILED
[NM_Error](nm_tpFirmwareCheck) 01341: Init failed.


This is what I get on serial after i press upgrade and fails at 40%. Sad
Thanks for the response and help!

Edit: Tried CFE recovery to flash, all went well, rebooted, router is probably dead, internet led is red, home and 5ghz led on, not responding to serial, turns on like that instantly.

I can do jtag (not my first time), though unsure where to go from here. Router is no longer under warranty now hehe, but I hope this was useful for others. I'm probably stupid since I messed with the flash tool before waiting instructions from experienced people.
I'll probably revive this later once someone provide me a full flash dump to recover via jtag maybe?
(As a sidenote, I was never satisfied with this router anyways, poor performance for the specs, very sh*tty stock firmware (not even mdns), have to restart every week, so I'm not feeling any "loss" here)

PSA:
NEVER ENABLE JFFS2 OPTION FOLKS!!

Thanks all.
mcalr3
DD-WRT Novice


Joined: 10 Oct 2017
Posts: 5

PostPosted: Mon Oct 16, 2017 22:20    Post subject: Reply with quote
Brainslayer, do you have the bin file of how to return to stock with this router? I am getting poor speeds on 5ghz and actually found that the stock was rock solid and allowed me to connect to my L2TP VPN so is good enough for now.

I tried googling how to produce a stripped bin file for v3 to no avail.

Cheers
adises
DD-WRT Novice


Joined: 28 Apr 2010
Posts: 6

PostPosted: Tue Oct 17, 2017 2:02    Post subject: Reply with quote
UPDATE: I Flashed ( https://download1.dd-wrt.com/dd-wrtv2/downloads/betas/2017/10-17-2017-r33525/tplink_archer-c9v3/archer-c9v3-webflash.bin ) and I'm happy to report that my C9 v3 (EU) is working fine so far.

Last edited by adises on Wed Oct 18, 2017 3:29; edited 1 time in total
tosiara
DD-WRT User


Joined: 20 Dec 2011
Posts: 89

PostPosted: Tue Oct 17, 2017 14:32    Post subject: Reply with quote
I'm also interested and subscribed
By the way, TP-Link provides "GPL code" which even includes binary toolchain for building:

http://static.tp-link.com/resources/gpl/GPL_C9v5_EU_20170110.tar.gz

Code:

1. This package contains all GPL code used by TP-LINK Routers/APs with Linux OS.
2. All components have been built successfully on Redhat Enterprise Linux 5.0 Workstation.
3. Compiling components in this package on platforms other than Redhat Enterprise Linux 5.0 Workstation may have unexpected results.
4. Recommended using "root" or "sudo" command to build the code.
5. After building code, you can get linux kernel image, then you can make rootfs with mksquashfs tool, but you can't upgrade these images to your router through web management page.

Build Instructions
1. All build targets are in ~/GPL_Code/build/Makefile, you should enter this directory to build components.
2. Pre-built toolchain is avaliable in this package.
3. Toolchain (include uclibc) source code is avaliable in toolchain_src.
4. Prepare Pre-built toolchain, tools and filesystem: 
make linux_build_prep

5. Build core components:(includes linux kernel, kernel modules and some applications)
make linux_build_all

6. Install binary and libs
make install

7. Build root fs:
make image

Note: please build the GPL codes following the order(1-7), otherwise it has risk to compile error.

tmash2
DD-WRT Novice


Joined: 13 Oct 2017
Posts: 6

PostPosted: Sun Oct 22, 2017 11:22    Post subject: Reply with quote
mcalr3 wrote:
Brainslayer, do you have the bin file of how to return to stock with this router? I am getting poor speeds on 5ghz and actually found that the stock was rock solid and allowed me to connect to my L2TP VPN so is good enough for now.

I tried googling how to produce a stripped bin file for v3 to no avail.

Cheers


My advice is to avoid, its better to have functional router than a dead one. If you happen to touch anything related to the nvram partition, its a brick. (restoring wont even help without stock calibration image, not sure about interchanging from other units) But there hasn't been any successful attempt sadly. It wouldn't have hurt to post a warning about that, or even "enabling jffs2 will corrupt the partition table and data", I understand the risks, but having these warning would actually help... Something like [EXPERIMENTAL] Image not ready for usage, instead of beta or unstable software, as this is low level. Equivalent to uploading an image that intentionally damage the flash partition for example while understanding the irreversible damage on this specific router unlike most other routers (having used ddwrt/openwrt on many routers)

P.S: On my side 2.4ghz has better throughput on ddwrt, higher tx limit, and longer range unless you have congested Wifi area and in need of 5ghz.
elerion
DD-WRT Novice


Joined: 29 Oct 2017
Posts: 6

PostPosted: Wed Nov 01, 2017 9:21    Post subject: Reply with quote
I have exectly the same issue with c9 v3 as tmash2.
Same cause (enabling jffs2).

I'm open to sugestions.
Send it to service through retailer?
Open it and try to restore it through serial port?
Or just buy a new router and trash this one as it's beyond repair?

EDIT:
Connected serial, download and flash from tftp works, but still unable to make it work. I guess I don't have full firmware to restore it with.

Console output:

Reading Partition Table from NVRAM ... OK
Parsing Partition Table ... [NM_Error](nm_lib_parsePtnIndexFile) 00545: invalid partition-index-file para id.
FAILED
[NM_Error](nm_api_checkInteger) 00322: factory boot check integer partition init fail.
tosiara
DD-WRT User


Joined: 20 Dec 2011
Posts: 89

PostPosted: Thu Nov 02, 2017 10:24    Post subject: Reply with quote
Is there a bug for this issue?
tmash2
DD-WRT Novice


Joined: 13 Oct 2017
Posts: 6

PostPosted: Fri Nov 03, 2017 13:50    Post subject: Reply with quote
tosiara wrote:
Is there a bug for this issue?

Yeah maybe when we stop lying
tosiara
DD-WRT User


Joined: 20 Dec 2011
Posts: 89

PostPosted: Fri Nov 03, 2017 13:58    Post subject: Reply with quote
http://svn.dd-wrt.com/ticket/6037
qpo
DD-WRT Novice


Joined: 06 Nov 2017
Posts: 1

PostPosted: Mon Nov 06, 2017 13:11    Post subject: How to restore partition-index-file para id ? Reply with quote
I got exactly the same issue with Archor C9 v3 in same cause (enabling JFFS2).

I have sucessfully connected via serial, and got an CFE error:

Code:
Device eth0:  hwaddr 70-4F-57-31-23-B4, ipaddr 192.168.0.1, mask 255.255.255.0
        gateway not set, nameserver not set
Reading Partition Table from NVRAM ... OK
Parsing Partition Table ... [NM_Error](nm_lib_parsePtnIndexFile) 00545: invalid partition-index-file para id.
FAILED
[NM_Error](nm_api_checkInteger) 00322: factory boot check integer partition init fail.
Device eth0:  hwaddr 70-4F-57-31-23-B4, ipaddr 192.168.0.1, mask 255.255.255.0
        gateway not set, nameserver not set


When I have connected remote TFTP server, I can see that CFE firmware has downloaded official *.bin file - so CFE firmware in TFTP subroutine works well.

Unfortunately after flash original firmware I have got the same Partition Table error. Its look like DD-WRT JFFS option damage partition table.

Is there manual way to restore NVRAM partition ?
Goto page Previous  1, 2, 3, 4, 5, 6, 7  Next Display posts from previous:    Page 3 of 7
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum